aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/polygraph
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-09 19:40:56 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-09 19:40:56 +0000
commitfc3bdd2b5bc1f418653dc07e3f7734890f957654 (patch)
tree92b61da7299fce780376b4e14bfa865c591ecd98 /benchmarks/polygraph
parent4c1494aefa5bfa8ca125e5950e2f5180df24d8c0 (diff)
downloadports-fc3bdd2b5bc1f418653dc07e3f7734890f957654.tar.gz
ports-fc3bdd2b5bc1f418653dc07e3f7734890f957654.zip
benchmarks/polygraph: Handle missing SSLv3
Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=421634
Diffstat (limited to 'benchmarks/polygraph')
-rw-r--r--benchmarks/polygraph/Makefile2
-rw-r--r--benchmarks/polygraph/files/patch-src_xstd_Ssl.cc14
2 files changed, 15 insertions, 1 deletions
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index cae6e8c779dc..3d41659cd661 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -35,7 +35,7 @@ LDNS_LIB_DEPENDS= libldns.so:dns/ldns
LDNS_CONFIGURE_ON= --with-ldns=${LOCALBASE}/bin/ldns-config
LDNS_CONFIGURE_OFF= --without-ldns
SSL_DESC= SSL/HTTPS support
-SSL_USE= openssl=yes
+SSL_USES= ssl
SSL_CONFIGURE_ON= --with-ssl=${OPENSSLBASE}
SSL_CONFIGURE_OFF= --without-ssl
PERL_DESC= Install Perl for PolyGraph tools
diff --git a/benchmarks/polygraph/files/patch-src_xstd_Ssl.cc b/benchmarks/polygraph/files/patch-src_xstd_Ssl.cc
new file mode 100644
index 000000000000..2a0872db65e2
--- /dev/null
+++ b/benchmarks/polygraph/files/patch-src_xstd_Ssl.cc
@@ -0,0 +1,14 @@
+--- src/xstd/Ssl.cc.orig 2014-10-22 23:22:22 UTC
++++ src/xstd/Ssl.cc
+@@ -38,9 +38,11 @@ SslCtx::SslCtx(SslProtocol protocol, con
+ case TLSv1:
+ theCtx = ::SSL_CTX_new(::TLSv1_method());
+ break;
++#ifndef OPENSSL_NO_SSL3
+ case SSLv3:
+ theCtx = ::SSL_CTX_new(::SSLv3_method());
+ break;
++#endif
+ case SSLv23:
+ theCtx = ::SSL_CTX_new(::SSLv23_method());
+ break;