aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/scimark2c
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-29 03:41:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-29 03:41:04 +0000
commit7879afde70fadfbfcc68d27af6030499b392e25f (patch)
tree2b39dd7e8281896b89da74716e9d015935bead88 /benchmarks/scimark2c
parent591f3672b85bb20293b596856db83fc24f50ffcb (diff)
downloadports-7879afde70fadfbfcc68d27af6030499b392e25f.tar.gz
ports-7879afde70fadfbfcc68d27af6030499b392e25f.zip
New port: benchmarks/scimark2c - an ANSI C version of the SciMark2 benchmark.
This is an ANSI C version of the SciMark2 benchmark, translated from the original Java sources. The intent in making this benchmark available in C is mainly for performance comparisons. Suggested by May Tho. PR: ports/50646 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=87950
Diffstat (limited to 'benchmarks/scimark2c')
-rw-r--r--benchmarks/scimark2c/Makefile43
-rw-r--r--benchmarks/scimark2c/distinfo1
-rw-r--r--benchmarks/scimark2c/files/patch-Makefile13
-rw-r--r--benchmarks/scimark2c/files/patch-scimark2.c11
-rw-r--r--benchmarks/scimark2c/pkg-descr7
-rw-r--r--benchmarks/scimark2c/pkg-plist1
6 files changed, 76 insertions, 0 deletions
diff --git a/benchmarks/scimark2c/Makefile b/benchmarks/scimark2c/Makefile
new file mode 100644
index 000000000000..d24651f764f5
--- /dev/null
+++ b/benchmarks/scimark2c/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: scimark2c
+# Date created: Sat Apr 05 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= scimark2c
+PORTVERSION= 2.0
+CATEGORIES= benchmarks
+MASTER_SITES= http://math.nist.gov/scimark2/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= thierry@pompo.net
+COMMENT= An ANSI C version of the SciMark2 benchmark
+
+WRKSRC= ${WRKDIR}
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+MALLOC2STD= kernel.c Stopwatch.c Random.c array.c
+
+post-patch:
+.for file in ${MALLOC2STD}
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" ${WRKSRC}/${file}
+.endfor
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/scimark2 ${PREFIX}/bin
+
+post-install:
+ @${ECHO} "*****************************************************************************"
+ @${ECHO} ""
+ @${ECHO} " Just run scimark2 or scimark2 -large"
+ @${ECHO} ""
+ @${ECHO} " The first SciMark number reported is the composite score, followed by the an"
+ @${ECHO} " approximate Mflop rate for each kernel."
+ @${ECHO} ""
+ @${ECHO} " You may try to hack CC or CFLAGS in /etc/make.conf..."
+ @${ECHO} ""
+ @${ECHO} "*****************************************************************************"
+
+.include <bsd.port.mk>
diff --git a/benchmarks/scimark2c/distinfo b/benchmarks/scimark2c/distinfo
new file mode 100644
index 000000000000..52d0c5dd9905
--- /dev/null
+++ b/benchmarks/scimark2c/distinfo
@@ -0,0 +1 @@
+MD5 (scimark2c.zip) = 3fe0d6b3c8068bf7481ce45fe51d96d0
diff --git a/benchmarks/scimark2c/files/patch-Makefile b/benchmarks/scimark2c/files/patch-Makefile
new file mode 100644
index 000000000000..0255950e5def
--- /dev/null
+++ b/benchmarks/scimark2c/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Jul 6 00:07:45 2000
++++ Makefile Sat Apr 5 22:53:49 2003
+@@ -5,8 +5,8 @@
+
+ all: scimark2
+
+-CC = cc
+-CFLAGS = -O
++#CC = cc
++#CFLAGS = -O
+ LDFLAGS =
+
+ OBJS = FFT.o kernel.o Stopwatch.o Random.o SOR.o SparseCompRow.o \
diff --git a/benchmarks/scimark2c/files/patch-scimark2.c b/benchmarks/scimark2c/files/patch-scimark2.c
new file mode 100644
index 000000000000..e28bade3b163
--- /dev/null
+++ b/benchmarks/scimark2c/files/patch-scimark2.c
@@ -0,0 +1,11 @@
+--- scimark2.c.orig Sat Apr 29 06:21:12 2000
++++ scimark2.c Sat Apr 5 23:13:45 2003
+@@ -58,7 +58,7 @@
+
+
+ print_banner();
+- printf("Using %10.2f seconds min time per kenel.\n", min_time);
++ printf("Using %10.2f seconds min time per kernel.\n", min_time);
+
+ res[1] = kernel_measureFFT( FFT_size, min_time, R);
+ res[2] = kernel_measureSOR( SOR_size, min_time, R);
diff --git a/benchmarks/scimark2c/pkg-descr b/benchmarks/scimark2c/pkg-descr
new file mode 100644
index 000000000000..5be647243fbb
--- /dev/null
+++ b/benchmarks/scimark2c/pkg-descr
@@ -0,0 +1,7 @@
+This is an ANSI C version of the SciMark2 benchmark, translated from the
+original Java sources. The intent in making this benchmark available in
+C is mainly for performance comparisons.
+
+Results of this benchmark can be sent to pozo@nist.gov.
+
+WWW: http://math.nist.gov/scimark2/download_c.html
diff --git a/benchmarks/scimark2c/pkg-plist b/benchmarks/scimark2c/pkg-plist
new file mode 100644
index 000000000000..97c242e9934c
--- /dev/null
+++ b/benchmarks/scimark2c/pkg-plist
@@ -0,0 +1 @@
+bin/scimark2