aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/siege
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-05-25 18:34:50 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-05-25 18:34:50 +0000
commit13e3c6bdcdb5250547b84e04f52b949afebc52ef (patch)
tree245787bfe9ed56718abc22289b42d0bf6ab60fb7 /benchmarks/siege
parent7e86306982027377c1d1f80ccfaf840a77b2ec8b (diff)
downloadports-13e3c6bdcdb5250547b84e04f52b949afebc52ef.tar.gz
ports-13e3c6bdcdb5250547b84e04f52b949afebc52ef.zip
Properly call freehostent()
PR: ports/168336 Approved by: maintainer <bapt@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=297452
Diffstat (limited to 'benchmarks/siege')
-rw-r--r--benchmarks/siege/Makefile1
-rw-r--r--benchmarks/siege/files/patch-src-sock.c22
2 files changed, 16 insertions, 7 deletions
diff --git a/benchmarks/siege/Makefile b/benchmarks/siege/Makefile
index 615fc27a42b9..5ec8faf79dfb 100644
--- a/benchmarks/siege/Makefile
+++ b/benchmarks/siege/Makefile
@@ -7,6 +7,7 @@
PORTNAME= siege
PORTVERSION= 2.70
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= ftp://sid.joedog.org/pub/siege/
diff --git a/benchmarks/siege/files/patch-src-sock.c b/benchmarks/siege/files/patch-src-sock.c
index 2282e630d8cd..202c63c073b2 100644
--- a/benchmarks/siege/files/patch-src-sock.c
+++ b/benchmarks/siege/files/patch-src-sock.c
@@ -1,12 +1,20 @@
---- src/sock.c.ORIG Sun Aug 29 13:39:37 2004
-+++ src/sock.c Sun Aug 29 13:38:01 2004
-@@ -132,7 +132,7 @@
- if((gethostbyname_r( hn, &hent, hbf, sizeof(hbf), &hp, &herrno ) < 0)){
- hp = NULL;
+--- src/sock.c.orig 2010-05-17 15:57:59.000000000 +0200
++++ src/sock.c 2012-05-25 15:55:21.743780806 +0200
+@@ -126,7 +126,7 @@
+ hp = NULL;
+ }
}
-#elif defined(sun)
+#elif defined(sun) || defined(__FreeBSD__)
# ifdef HAVE_GETIPNODEBYNAME
- hp = getipnodebyname( hn, AF_INET, 0, &herrno );
+ hp = getipnodebyname(hn, AF_INET, 0, &herrno);
# else /* default use gethostbyname_r*/
-
+@@ -154,7 +154,7 @@
+ if(hp == NULL){ return -1; }
+ memset((void*) &cli, 0, sizeof(cli));
+ memcpy(&cli.sin_addr, hp->h_addr, hp->h_length);
+-#if defined(sun)
++#if defined(sun) || defined(__FreeBSD__)
+ # ifdef HAVE_FREEHOSTENT
+ freehostent(hp);
+ # endif/*HAVE_FREEHOSTENT*/