aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/siege
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-02-18 23:01:19 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-02-18 23:01:19 +0000
commit1e2c3f91e88ef1bbfdb21c011e8c5411176fd564 (patch)
tree4dd66bde9a72698337ac01b5774a2082bc9826bd /benchmarks/siege
parent87d4f86d83593dd321736b42a2027982d2f278ed (diff)
downloadports-1e2c3f91e88ef1bbfdb21c011e8c5411176fd564.tar.gz
ports-1e2c3f91e88ef1bbfdb21c011e8c5411176fd564.zip
benchmarks/siege: Update version 3.1.3=>3.1.4
- Fix patch files for 'make makepatch'
Notes
Notes: svn path=/head/; revision=409136
Diffstat (limited to 'benchmarks/siege')
-rw-r--r--benchmarks/siege/Makefile2
-rw-r--r--benchmarks/siege/distinfo4
-rw-r--r--benchmarks/siege/files/patch-Makefile.am2
-rw-r--r--benchmarks/siege/files/patch-configure.ac16
-rw-r--r--benchmarks/siege/files/patch-src_init.c12
-rw-r--r--benchmarks/siege/files/patch-src_sock.c (renamed from benchmarks/siege/files/patch-src-sock.c)2
6 files changed, 25 insertions, 13 deletions
diff --git a/benchmarks/siege/Makefile b/benchmarks/siege/Makefile
index 44ee74d4ac65..cbb6fe857ae2 100644
--- a/benchmarks/siege/Makefile
+++ b/benchmarks/siege/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= siege
-PORTVERSION= 3.1.3
+PORTVERSION= 3.1.4
CATEGORIES= benchmarks www
MASTER_SITES= http://download.joedog.org/siege/ \
http://fossies.org/linux/www/
diff --git a/benchmarks/siege/distinfo b/benchmarks/siege/distinfo
index 37706ba1a0b9..5c1e65b42ef2 100644
--- a/benchmarks/siege/distinfo
+++ b/benchmarks/siege/distinfo
@@ -1,2 +1,2 @@
-SHA256 (siege-3.1.3.tar.gz) = 4d3932ea23cbf6d1d22df7c7ee6e7a6bc9f591b604ab582393eeb62f393f5a33
-SIZE (siege-3.1.3.tar.gz) = 527862
+SHA256 (siege-3.1.4.tar.gz) = 0436970ca81ade76eb419bc42d3f8460b475079eb5d8f199d2fa83328893099d
+SIZE (siege-3.1.4.tar.gz) = 530149
diff --git a/benchmarks/siege/files/patch-Makefile.am b/benchmarks/siege/files/patch-Makefile.am
index f4eface21c57..8ccd3132992e 100644
--- a/benchmarks/siege/files/patch-Makefile.am
+++ b/benchmarks/siege/files/patch-Makefile.am
@@ -1,4 +1,4 @@
---- Makefile.am.orig 2015-06-04 10:45:57 UTC
+--- Makefile.am.orig 2015-12-22 20:12:40 UTC
+++ Makefile.am
@@ -20,6 +20,8 @@
## 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
diff --git a/benchmarks/siege/files/patch-configure.ac b/benchmarks/siege/files/patch-configure.ac
index 6024a02876f5..f6bd8e909a39 100644
--- a/benchmarks/siege/files/patch-configure.ac
+++ b/benchmarks/siege/files/patch-configure.ac
@@ -1,14 +1,14 @@
---- configure.ac.orig 2015-06-04 10:43:01 UTC
+--- configure.ac.orig 2015-12-22 20:12:40 UTC
+++ configure.ac
-@@ -7,6 +7,7 @@ dnl
- AC_INIT
- AC_CONFIG_SRCDIR([src/setup.h])
+@@ -17,6 +17,7 @@ AC_CONFIG_AUX_DIR(utils)
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_SRCDIR([src/setup.h])
AC_CONFIG_HEADERS(include/config.h)
+AC_CONFIG_MACRO_DIRS([m4])
-
- dnl
- dnl Define the utils directory
-@@ -44,7 +45,6 @@ dnl
+ DATE=`${CONFIG_SHELL} ${srcdir}/utils/mkstamp`
+ AC_SUBST(DATE)
+ AC_SUBST(PROGRAM)
+@@ -42,7 +43,6 @@ dnl
dnl Program support
dnl
AC_PATH_PROG( PERL, perl, false )
diff --git a/benchmarks/siege/files/patch-src_init.c b/benchmarks/siege/files/patch-src_init.c
new file mode 100644
index 000000000000..a805d8487e92
--- /dev/null
+++ b/benchmarks/siege/files/patch-src_init.c
@@ -0,0 +1,12 @@
+--- src/init.c.orig 2015-12-22 20:12:40 UTC
++++ src/init.c
+@@ -35,6 +35,9 @@
+ #include <unistd.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
++#include <signal.h>
++#endif
+
+ int
+ init_config( void )
diff --git a/benchmarks/siege/files/patch-src-sock.c b/benchmarks/siege/files/patch-src_sock.c
index e33f15ef76df..b63a6099b02e 100644
--- a/benchmarks/siege/files/patch-src-sock.c
+++ b/benchmarks/siege/files/patch-src_sock.c
@@ -1,4 +1,4 @@
---- src/sock.c.orig 2015-06-03 19:01:21 UTC
+--- src/sock.c.orig 2015-12-22 20:12:40 UTC
+++ src/sock.c
@@ -148,7 +148,7 @@ new_socket(CONN *C, const char *hostpara
hp = NULL;