aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sipp
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2007-12-17 01:37:43 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2007-12-17 01:37:43 +0000
commit03c1277ad7348a8adfd60967232e455ce9cbd194 (patch)
tree07664805f8e9f91ea47150ee1e26fc57d9cdf4ff /benchmarks/sipp
parentad6be9c6f76e51b9fbd37579c169af416896cb8b (diff)
downloadports-03c1277ad7348a8adfd60967232e455ce9cbd194.tar.gz
ports-03c1277ad7348a8adfd60967232e455ce9cbd194.zip
- Forced commit after repocopy.
- Repocopy from net/sipp to benchmarks/sipp. PR: ports/117305 [1], ports/117463 [2] Submitted by: araujo [1], Artem Naluzhnyy <tut@nhamon.com.ua> (maintainer) [2] Approved by: stas (mentor, implicit) Repocopied by: marcus
Notes
Notes: svn path=/head/; revision=203897
Diffstat (limited to 'benchmarks/sipp')
-rw-r--r--benchmarks/sipp/Makefile6
-rw-r--r--benchmarks/sipp/distinfo6
-rw-r--r--benchmarks/sipp/files/patch-Makefile18
-rw-r--r--benchmarks/sipp/files/patch-prepare_pcap.c48
-rw-r--r--benchmarks/sipp/files/patch-prepare_pcap.h13
-rw-r--r--benchmarks/sipp/files/patch-send_packets.c13
6 files changed, 6 insertions, 98 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 07bf06fb48cc..514a96da6933 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= sipp
-PORTVERSION= 2.0.20070906
-CATEGORIES= net
+PORTVERSION= 2.0.20071024
+CATEGORIES= benchmarks net
MASTER_SITES= http://sipp.sourceforge.net/snapshots/
-DISTNAME= ${PORTNAME}.2007-09-06
+DISTNAME= ${PORTNAME}.2007-10-24
MAINTAINER= tut@nhamon.com.ua
COMMENT= SIP testing tool
diff --git a/benchmarks/sipp/distinfo b/benchmarks/sipp/distinfo
index d718b0d00e18..76c0af22152e 100644
--- a/benchmarks/sipp/distinfo
+++ b/benchmarks/sipp/distinfo
@@ -1,3 +1,3 @@
-MD5 (sipp.2007-09-06.tar.gz) = b96d01b1435912ea65fd0092c98f130e
-SHA256 (sipp.2007-09-06.tar.gz) = b20de66bdd6b33b8d5441e3655f6e8f247dbcd40b9853e43ab9992f8122ff7eb
-SIZE (sipp.2007-09-06.tar.gz) = 197176
+MD5 (sipp.2007-10-24.tar.gz) = 430463e6d8c651a82a8826fcf76a1cb1
+SHA256 (sipp.2007-10-24.tar.gz) = 4970692fb624e55c39ec8e954242d0a9a243744d6e46c8ace8c591d0c3efa984
+SIZE (sipp.2007-10-24.tar.gz) = 198008
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
index 06c2bf30c561..0c31815c876c 100644
--- a/benchmarks/sipp/files/patch-Makefile
+++ b/benchmarks/sipp/files/patch-Makefile
@@ -54,24 +54,6 @@
#Linker Flags
LFLAGS_hpux=-AA -mt
-@@ -138,7 +136,7 @@
- LIBS_linux= -ldl -lpthread -lncurses -lstdc++ -lm -L /usr/local/lib -L /usr/lib -L /usr/lib64
- LIBS_hpux= -lcurses -lpthread -L /opt/openssl/lib -L /usr/local/lib
- LIBS_tru64= -lcurses -lpthread
--LIBS_freebsd= -lcurses -pthread
-+LIBS_freebsd= -lcurses -pthread -L /usr/local/lib
- LIBS_SunOS= -lcurses -lpthread -lnsl -lsocket -lstdc++ -lm -ldl -L /usr/local/ssl/lib/
- LIBS_Cygwin= -lcurses -lpthread -lstdc++ -L /usr/lib/WpdPack/Lib
- LIBS_Darwin= -lcurses
-@@ -146,7 +144,7 @@
-
- # Include directories
- INCDIR_linux=-I. -I/usr/include/openssl
--INCDIR_freebsd=-I. -I/opt/openssl/include
-+INCDIR_freebsd=-I. -I/usr/local/include
- INCDIR_hpux=-I. -I/usr/local/include -I/opt/openssl/include
- INCDIR_tru64=-I. -I/opt/openssl/include
- INCDIR_SunOS=-I. -I/usr/local/ssl/include/
@@ -154,8 +152,6 @@
INCDIR_Darwin=-I. -I/usr/local/ssl/include
INCDIR=$(INCDIR_$(SYSTEM))
diff --git a/benchmarks/sipp/files/patch-prepare_pcap.c b/benchmarks/sipp/files/patch-prepare_pcap.c
deleted file mode 100644
index a878d162d7ba..000000000000
--- a/benchmarks/sipp/files/patch-prepare_pcap.c
+++ /dev/null
@@ -1,48 +0,0 @@
-$FreeBSD$
-
---- prepare_pcap.c.orig
-+++ prepare_pcap.c
-@@ -19,7 +19,7 @@
- #include <stdlib.h>
- #include <netinet/in.h>
- #include <netinet/udp.h>
--#if defined(__HPUX) || defined(__CYGWIN)
-+#if defined(__HPUX) || defined(__CYGWIN) || defined(__FreeBSD__)
- #include <netinet/in_systm.h>
- #endif
- #include <netinet/ip.h>
-@@ -142,7 +142,7 @@
- fprintf(stderr, "prepare_pcap.c: Ignoring non UDP packet!\n");
- continue;
- }
--#if defined(__DARWIN) || defined(__CYGWIN)
-+#if defined(__DARWIN) || defined(__CYGWIN) || defined(__FreeBSD__)
- udphdr = (struct udphdr *)((char *)iphdr + (iphdr->ihl << 2) + 4);
- pktlen = (u_long)(ntohs(udphdr->uh_ulen));
- #else
-@@ -164,7 +164,7 @@
- ERROR("Can't allocate memory for pcap pkt data");
- memcpy(pkt_index->data, udphdr, pktlen);
-
--#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN) || defined(__FreeBSD__)
- udphdr->uh_sum = 0 ;
- #else
- udphdr->check = 0;
-@@ -173,14 +173,14 @@
- // compute a partial udp checksum
- // not including port that will be changed
- // when sending RTP
--#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN) || defined(__FreeBSD__)
- pkt_index->partial_check = check((u_int16_t *) &udphdr->uh_ulen, pktlen - 4) + ntohs(IPPROTO_UDP + pktlen);
- #else
- pkt_index->partial_check = check((u_int16_t *) &udphdr->len, pktlen - 4) + ntohs(IPPROTO_UDP + pktlen);
- #endif
- if (max_length < pktlen)
- max_length = pktlen;
--#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN) || defined(__FreeBSD__)
- if (base > ntohs(udphdr->uh_dport))
- base = ntohs(udphdr->uh_dport);
- #else
diff --git a/benchmarks/sipp/files/patch-prepare_pcap.h b/benchmarks/sipp/files/patch-prepare_pcap.h
deleted file mode 100644
index f7c7fec52e60..000000000000
--- a/benchmarks/sipp/files/patch-prepare_pcap.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- prepare_pcap.h.orig
-+++ prepare_pcap.h
-@@ -22,7 +22,7 @@
- #include <netinet/udp.h>
- #include <time.h>
-
--#if defined(__HPUX) || defined(__DARWIN) || defined(__CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || defined(__CYGWIN) || defined(__FreeBSD__)
- #define u_int8_t uint8_t
- #define u_int16_t uint16_t
- #define u_int32_t uint32_t
diff --git a/benchmarks/sipp/files/patch-send_packets.c b/benchmarks/sipp/files/patch-send_packets.c
deleted file mode 100644
index e386eee113b6..000000000000
--- a/benchmarks/sipp/files/patch-send_packets.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- send_packets.c.orig
-+++ send_packets.c
-@@ -45,7 +45,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <netinet/udp.h>
--#if defined(__DARWIN) || defined(__CYGWIN)
-+#if defined(__DARWIN) || defined(__CYGWIN) || defined(__FreeBSD__)
- #include <netinet/in.h>
- #endif
- #ifndef __CYGWIN