aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sipp
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2015-09-04 08:34:50 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2015-09-04 08:34:50 +0000
commit36134ea1f4884e200e275547b3cdad787c78e61e (patch)
treee8ba64b6b68ace0647e3fca70acd2e53111b1183 /benchmarks/sipp
parent66c538a80b7ce1c487a3514240ddd35e5030d27c (diff)
downloadports-36134ea1f4884e200e275547b3cdad787c78e61e.tar.gz
ports-36134ea1f4884e200e275547b3cdad787c78e61e.zip
- Update to 3.4.1
- Take maintainership Approved by: mat Differential Revision: https://reviews.freebsd.org/D3560
Notes
Notes: svn path=/head/; revision=396057
Diffstat (limited to 'benchmarks/sipp')
-rw-r--r--benchmarks/sipp/Makefile79
-rw-r--r--benchmarks/sipp/distinfo4
-rw-r--r--benchmarks/sipp/files/patch-Makefile67
-rw-r--r--benchmarks/sipp/files/patch-sipp.cpp22
-rw-r--r--benchmarks/sipp/files/sipp.1158
5 files changed, 25 insertions, 305 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index c4cdb71c4be1..0610f761886a 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -2,93 +2,60 @@
# $FreeBSD$
PORTNAME= sipp
-PORTVERSION= 3.3
-PORTREVISION= 2
+PORTVERSION= 3.4.1
+DISTVERSIONPREFIX= v
CATEGORIES= benchmarks net
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-3.3beta2
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= farrokhi@FreeBSD.org
COMMENT= SIP benchmarking and testing tool
LICENSE= GPLv2
+USE_GITHUB= yes
+GH_ACCOUNT= SIPp
+
PLIST_FILES= bin/sipp man/man1/sipp.1.gz
USES= gmake
-CPP= ${CXX}
-MAKE_ENV+= CCLINK="${CXX}"
-CPPFLAGS+= ${CXXFLAGS}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
-OPTIONS_DEFINE= OPENSSL GSL PCAPPLAY
-OPTIONS_DEFAULT= OPENSSL
+OPTIONS_DEFINE= OPENSSL GSL PCAP RTPSTREAM SCTP
+OPTIONS_DEFAULT= OPENSSL PCAP RTPSTREAM
OPENSSL_DESC= OpenSSL support (for digest auth and SIP over TLS)
GSL_DESC= GSL support (for statistical distributed pauses)
-PCAPPLAY_DESC= RTP play support
-
-.include <bsd.port.options.mk>
+PCAP_DESC= PCAP Support
+RTPSTREAM_DESC= RTP Streaming Support
+SCTP_DESC= SCTP Transport Protocol Support
-.if ${PORT_OPTIONS:MGSL}
-LIB_DEPENDS+= libgsl.so:${PORTSDIR}/math/gsl
+GSL_CONFIGURE_WITH= gsl
+SCTP_CONFIGURE_WITH= sctp
+RTPSTREAM_CONFIGURE_WITH= rtpstream
+OPENSSL_CONFIGURE_WITH= openssl
-MAKE_ENV+= EXTRACPPFLAGS=-DHAVE_GSL \
- EXTRACFLAGS=-DHAVE_GSL \
- EXTRALIBS='-lgsl -lgslcblas'
-.endif #defined(WITH_GSL)
+OPENSSL_USE= openssl=yes
+GSL_LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
-.if ${PORT_OPTIONS:MPCAPPLAY}
PCAP_FILES= dtmf_2833_0.pcap dtmf_2833_1.pcap dtmf_2833_2.pcap \
dtmf_2833_3.pcap dtmf_2833_4.pcap dtmf_2833_5.pcap \
dtmf_2833_6.pcap dtmf_2833_7.pcap dtmf_2833_8.pcap \
dtmf_2833_9.pcap dtmf_2833_pound.pcap dtmf_2833_star.pcap \
g711a.pcap
-.for f in ${PCAP_FILES}
-PLIST_FILES+= %%DATADIR%%/pcap/${f}
-.endfor
-.endif #defined(WITH_PCAPPLAY)
-
-.if ${PORT_OPTIONS:MOPENSSL}
-
-USE_OPENSSL= yes
-.if ${PORT_OPTIONS:MPCAPPLAY}
-ALL_TARGET= pcapplay_ossl
-.else
-ALL_TARGET= ossl
-.endif #defined(WITH_PCAPPLAY)
-
-.else # ! ${PORT_OPTIONS:MOPENSSL}
+PCAP_PLIST_FILES= ${PCAP_FILES:S|^|${DATADIR}/pcap/|}
-.if ${PORT_OPTIONS:MPCAPPLAY}
-ALL_TARGET= pcapplay
-.endif #defined(WITH_PCAPPLAY)
-
-
-.endif #defined(WITHOUT_OPENSSL)
-
-post-patch:
-.if ${ARCH} == "ia64"
- @${REINPLACE_CMD} 's/^\(MFLAGS_ia64=\)\+DD64$$/\1/' ${WRKSRC}/Makefile
-.endif
-
-.if ${PORT_OPTIONS:MPCAPPLAY}
+post-patch-PCAP-on:
@${REINPLACE_CMD} \
's|\(\\"\)\(pcap/[^"]*\.pcap\\"\)|\1${DATADIR}/\2|' \
- ${WRKSRC}/scenario.cpp
-.endif #defined(WITH_PCAPPLAY)
+ ${WRKSRC}/src/scenario.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/sipp.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/sipp.1 ${STAGEDIR}${PREFIX}/man/man1
-.if ${PORT_OPTIONS:MPCAPPLAY}
+do-install-PCAP-on:
${MKDIR} ${STAGEDIR}${DATADIR}/pcap
-
.for f in ${PCAP_FILES}
${INSTALL_DATA} ${WRKSRC}/pcap/${f} ${STAGEDIR}${DATADIR}/pcap/${f}
.endfor
-.endif #defined(WITH_PCAPPLAY)
-
.include <bsd.port.mk>
diff --git a/benchmarks/sipp/distinfo b/benchmarks/sipp/distinfo
index 1424c26e99c5..5f1f8479925b 100644
--- a/benchmarks/sipp/distinfo
+++ b/benchmarks/sipp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sipp-3.3beta2.tar.gz) = 998fbffa84107a6c7113dc1f801c449648f415fabb3fb3cf0f6620afeef6dd9a
-SIZE (sipp-3.3beta2.tar.gz) = 240886
+SHA256 (SIPp-sipp-v3.4.1_GH0.tar.gz) = bb6829a1f3af8d8b5f08ffcd7de40e2692b4dfb9a83eccec3653a51f77a82bc4
+SIZE (SIPp-sipp-v3.4.1_GH0.tar.gz) = 439326
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
deleted file mode 100644
index cd642263d995..000000000000
--- a/benchmarks/sipp/files/patch-Makefile
+++ /dev/null
@@ -1,67 +0,0 @@
---- Makefile.orig 2013-01-10 22:58:10.000000000 +0000
-+++ Makefile 2013-02-09 19:53:19.000000000 +0000
-@@ -18,10 +18,6 @@
- # From Hewlett Packard Company.
- #
-
---include local.mk
--SVN_VERSION=$(shell if test -d .svn ; then svnversion . | sed -e 's/^/svn/;' ; else echo unknown ; fi)
--VERINFO=-DSVN_VERSION="\"$(SVN_VERSION)\""
--
- # Output binary to be built
- OUTPUT=sipp
-
-@@ -73,7 +69,7 @@
- CC_SunOS=gcc
- CC_Cygwin=cc
- CC_Darwin=cc
--CC=$(CC_$(SYSTEM))
-+CC?=$(CC_$(SYSTEM))
-
- # C++ compiler mapping
- CPP_hpux=aCC
-@@ -83,7 +79,7 @@
- CPP_SunOS=g++
- CPP_Cygwin=g++
- CPP_Darwin=g++
--CPP=$(CPP_$(SYSTEM))
-+CPP?=$(CPP_$(SYSTEM))
-
- #Model specific flags
- MFLAGS_ia64=+DD64
-@@ -106,7 +102,7 @@
- CFLAGS_SunOS=${DEBUG_FLAGS} -D__SUNOS
- CFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
- CFLAGS_Darwin=-D__DARWIN
--CFLAGS=$(CFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(SCTP) $(PCAPPLAY) $(EXTRACFLAGS) $(UNITTEST)
-+CFLAGS+=$(CFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(SCTP) $(PCAPPLAY) $(EXTRACFLAGS) $(UNITTEST)
-
- #C++ Compiler Flags
- CPPFLAGS_hpux=-AA -mt -D__HPUX -D_INCLUDE_LONGLONG -DNOMACROS +W829
-@@ -116,7 +112,7 @@
- CPPFLAGS_SunOS=${DEBUG_FLAGS} -D__SUNOS
- CPPFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
- CPPFLAGS_Darwin=-D__DARWIN
--CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(SCTP) $(PCAPPLAY) $(EXTRACPPFLAGS) $(UNITTEST)
-+CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(SCTP) $(PCAPPLAY) $(EXTRACPPFLAGS) $(UNITTEST)
-
- #Linker mapping
- CCLINK_hpux=aCC
-@@ -126,7 +122,7 @@
- CCLINK_SunOS=gcc
- CCLINK_Cygwin=g++
- CCLINK_Darwin=g++
--CCLINK=$(CCLINK_$(SYSTEM))
-+CCLINK?=$(CCLINK_$(SYSTEM))
-
- #Linker Flags
- LFLAGS_hpux=-AA -mt
-@@ -158,8 +154,6 @@
- INCDIR_Darwin=-I. -I/usr/local/ssl/include
- INCDIR=$(INCDIR_$(SYSTEM))
-
---include local.mk
--
- # Building without TLS (no openssl pre-requisite)
- all:
- $(MAKE) OSNAME=`uname|sed -e "s/CYGWIN.*/CYGWIN/"` MODELNAME=`uname -m|sed "s/Power Macintosh/ppc/"` $(OUTPUT)
diff --git a/benchmarks/sipp/files/patch-sipp.cpp b/benchmarks/sipp/files/patch-sipp.cpp
deleted file mode 100644
index a12b0481b589..000000000000
--- a/benchmarks/sipp/files/patch-sipp.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- sipp.cpp.orig 2013-02-09 20:03:03.000000000 +0000
-+++ sipp.cpp 2013-02-09 20:10:27.000000000 +0000
-@@ -4622,7 +4622,7 @@
- }
- exit(EXIT_OTHER);
- case SIPP_OPTION_VERSION:
-- printf("\n SIPp v3.3-beta2"
-+ printf("\n SIPp v3.3"
- #ifdef _USE_OPENSSL
- "-TLS"
- #endif
-@@ -4632,8 +4632,8 @@
- #ifdef PCAPPLAY
- "-PCAP"
- #endif
-- ", version %s, built %s, %s.\n\n",
-- SIPP_VERSION, __DATE__, __TIME__);
-+ ", built %s, %s.\n\n",
-+ __DATE__, __TIME__);
-
- printf
- (" This program is free software; you can redistribute it and/or\n"
diff --git a/benchmarks/sipp/files/sipp.1 b/benchmarks/sipp/files/sipp.1
deleted file mode 100644
index 52e5cbe2cac6..000000000000
--- a/benchmarks/sipp/files/sipp.1
+++ /dev/null
@@ -1,158 +0,0 @@
-.\"
-.\" Standard preamble:
-.\" ========================================================================
-.de Sh \" Subsection heading
-.br
-.if t .Sp
-.ne 5
-.PP
-\fB\\$1\fR
-.PP
-..
-.de Sp \" Vertical space (when we can't use .PP)
-.if t .sp .5v
-.if n .sp
-..
-.de Vb \" Begin verbatim text
-.ft CW
-.nf
-.ne \\$1
-..
-.de Ve \" End verbatim text
-.ft R
-.fi
-..
-.\" Set up some character translations and predefined strings. \*(-- will
-.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
-.\" double quote, and \*(R" will give a right double quote. | will give a
-.\" real vertical bar. \*(C+ will give a nicer C++. Capital omega is used to
-.\" do unbreakable dashes and therefore won't be available. \*(C` and \*(C'
-.\" expand to `' in nroff, nothing in troff, for use with C<>.
-.tr \(*W-|\(bv\*(Tr
-.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
-.ie n \{\
-. ds -- \(*W-
-. ds PI pi
-. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
-. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
-. ds L" ""
-. ds R" ""
-. ds C` ""
-. ds C' ""
-'br\}
-.el\{\
-. ds -- \|\(em\|
-. ds PI \(*p
-. ds L" ``
-. ds R" ''
-'br\}
-.\"
-.\" If the F register is turned on, we'll generate index entries on stderr for
-.\" titles (.TH), headers (.SH), subsections (.Sh), items (.Ip), and index
-.\" entries marked with X<> in POD. Of course, you'll have to process the
-.\" output yourself in some meaningful fashion.
-.if \nF \{\
-. de IX
-. tm Index:\\$1\t\\n%\t"\\$2"
-..
-. nr % 0
-. rr F
-.\}
-.\"
-.\" For nroff, turn off justification. Always turn off hyphenation; it makes
-.\" way too many mistakes in technical documents.
-.hy 0
-.if n .na
-.\"
-.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
-.\" Fear. Run. Save yourself. No user-serviceable parts.
-. \" fudge factors for nroff and troff
-.if n \{\
-. ds #H 0
-. ds #V .8m
-. ds #F .3m
-. ds #[ \f1
-. ds #] \fP
-.\}
-.if t \{\
-. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
-. ds #V .6m
-. ds #F 0
-. ds #[ \&
-. ds #] \&
-.\}
-. \" simple accents for nroff and troff
-.if n \{\
-. ds ' \&
-. ds ` \&
-. ds ^ \&
-. ds , \&
-. ds ~ ~
-. ds /
-.\}
-.if t \{\
-. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
-. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
-. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
-. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
-. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
-. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
-.\}
-. \" troff and (daisy-wheel) nroff accents
-.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
-.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
-.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
-.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
-.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
-.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
-.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
-.ds ae a\h'-(\w'a'u*4/10)'e
-.ds Ae A\h'-(\w'A'u*4/10)'E
-. \" corrections for vroff
-.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
-.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
-. \" for low resolution devices (crt and lpr)
-.if \n(.H>23 .if \n(.V>19 \
-\{\
-. ds : e
-. ds 8 ss
-. ds o a
-. ds d- d\h'-1'\(ga
-. ds D- D\h'-1'\(hy
-. ds th \o'bp'
-. ds Th \o'LP'
-. ds ae ae
-. ds Ae AE
-.\}
-.rm #[ #] #H #V #F C
-.\" ========================================================================
-.\"
-.IX Title "sipp 1"
-.TH sipp 1 "2006-12-17" "sipp" "User Contributed Documentation"
-.SH "NAME"
-sipp \- A benchworking tool for the SIP protocol.
-.SH "DESCRIPTION"
-.IX Header "DESCRIPTION"
-Sipp is a performance test tool / traffic generator for the \s-1SIP\s0
-protocol. It comes with a few basic SipStone user-agents
-scenarios (\s-1UAC\s0 & \s-1UAS\s0), establishing and releasing multiple
-calls with the \s-1INVITE\s0 and \s-1BYE\s0 methods.
-.PP
-It can also read \s-1XML\s0 scenario files describing any performance
-testing configuration for \s-1SIP\s0.
-.SH "SYNTAX"
-.IX Header "SYNTAX"
-.Vb 1
-\&Run 'sipp' command without parameters for configuration details.
-.Ve
-.SH "SEE ALSO"
-.IX Header "SEE ALSO"
-.Vb 1
-\&SIPp documentation - http://sipp.sourceforge.net/doc/
-.Ve
-.SH "AUTHORS"
-.IX Header "AUTHORS"
-.Vb 2
-\&Richard Gayraud <richard_gayraud@users.sourceforge.net>
-\&Olivier Jacques <ojacques@users.sourceforge.net>
-.Ve