aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sipp
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2017-01-13 14:52:40 +0000
committerJohn Marino <marino@FreeBSD.org>2017-01-13 14:52:40 +0000
commit6e8f29bd0d37a8e5113bdac9d35eac7310e2afd8 (patch)
tree704cfa48e5f3a6a025dd9f74bcaec9146eba9472 /benchmarks/sipp
parent66017a99371babe6c84e497552b22147aba563c6 (diff)
downloadports-6e8f29bd0d37a8e5113bdac9d35eac7310e2afd8.tar.gz
ports-6e8f29bd0d37a8e5113bdac9d35eac7310e2afd8.zip
benchmarks/sipp: Fix stage-QA and restore curses support
1. curses support: Adding autoreconf negated the changes to configure script, so change configure.ac instead 2. The man page wasn't being installed (plist QA fail) so fix 3. While here, change USE_OPENSSL to USES=ssl Approved by: ncurses and just-fix-it blankets
Notes
Notes: svn path=/head/; revision=431396
Diffstat (limited to 'benchmarks/sipp')
-rw-r--r--benchmarks/sipp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index ee0fb1bfdd9c..d0e3f1fa296a 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sipp
PORTVERSION= 3.5.1
+PORTREVISION= 1
CATEGORIES= benchmarks net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${PORTVERSION}/
@@ -29,7 +30,7 @@ SCTP_CONFIGURE_WITH= sctp
RTPSTREAM_CONFIGURE_WITH= rtpstream
OPENSSL_CONFIGURE_WITH= openssl
-OPENSSL_USE= openssl=yes
+OPENSSL_USES= ssl
GSL_LIB_DEPENDS= libgsl.so:math/gsl
PCAP_FILES= dtmf_2833_0.pcap dtmf_2833_1.pcap dtmf_2833_2.pcap \
@@ -41,7 +42,7 @@ PCAP_FILES= dtmf_2833_0.pcap dtmf_2833_1.pcap dtmf_2833_2.pcap \
PCAP_PLIST_FILES= ${PCAP_FILES:S|^|${DATADIR}/pcap/|}
post-patch:
- ${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[[:<:]]curses|ncurses|' ${WRKSRC}/configure.ac
post-patch-PCAP-on:
@${REINPLACE_CMD} \
@@ -50,7 +51,7 @@ post-patch-PCAP-on:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/sipp.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/include/sipp.1 ${STAGEDIR}${PREFIX}/man/man1
do-install-PCAP-on:
${MKDIR} ${STAGEDIR}${DATADIR}/pcap