aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sipp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-15 01:25:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-15 01:25:25 +0000
commit759e3adb46541e2e15e2f89cbef455a609b946b0 (patch)
tree04f0e773c1cba9e0ac26d73c5279b8a3560af2bd /benchmarks/sipp
parent2b9a819eb960f69c9353fe2a92cc74c36e64f54e (diff)
downloadports-759e3adb46541e2e15e2f89cbef455a609b946b0.tar.gz
ports-759e3adb46541e2e15e2f89cbef455a609b946b0.zip
- Update to 2.0.20070906
PR: 116202 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=199504
Diffstat (limited to 'benchmarks/sipp')
-rw-r--r--benchmarks/sipp/Makefile7
-rw-r--r--benchmarks/sipp/distinfo6
-rw-r--r--benchmarks/sipp/files/patch-Makefile15
-rw-r--r--benchmarks/sipp/files/patch-call.cpp24
4 files changed, 14 insertions, 38 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 9b1b0db47615..07bf06fb48cc 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= sipp
-PORTVERSION= 2.0
-PORTREVISION= 1
+PORTVERSION= 2.0.20070906
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
-MASTER_SITE_SUBDIR= sipp
+MASTER_SITES= http://sipp.sourceforge.net/snapshots/
+DISTNAME= ${PORTNAME}.2007-09-06
MAINTAINER= tut@nhamon.com.ua
COMMENT= SIP testing tool
diff --git a/benchmarks/sipp/distinfo b/benchmarks/sipp/distinfo
index aff62368ff85..d718b0d00e18 100644
--- a/benchmarks/sipp/distinfo
+++ b/benchmarks/sipp/distinfo
@@ -1,3 +1,3 @@
-MD5 (sipp-2.0.tar.gz) = a76e640709cbf900b0313713ac34d312
-SHA256 (sipp-2.0.tar.gz) = 9f8ce07ed09e574243857bbc22ba0b1f9b12b1a4b4f13378cecadd5abb1de155
-SIZE (sipp-2.0.tar.gz) = 184756
+MD5 (sipp.2007-09-06.tar.gz) = b96d01b1435912ea65fd0092c98f130e
+SHA256 (sipp.2007-09-06.tar.gz) = b20de66bdd6b33b8d5441e3655f6e8f247dbcd40b9853e43ab9992f8122ff7eb
+SIZE (sipp.2007-09-06.tar.gz) = 197176
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
index 8084206fe46e..06c2bf30c561 100644
--- a/benchmarks/sipp/files/patch-Makefile
+++ b/benchmarks/sipp/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Jan 16 11:18:32 2007
-+++ Makefile Tue Jan 30 21:44:15 2007
+--- Makefile.orig 2007-09-06 11:51:24.000000000 +0300
++++ Makefile 2007-09-08 19:16:08.000000000 +0300
@@ -18,8 +18,6 @@
# From Hewlett Packard Company.
#
@@ -63,20 +63,21 @@
LIBS_SunOS= -lcurses -lpthread -lnsl -lsocket -lstdc++ -lm -ldl -L /usr/local/ssl/lib/
LIBS_Cygwin= -lcurses -lpthread -lstdc++ -L /usr/lib/WpdPack/Lib
LIBS_Darwin= -lcurses
-@@ -146,15 +144,13 @@
+@@ -146,7 +144,7 @@
# Include directories
- INCDIR_linux=-I. -I/opt/openssl/include
+ INCDIR_linux=-I. -I/usr/include/openssl
-INCDIR_freebsd=-I. -I/opt/openssl/include
+INCDIR_freebsd=-I. -I/usr/local/include
INCDIR_hpux=-I. -I/usr/local/include -I/opt/openssl/include
INCDIR_tru64=-I. -I/opt/openssl/include
INCDIR_SunOS=-I. -I/usr/local/ssl/include/
- INCDIR_Cygwin=-I. -I/usr/include/openssl -I/usr/include -I/usr/lib/WpdPack/Include
+@@ -154,8 +152,6 @@
INCDIR_Darwin=-I. -I/usr/local/ssl/include
INCDIR=$(INCDIR_$(SYSTEM))
--
---include local.mk
+--include local.mk
+-
# Building without TLS and authentication (no openssl pre-requisite)
all:
+ make OSNAME=`uname|sed -e "s/CYGWIN.*/CYGWIN/"` MODELNAME=`uname -m|sed "s/Power Macintosh/ppc/"` $(OUTPUT)
diff --git a/benchmarks/sipp/files/patch-call.cpp b/benchmarks/sipp/files/patch-call.cpp
deleted file mode 100644
index 3a8651d50f70..000000000000
--- a/benchmarks/sipp/files/patch-call.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
-$FreeBSD$
-
---- call.cpp.orig Tue Jan 23 20:02:26 2007
-+++ call.cpp Fri Feb 9 01:49:46 2007
-@@ -2216,13 +2216,17 @@
-
- auth_marker = src;
- auth_marker_len = strchr(src, ']') - src;
-- strcpy(my_auth_user, service);
-- strcpy(my_auth_pass, auth_password);
- /* Look for optional username and password parameters */
- /* add aka_OP, aka_AMF, aka_K */
- key = getKeywordParam(src, "username=", my_auth_user);
-+ if (my_auth_user[0]==0){
-+ strcpy(my_auth_user, service);
-+ }
- memset(my_auth_pass,0,KEYWORD_SIZE);
- key = getKeywordParam(src, "password=", my_auth_pass);
-+ if (my_auth_pass[0]==0){
-+ strcpy(my_auth_pass, auth_password);
-+ }
- memset(my_aka_OP,0,KEYWORD_SIZE);
- key = getKeywordParam(src, "aka_OP=", my_aka_OP);
- memset(my_aka_AMF,0,KEYWORD_SIZE);