aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/spp
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-21 12:50:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-21 12:51:18 +0000
commit6d8dd71bd798c6830a873e65124d75b19b596130 (patch)
tree0503324d7042f30d4d4820a7fc0d7eb5131bb8a9 /benchmarks/spp
parent3d947aa703b384585409ba07e790303a3f9ec0d6 (diff)
downloadports-6d8dd71bd798c6830a873e65124d75b19b596130.tar.gz
ports-6d8dd71bd798c6830a873e65124d75b19b596130.zip
benchmarks/spp: Sanitize MANPREFIX
Approved by: portmgr (blanket)
Diffstat (limited to 'benchmarks/spp')
-rw-r--r--benchmarks/spp/Makefile2
-rw-r--r--benchmarks/spp/files/patch-Makefile44
2 files changed, 38 insertions, 8 deletions
diff --git a/benchmarks/spp/Makefile b/benchmarks/spp/Makefile
index 055bcc2b8f13..3c64e73cd088 100644
--- a/benchmarks/spp/Makefile
+++ b/benchmarks/spp/Makefile
@@ -16,6 +16,6 @@ USES= tar:bzip2
BB_TAGNAME= 8cfe6814ce52
WRKSRC= ${WRKDIR}/caia-swin-${PORTNAME}-${BB_TAGNAME}
-PLIST_FILES= bin/spp man/man1/spp.1.gz
+PLIST_FILES= bin/spp share/man/man1/spp.1.gz
.include <bsd.port.mk>
diff --git a/benchmarks/spp/files/patch-Makefile b/benchmarks/spp/files/patch-Makefile
index 30fa5a51f9a5..461471f1989b 100644
--- a/benchmarks/spp/files/patch-Makefile
+++ b/benchmarks/spp/files/patch-Makefile
@@ -1,17 +1,32 @@
---- Makefile.orig 2015-05-21 00:10:33 UTC
+--- Makefile.orig 2020-11-09 06:43:39 UTC
+++ Makefile
-@@ -39,8 +39,8 @@ INCLUDES = $(SRCDIR)/crc32.h \
- SLIBS= -pthread -lpcap
+@@ -5,7 +5,7 @@
+ #
+ # <default> : see target "all"
+ # all : build all source and binaries
+-# clean : clean up object files and binaries
++# clean : clean up object files and binaries
+ #
+ # Amiel Heyde
+ #
+@@ -36,13 +36,13 @@ INCLUDES = $(SRCDIR)/crc32.h \
+ $(SRCDIR)/rtp.h \
+ $(SRCDIR)/config.h
+
+-
+
++
+ SLIBS= -pthread -lpcap -lm
BINDIR=./bin
PROGRAM= $(BINDIR)/$(NAME)
-CFLAGS += -I/usr/local/include
-LDFLAGS += -L/usr/local/lib
-+CFLAGS += -I$(LOCALBASE)/include
++CFLAGS += -I$(LOCALBASE)/include
+LDFLAGS += -L$(LOCALBASE)/lib
INSTALL= install
-@@ -48,11 +48,11 @@ INSTALL= install
+@@ -50,11 +50,11 @@ INSTALL= install
# If, for some reason, you don't want debugging info to bewww
# logged, then comment the following line.
#
@@ -25,7 +40,14 @@
# turn on optimisation
CFLAGS += -O2
-@@ -79,13 +79,10 @@ clean:
+@@ -76,19 +76,16 @@ $(PROGRAM): $(OBJECTS)
+
+ $(PROGRAM): $(OBJECTS)
+ mkdir -p bin
+- $(CC) -o $@ $(OBJECTS) $(CFLAGS) $(LDFLAGS) $(SLIBS)
++ $(CC) -o $@ $(OBJECTS) $(CFLAGS) $(LDFLAGS) $(SLIBS)
+
+ clean:
rm -f $(PROGRAM) *.o $(SRCDIR)/*.o *~
install:
@@ -37,7 +59,15 @@
+ $(BSD_INSTALL_PROGRAM) $(PROGRAM) $(DESTDIR)$(PREFIX)/bin/
@echo "Installing manual page"
- $(INSTALL) -c -m 644 doc/spp.1 /usr/local/man/man1/
-+ $(BSD_INSTALL_MAN) doc/spp.1 $(DESTDIR)$(PREFIX)/man/man1/
++ $(BSD_INSTALL_MAN) doc/spp.1 $(DESTDIR)$(PREFIX)/share/man/man1/
# target 'distro'
#
+@@ -99,7 +96,3 @@ distro:
+ distro:
+ #Make a gzip archive with only the necessary files
+ mkdir $(DISTRONAME); rsync -av --exclude .hgtags --exclude .hg --exclude bin --exclude spp-0.4.2 . $(DISTRONAME); tar --exclude="*.svn*" --exclude="*.o" --exclude="*~" --exclude="*.old" --exclude="*.orig" --exclude="*.kde*" --exclude="*.out" --exclude="*.new" --exclude="*Doxyfile*" --exclude="*bin/spp*" --exclude="src-fork" --exclude="spp-*.tar.gz" --format=ustar -cvf ${DISTRONAME}.tar ${DISTRONAME}; rm -rf $(DISTRONAME); gzip $(DISTRONAME).tar;
+-
+-
+-
+-