aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/ttcp
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-01-03 15:34:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-01-03 15:34:13 +0000
commit58848c550bf7029a7c353fcfb5d561f730a4a04e (patch)
treebda726dcf401a0a3088ac3e3520896cd590c1cec /benchmarks/ttcp
parent49bf36d52771ccccdeacb84f6e4f3406a8814618 (diff)
downloadports-58848c550bf7029a7c353fcfb5d561f730a4a04e.tar.gz
ports-58848c550bf7029a7c353fcfb5d561f730a4a04e.zip
Convert benchmarks to PORT_OPTIONS:MDOCS
Notes
Notes: svn path=/head/; revision=338548
Diffstat (limited to 'benchmarks/ttcp')
-rw-r--r--benchmarks/ttcp/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/benchmarks/ttcp/Makefile b/benchmarks/ttcp/Makefile
index 10394736ba03..9ee4d02512e5 100644
--- a/benchmarks/ttcp/Makefile
+++ b/benchmarks/ttcp/Makefile
@@ -23,10 +23,13 @@ DIST_SUBDIR= ${PORTNAME}
MAN1= ttcp.1
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-extract:
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/ttcp.c ${WRKSRC}/
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/ttcp.1 ${WRKSRC}/
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/README ${WRKSRC}/
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/ttcp.c ${WRKSRC}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/ttcp.1 ${WRKSRC}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/README ${WRKSRC}
do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/ttcp ${WRKSRC}/ttcp.c
@@ -34,9 +37,9 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ttcp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ttcp.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>