aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/wrk
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2015-05-26 23:39:40 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2015-05-26 23:39:40 +0000
commit1761870a317c3ef75a6fcc3aeb683548bcd55dfa (patch)
tree33a7939985f3fd3d52101c09346d855569eedda7 /benchmarks/wrk
parent1d8d8ced6cb74dbaebb1b6ad9c694935ae9af0a9 (diff)
downloadports-1761870a317c3ef75a6fcc3aeb683548bcd55dfa.tar.gz
ports-1761870a317c3ef75a6fcc3aeb683548bcd55dfa.zip
Another attempt to fix undefined reference to `__sync_fetch_and_add_8' and
`__sync_val_compare_and_swap_8' for FreeBSD[8|9]. Idea from: tijl
Notes
Notes: svn path=/head/; revision=387524
Diffstat (limited to 'benchmarks/wrk')
-rw-r--r--benchmarks/wrk/Makefile10
-rw-r--r--benchmarks/wrk/files/patch-src-stats.h14
2 files changed, 9 insertions, 15 deletions
diff --git a/benchmarks/wrk/Makefile b/benchmarks/wrk/Makefile
index ff05bf45c7de..8ce5ec9e1ab4 100644
--- a/benchmarks/wrk/Makefile
+++ b/benchmarks/wrk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wrk
PORTVERSION= 4.0.1
+PORTREVISION= 1
CATEGORIES= benchmarks www
DISTNAME= ${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
@@ -23,7 +24,14 @@ CFLAGS+= -std=c99 -D_DECLARE_C99_LDBL_MATH
PLIST_FILES= bin/wrk
+.include <bsd.port.pre.mk>
+
+# Port requires 64 bit atomics
+.if ${ARCH} == i386 && empty(MACHINE_CPU:Mi586)
+CFLAGS+= -march=i586
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/benchmarks/wrk/files/patch-src-stats.h b/benchmarks/wrk/files/patch-src-stats.h
deleted file mode 100644
index 57c543c609e8..000000000000
--- a/benchmarks/wrk/files/patch-src-stats.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/stats.h.orig 2015-05-25 02:43:07.925981000 +0300
-+++ src/stats.h 2015-05-25 02:43:18.075337000 +0300
-@@ -1,6 +1,11 @@
- #ifndef STATS_H
- #define STATS_H
-
-+#if defined(__FreeBSD__)
-+#include <sys/types.h>
-+#include <machine/atomic.h>
-+#endif /* defined(__FreeBSD__) */
-+
- #include <stdbool.h>
- #include <stdint.h>
-