aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-06-17 17:06:41 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-06-17 17:06:41 +0000
commit0b83e8dde93cb34d16a1ad5ebb28c34d08513d4d (patch)
treea50a29d7a147ba7ba96969dffab934bdc97923c9 /benchmarks
parentf0559e873477fc1b4d625ca9edf8c4a0f3cc2489 (diff)
downloadports-0b83e8dde93cb34d16a1ad5ebb28c34d08513d4d.tar.gz
ports-0b83e8dde93cb34d16a1ad5ebb28c34d08513d4d.zip
benchmarks/mst-bench: Maximum sustainable throughput benchmark
MST-bench is a simple program to measure optimal sustained memory and disk performance. Unlike many benchmarks, it does not attempt to simulate naturally occurring loads. Rather, it indicates what is the best performance you can expect out of your hardware, providing a reference to which software can be compared.
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/mst-bench/Makefile18
-rw-r--r--benchmarks/mst-bench/distinfo3
-rw-r--r--benchmarks/mst-bench/pkg-descr8
4 files changed, 30 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 5dc990a519b8..71f2f9bbe3d4 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -45,6 +45,7 @@
SUBDIR += lzbench
SUBDIR += mangohud
SUBDIR += mdtest
+ SUBDIR += mst-bench
SUBDIR += nbench
SUBDIR += netio
SUBDIR += netperf
diff --git a/benchmarks/mst-bench/Makefile b/benchmarks/mst-bench/Makefile
new file mode 100644
index 000000000000..db74e181d06e
--- /dev/null
+++ b/benchmarks/mst-bench/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= MST-Bench
+DISTVERSION= 0.2.1-3
+DISTVERSIONSUFFIX= -g0175cb2
+CATEGORIES= benchmarks
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Maximum sustained throughput benchmark
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+
+GH_ACCOUNT= outpaddling
+
+PLIST_FILES= bin/mst-bench man/man1/mst-bench.1.gz
+
+.include <bsd.port.mk>
diff --git a/benchmarks/mst-bench/distinfo b/benchmarks/mst-bench/distinfo
new file mode 100644
index 000000000000..9a394535c18f
--- /dev/null
+++ b/benchmarks/mst-bench/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623949342
+SHA256 (outpaddling-MST-Bench-0.2.1-3-g0175cb2_GH0.tar.gz) = 454d48039f25e668fcb1dc7946808761fe43333e7dcad8a468c26ec066b90c4f
+SIZE (outpaddling-MST-Bench-0.2.1-3-g0175cb2_GH0.tar.gz) = 10964
diff --git a/benchmarks/mst-bench/pkg-descr b/benchmarks/mst-bench/pkg-descr
new file mode 100644
index 000000000000..4569cd665987
--- /dev/null
+++ b/benchmarks/mst-bench/pkg-descr
@@ -0,0 +1,8 @@
+MST-bench is a simple program to measure optimal sustained memory and disk
+performance.
+
+Unlike many benchmarks, it does not attempt to simulate naturally occurring
+loads. Rather, it indicates what is the best performance you can expect out of
+your hardware, providing a reference to which software can be compared.
+
+WWW: https://github.com/outpaddling/MST-Bench