aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-10 20:39:34 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-10 20:39:34 +0000
commit1280e55e5812ef1dab4c211ae927729b645bf986 (patch)
tree920de4e55a71b6b0ed3347f70d4be2e0f1cbe81f /benchmarks
parentfdcf5af89ebd786a0c8a059835c92915234b7269 (diff)
downloadports-1280e55e5812ef1dab4c211ae927729b645bf986.tar.gz
ports-1280e55e5812ef1dab4c211ae927729b645bf986.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile6
-rw-r--r--benchmarks/sipp/distinfo6
-rw-r--r--benchmarks/sipp/files/patch-Makefile25
-rw-r--r--benchmarks/sipp/files/patch-auth.c14
4 files changed, 31 insertions, 20 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index e7ae5701a655..50d86e9a5174 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -6,17 +6,15 @@
#
PORTNAME= sipp
-PORTVERSION= 1.1.r5
+PORTVERSION= 1.1.r6
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= sipp
-DISTNAME= ${PORTNAME}-1.1rc5
+DISTNAME= ${PORTNAME}-1.1rc6
MAINTAINER= tut@nhamon.com.ua
COMMENT= SIP testing tool
-WRKSRC= ${WRKDIR}/${PORTNAME}.cumulus.2006-03-20
-
PLIST_FILES= bin/sipp
MAN1= sipp.1
diff --git a/benchmarks/sipp/distinfo b/benchmarks/sipp/distinfo
index 6e53e309f364..5c50d1190e17 100644
--- a/benchmarks/sipp/distinfo
+++ b/benchmarks/sipp/distinfo
@@ -1,3 +1,3 @@
-MD5 (sipp-1.1rc5.tar.gz) = 081412e2a31431dec8c00d8ec0895dbf
-SHA256 (sipp-1.1rc5.tar.gz) = 0d094682d60aaf8579f70dccd4c144ea35b95028ae6140fd66dcebca862f9279
-SIZE (sipp-1.1rc5.tar.gz) = 136055
+MD5 (sipp-1.1rc6.tar.gz) = 05f4b8b4d296c1d0771323eb1dbc14a8
+SHA256 (sipp-1.1rc6.tar.gz) = 2c6c842c1b6d6d5e57eb6b88a3673c01417e87032ebaff8e21c6d5469ab5f386
+SIZE (sipp-1.1rc6.tar.gz) = 157911
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
index 8c57e9d39f6b..ead280cbfc25 100644
--- a/benchmarks/sipp/files/patch-Makefile
+++ b/benchmarks/sipp/files/patch-Makefile
@@ -1,48 +1,47 @@
-
$FreeBSD$
---- Makefile.orig Fri Dec 23 15:49:38 2005
-+++ Makefile Fri Dec 23 15:51:24 2005
-@@ -64,7 +64,7 @@
- CC_tru64=cc
+--- Makefile.orig Tue Aug 29 11:03:34 2006
++++ Makefile Thu Sep 7 22:35:57 2006
+@@ -67,7 +67,7 @@
CC_SunOS=gcc
CC_Cygwin=cc
+ CC_Darwin=cc
-CC=$(CC_$(SYSTEM))
+CC?=$(CC_$(SYSTEM))
# C++ compiler mapping
CPP_hpux=aCC
-@@ -73,7 +73,7 @@
- CPP_tru64=cxx
+@@ -77,7 +77,7 @@
CPP_SunOS=g++
CPP_Cygwin=g++
+ CPP_Darwin=g++
-CPP=$(CPP_$(SYSTEM))
+CPP?=$(CPP_$(SYSTEM))
#Model specific flags
MFLAGS_ia64=+DD64
-@@ -94,7 +94,7 @@
- CFLAGS_tru64=-D__OSF1 -pthread
+@@ -99,7 +99,7 @@
CFLAGS_SunOS=-g
CFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
+ CFLAGS_Darwin=-D__DARWIN
-CFLAGS=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY)
+CFLAGS+=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY)
#C++ Compiler Flags
CPPFLAGS_hpux=-AA -mt -D__HPUX +W829
-@@ -103,7 +103,7 @@
- CPPFLAGS_tru64=-D__OSF1 -pthread
+@@ -109,7 +109,7 @@
CPPFLAGS_SunOS=-g
CPPFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
+ CPPFLAGS_Darwin=-D__DARWIN
-CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY)
+CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY)
#Linker mapping
CCLINK_hpux=aCC
-@@ -112,7 +112,7 @@
- CCLINK_tru64=cxx
+@@ -119,7 +119,7 @@
CCLINK_SunOS=gcc
CCLINK_Cygwin=g++
+ CCLINK_Darwin=g++
-CCLINK=$(CCLINK_$(SYSTEM))
+CCLINK?=$(CCLINK_$(SYSTEM))
diff --git a/benchmarks/sipp/files/patch-auth.c b/benchmarks/sipp/files/patch-auth.c
new file mode 100644
index 000000000000..2ed3be8c1e34
--- /dev/null
+++ b/benchmarks/sipp/files/patch-auth.c
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- auth.c.orig Tue Aug 29 11:03:34 2006
++++ auth.c Thu Sep 7 22:54:05 2006
+@@ -21,6 +21,9 @@
+ * - introduced AKAv1-MD5
+ */
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>