aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-03 12:34:05 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-03 12:34:05 +0000
commit29011d038dd62a251586856d8beb1d94982c9d43 (patch)
tree626ad57321ab9b7a84f12900e716df2e4d4b0d3e /benchmarks
parentc8e11003c24f0cb96c55c48ad01700662a5377bb (diff)
downloadports-29011d038dd62a251586856d8beb1d94982c9d43.tar.gz
ports-29011d038dd62a251586856d8beb1d94982c9d43.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/flowgrind/Makefile1
-rw-r--r--benchmarks/flowgrind/files/patch-fg_socket22
2 files changed, 23 insertions, 0 deletions
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index a5118713f32f..46f87871d13d 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -3,6 +3,7 @@
PORTNAME= flowgrind
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= https://launchpad.net/flowgrind/trunk/${PORTNAME}-0.6/+download/
diff --git a/benchmarks/flowgrind/files/patch-fg_socket b/benchmarks/flowgrind/files/patch-fg_socket
new file mode 100644
index 000000000000..cfb25f25bfd0
--- /dev/null
+++ b/benchmarks/flowgrind/files/patch-fg_socket
@@ -0,0 +1,22 @@
+--- src/fg_socket.h 2013-07-02 14:09:06.000000000 +0200
++++ src/fg_socket.h.orig 2013-07-02 14:07:20.000000000 +0200
+@@ -19,7 +19,7 @@
+ int set_so_lcd(int fd);
+ int set_tcp_mtcp(int fd);
+ int set_tcp_nodelay(int fd);
+-int set_dscp(int sock, uint8_t dscp);
++int set_dscp(int sock, int dscp);
+ int set_tcp_cork(int fd);
+ int toggle_tcp_cork(int fd);
+ int set_window_size(int, int);
+--- src/fg_socket.c 2013-07-02 14:07:12.000000000 +0200
++++ src/fg_socket.c.orig 2013-07-02 14:06:41.000000000 +0200
+@@ -132,7 +132,7 @@
+ return send < receive? send: receive;
+ }
+
+-int set_dscp(int fd, uint8_t dscp)
++int set_dscp(int fd, int dscp)
+ {
+ int optname = IP_TOS;
+ int optlevel = IPPROTO_IP;