aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-10-07 13:13:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-10-07 13:13:10 +0000
commit391d3a2e66e22ae717e9097d3d76acd340c8c0fe (patch)
treee9a966ba222cac614b0e0ebbc912e091488d26c3 /benchmarks
parenta01ce24d15441dd0b7baef1076666859f183dcb7 (diff)
downloadports-391d3a2e66e22ae717e9097d3d76acd340c8c0fe.tar.gz
ports-391d3a2e66e22ae717e9097d3d76acd340c8c0fe.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iperf/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index 452a02711d22..35989bd348b5 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iperf
-# Date Created: 20 May 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= iperf
PORTVERSION= 2.0.5
@@ -13,8 +9,10 @@ MASTER_SITES= SF/${PORTNAME}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A tool to measure maximum TCP and UDP bandwidth
-OPTIONS= IPV6 "Enable support to IPv6" on \
- THREADS "Enable threads support" on
+LICENSE= BSD
+
+OPTIONS_DEFINE= DOCS IPV6 THREADS
+OPTIONS_DEFAULT=IPV6 THREADS
GNU_CONFIGURE= yes
@@ -24,22 +22,24 @@ PORTDOCS= *
.include <bsd.port.options.mk>
-.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+=--disable-ipv6
-.else
+.if ${PORT_OPTIONS:MIPV6}
CATEGORIES+= ipv6
+CONFIGURE_ARGS+=--enable-ipv6
+.else
+CONFIGURE_ARGS+=--disable-ipv6
.endif
-.if defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+=--disable-threads
-.else
+.if ${PORT_OPTIONS:MTHREADS}
+CONFIGURE_ARGS+=--enable-threads
LDFLAGS+= ${PTHREAD_LIBS}
+.else
+CONFIGURE_ARGS+=--disable-threads
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/doc/*.gif ${WRKSRC}/doc/*.html ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} README doc/*.gif doc/*.html ${DOCSDIR}/
.endif
.include <bsd.port.mk>