aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2021-01-15 23:37:53 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2021-01-15 23:37:53 +0000
commit3c82ccec6468e26216de4deeb369c7059f859f8e (patch)
tree18be23119c0f0bc59e6bc737e9d135a82d153891 /benchmarks
parentb87309af3807c030d7dbb2514db3c487325ecb8d (diff)
downloadports-3c82ccec6468e26216de4deeb369c7059f859f8e.tar.gz
ports-3c82ccec6468e26216de4deeb369c7059f859f8e.zip
benchmarks/stress-ng: Add and fix libinotify support
stress-ng supports libinotify. A kevent based implementation can be used to provide support, fixing a build issue reported in PR 252661 PR: 252661 Reported by: dewayne@heuristicsystems.com.au
Notes
Notes: svn path=/head/; revision=561681
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/stress-ng/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/benchmarks/stress-ng/Makefile b/benchmarks/stress-ng/Makefile
index 833eae64857e..c46947710358 100644
--- a/benchmarks/stress-ng/Makefile
+++ b/benchmarks/stress-ng/Makefile
@@ -2,6 +2,7 @@
PORTNAME= stress-ng
PORTVERSION= 0.12.01
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
@@ -13,12 +14,17 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= Fails to link: missing sbrk
+LIB_DEPENDS= libinotify.so:devel/libinotify
+
USES= compiler:c11 gmake tar:xz
ALL_TARGET= # empty
PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz
+CFLAGS += -I${LOCALBASE}/include
+LDFLAGS += -L${LOCALBASE}/lib -linotify
+
post-patch:
${REINPLACE_CMD} -e \
's/int main(void)/int main(void) __attributes__((noinline))/' \