aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-01 19:24:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-01 19:24:15 +0000
commitc965e8351116214d91c5dc5f3f702ebaa0191b51 (patch)
tree2ffa266d08600ef04bd090419afc292fe386f14a /benchmarks
parent83c149d7cb6b742618948a033b7dc3671a684d3f (diff)
downloadports-c965e8351116214d91c5dc5f3f702ebaa0191b51.tar.gz
ports-c965e8351116214d91c5dc5f3f702ebaa0191b51.zip
Update to 2.1.0 RC2
Notes
Notes: svn path=/head/; revision=563615
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iperf/Makefile4
-rw-r--r--benchmarks/iperf/distinfo6
-rw-r--r--benchmarks/iperf/files/patch-src-Settings.cpp47
-rw-r--r--benchmarks/iperf/files/patch-src-SocketAddr.c10
-rw-r--r--benchmarks/iperf/files/patch-src-histogram.c16
5 files changed, 5 insertions, 78 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index 5188b6370d0c..fdddac6d7165 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= iperf
-DISTVERSION= 2.1.0-rc
+DISTVERSION= 2.1.0-rc2
CATEGORIES= benchmarks
MASTER_SITES= SF/iperf2 \
- LOCAL/sunpoet/iperf/20210105
+ LOCAL/sunpoet/iperf/20210128
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Tool to measure maximum TCP and UDP bandwidth
diff --git a/benchmarks/iperf/distinfo b/benchmarks/iperf/distinfo
index 0060bd443ee7..c68294e7c97a 100644
--- a/benchmarks/iperf/distinfo
+++ b/benchmarks/iperf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1609953859
-SHA256 (iperf-2.1.0-rc.tar.gz) = 6b1db400cb9bd4bed3023a1de580c8b9ed2e1597162fb76ed1b3c12c4d7acd1f
-SIZE (iperf-2.1.0-rc.tar.gz) = 381904
+TIMESTAMP = 1612101546
+SHA256 (iperf-2.1.0-rc2.tar.gz) = 6232c32890d59b53f098b12963aa49aeea694ea54bde9596c690e8812fa8f6f3
+SIZE (iperf-2.1.0-rc2.tar.gz) = 376433
diff --git a/benchmarks/iperf/files/patch-src-Settings.cpp b/benchmarks/iperf/files/patch-src-Settings.cpp
deleted file mode 100644
index 7b96b76c0d10..000000000000
--- a/benchmarks/iperf/files/patch-src-Settings.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/Settings.cpp.orig 2020-12-12 00:59:10 UTC
-+++ src/Settings.cpp
-@@ -1054,7 +1054,7 @@ void Settings_ModalOptions (struct thread_Settings *mE
- bail = true;
- } else if (isTxStartTime(mExtSettings) || isTxHoldback(mExtSettings)) {
- Timestamp now;
-- long nowsecs = now.getSecs();
-+ time_t nowsecs = now.getSecs();
- // fill out the formats in the event they are needed per an time error
- char start_timebuf[80];
- struct tm ts = *localtime(&mExtSettings->txstart_epoch.tv_sec);
-@@ -1731,13 +1731,13 @@ int Settings_GenerateClientHdr (struct thread_Settings
- if (isFullDuplex(client) || isReverse(client)) {
- upperflags |= HEADER_ISOCH_SETTINGS;
- hdr->isoch_settings.FPSl = htonl((long)(client->mFPS));
-- hdr->isoch_settings.FPSu = htonl(((client->mFPS - (long)(client->mFPS)) * rMillion));
-+ hdr->isoch_settings.FPSu = htonl((long)((client->mFPS - (long)(client->mFPS)) * rMillion));
- hdr->isoch_settings.Meanl = htonl((long)(client->mMean));
-- hdr->isoch_settings.Meanu = htonl((((client->mMean) - (long)(client->mMean)) * rMillion));
-+ hdr->isoch_settings.Meanu = htonl((long)(((client->mMean) - (long)(client->mMean)) * rMillion));
- hdr->isoch_settings.Variancel = htonl((long)(client->mVariance));
-- hdr->isoch_settings.Varianceu = htonl(((client->mVariance - (long)(client->mVariance)) * rMillion));
-+ hdr->isoch_settings.Varianceu = htonl((long)((client->mVariance - (long)(client->mVariance)) * rMillion));
- hdr->isoch_settings.BurstIPGl = htonl((long)(client->mBurstIPG));
-- hdr->isoch_settings.BurstIPGu = htonl(((client->mBurstIPG - (long)(client->mBurstIPG)) * rMillion));
-+ hdr->isoch_settings.BurstIPGu = htonl((long)((client->mBurstIPG - (long)(client->mBurstIPG)) * rMillion));
- len += sizeof(struct client_hdrext_isoch_settings);
- }
- }
-@@ -1822,13 +1822,13 @@ int Settings_GenerateClientHdr (struct thread_Settings
- upperflags |= HEADER_ISOCH;
- if (isFullDuplex(client) || isReverse(client)) {
- upperflags |= HEADER_ISOCH_SETTINGS;
-- hdr->isoch_settings.FPSl = htonl(client->mFPS);
-+ hdr->isoch_settings.FPSl = htonl((long)client->mFPS);
- hdr->isoch_settings.FPSu = htonl(((long)(client->mFPS) - (long)client->mFPS * rMillion));
-- hdr->isoch_settings.Meanl = htonl(client->mMean);
-+ hdr->isoch_settings.Meanl = htonl((long)client->mMean);
- hdr->isoch_settings.Meanu = htonl(((long)(client->mMean) - (long)client->mMean * rMillion));
-- hdr->isoch_settings.Variancel = htonl(client->mVariance);
-+ hdr->isoch_settings.Variancel = htonl((long)client->mVariance);
- hdr->isoch_settings.Varianceu = htonl(((long)(client->mVariance) - (long)client->mVariance * rMillion));
-- hdr->isoch_settings.BurstIPGl = htonl(client->mBurstIPG);
-+ hdr->isoch_settings.BurstIPGl = htonl((long)client->mBurstIPG);
- hdr->isoch_settings.BurstIPGu = htonl(((long)(client->mBurstIPG) - (long)client->mBurstIPG * rMillion));
- len += sizeof(struct client_hdrext_isoch_settings);
- }
diff --git a/benchmarks/iperf/files/patch-src-SocketAddr.c b/benchmarks/iperf/files/patch-src-SocketAddr.c
deleted file mode 100644
index c0c642033b55..000000000000
--- a/benchmarks/iperf/files/patch-src-SocketAddr.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/SocketAddr.c.orig 2020-11-30 18:53:55 UTC
-+++ src/SocketAddr.c
-@@ -87,6 +87,7 @@ void SockAddr_remoteAddr (struct thread_Settings *inSe
- inSettings->size_peer = sizeof(struct sockaddr_in);
- }
- #else
-+ }
- ((struct sockaddr*)&inSettings->peer)->sa_family = AF_INET;
- inSettings->size_peer = sizeof(struct sockaddr_in);
- #endif
diff --git a/benchmarks/iperf/files/patch-src-histogram.c b/benchmarks/iperf/files/patch-src-histogram.c
deleted file mode 100644
index d0cb80e6c48f..000000000000
--- a/benchmarks/iperf/files/patch-src-histogram.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/histogram.c.orig 2020-11-30 18:53:55 UTC
-+++ src/histogram.c
-@@ -239,11 +239,11 @@ void histogram_print(struct histogram *h, double start
- fprintf(stdout, "%s (%.2f/%.2f/99.7%%=%d/%d/%d,Outliers=%d,obl/obu=%d/%d)", \
- h->outbuf, h->ci_lower, h->ci_upper, lowerci, upperci, upper3stdev, outliercnt, oob_l, oob_u);
- if (!h->final && (h->maxval > 0)) {
-- fprintf(stdout, " (%0.3f ms/%ld.%ld)\n", (h->maxval * 1e3), h->maxts.tv_sec, (long) h->maxts.tv_usec);
-+ fprintf(stdout, " (%0.3f ms/%ld.%ld)\n", (h->maxval * 1e3), (long) h->maxts.tv_sec, (long) h->maxts.tv_usec);
- h->maxbin = -1;
- h->maxval = 0;
- } else if (h->final && (h->fmaxval > 0)) {
-- fprintf(stdout, " (%0.3f ms/%ld.%ld)\n", (h->fmaxval * 1e3), h->fmaxts.tv_sec, (long) h->fmaxts.tv_usec);
-+ fprintf(stdout, " (%0.3f ms/%ld.%ld)\n", (h->fmaxval * 1e3), (long) h->fmaxts.tv_sec, (long) h->fmaxts.tv_usec);
- } else {
- fprintf(stdout, "\n");
- }