aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2021-01-17 21:18:16 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2021-01-17 21:18:16 +0000
commitd03c457c2c31fbcebbdc97a9a2188702261b03a1 (patch)
treec0c5f51da8356b76d5c9fe995a9cd263b0e722fd /benchmarks
parent493f24d6b27c808ead18007ec38137ca0548972e (diff)
downloadports-d03c457c2c31fbcebbdc97a9a2188702261b03a1.tar.gz
ports-d03c457c2c31fbcebbdc97a9a2188702261b03a1.zip
benchmarks/stress-ng: add option to disable inotify support
The option LIBINOTIFY, on by default, can be used to not build inotify stressor and install its dependency. No portrevision bump needed, inotify support was already enable.
Notes
Notes: svn path=/head/; revision=561869
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/stress-ng/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/benchmarks/stress-ng/Makefile b/benchmarks/stress-ng/Makefile
index c46947710358..eb0c67d09641 100644
--- a/benchmarks/stress-ng/Makefile
+++ b/benchmarks/stress-ng/Makefile
@@ -14,16 +14,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= Fails to link: missing sbrk
-LIB_DEPENDS= libinotify.so:devel/libinotify
-
USES= compiler:c11 gmake tar:xz
ALL_TARGET= # empty
PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz
-CFLAGS += -I${LOCALBASE}/include
-LDFLAGS += -L${LOCALBASE}/lib -linotify
+OPTIONS_DEFINE= LIBINOTIFY
+OPTIONS_DEFAULT= LIBINOTIFY
+LIBINOTIFY_DESC= Install the kevent based libinotify to enable its stress
+
+LIBINOTIFY_CFLAGS += -I${LOCALBASE}/include
+LIBINOTIFY_LDFLAGS += -L${LOCALBASE}/lib -linotify
+LIBINOTIFY_LIB_DEPENDS= libinotify.so:devel/libinotify
post-patch:
${REINPLACE_CMD} -e \