aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorGabriel M. Dutra <0xdutra@gmail.com>2022-06-05 11:33:03 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2022-06-05 11:36:06 +0000
commite04d99854758c70e91092f10236b96053427390f (patch)
treebaec91f54ef8417fd4892fe1bed1b523d41c8a33 /benchmarks
parent32c89632762a355932e34738753e83fbce12769c (diff)
downloadports-e04d99854758c70e91092f10236b96053427390f.tar.gz
ports-e04d99854758c70e91092f10236b96053427390f.zip
benchmarks/ddosify: Add new port
High-performance load testing tool Features - Protocol Agnostic - Currently supporting HTTP, HTTPS, HTTP/2. - Scenario-Based - Create your flow in a JSON file. Without a line of code! - Different Load Types - Test your system's limits across different load types. WWW: https://github.com/ddosify/ddosify PR: 264321
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/ddosify/Makefile36
-rw-r--r--benchmarks/ddosify/distinfo21
-rw-r--r--benchmarks/ddosify/pkg-descr8
4 files changed, 66 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 8adc930b9aec..cb6892152da5 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -11,6 +11,7 @@
SUBDIR += cpipe
SUBDIR += dbench
SUBDIR += dbs
+ SUBDIR += ddosify
SUBDIR += dhrystone
SUBDIR += dkftpbench
SUBDIR += fhourstones
diff --git a/benchmarks/ddosify/Makefile b/benchmarks/ddosify/Makefile
new file mode 100644
index 000000000000..6684767b2c39
--- /dev/null
+++ b/benchmarks/ddosify/Makefile
@@ -0,0 +1,36 @@
+# Created by: Gabriel M. Dutra <0xdutra@gmail.com>
+
+PORTNAME= ddosify
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.7.9
+CATEGORIES= benchmarks
+
+MAINTAINER= 0xdutra@gmail.com
+COMMENT= High-performance load testing tool
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_TUPLE= \
+ asaskevich:govalidator:f21760c49a8d:asaskevich_govalidator/vendor/github.com/asaskevich/govalidator \
+ enescakir:emoji:v1.0.0:enescakir_emoji/vendor/github.com/enescakir/emoji \
+ fatih:color:v1.13.0:fatih_color/vendor/github.com/fatih/color \
+ golang:net:2871e0cb64e4:golang_net/vendor/golang.org/x/net \
+ golang:sys:9388b58f7150:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.7:golang_text/vendor/golang.org/x/text \
+ google:uuid:v1.3.0:google_uuid/vendor/github.com/google/uuid \
+ mattn:go-colorable:v0.1.12:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-isatty:v0.0.14:mattn_go_isatty/vendor/github.com/mattn/go-isatty
+
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= EMOJI
+OPTIONS_DEFAULT=EMOJI
+
+EMOJI_DESC= Enable emojis in console output
+EMOJI_RUN_DEPENDS= noto-emoji>0:x11-fonts/noto-emoji
+
+.include <bsd.port.mk>
diff --git a/benchmarks/ddosify/distinfo b/benchmarks/ddosify/distinfo
new file mode 100644
index 000000000000..141a2f581c36
--- /dev/null
+++ b/benchmarks/ddosify/distinfo
@@ -0,0 +1,21 @@
+TIMESTAMP = 1654427166
+SHA256 (ddosify-ddosify-v0.7.9_GH0.tar.gz) = 41e62257d1c3127eee7d5e7e7f7c5d91d7485d80f09589e447efe2e7386dc848
+SIZE (ddosify-ddosify-v0.7.9_GH0.tar.gz) = 550259
+SHA256 (asaskevich-govalidator-f21760c49a8d_GH0.tar.gz) = 8d22a0b8a8870f814314637343ba97d598aed64c026ab1dab045ee43eb34d416
+SIZE (asaskevich-govalidator-f21760c49a8d_GH0.tar.gz) = 62652
+SHA256 (enescakir-emoji-v1.0.0_GH0.tar.gz) = d62dc29e5a3f08b8de6fdb8919089cfa9a82c003466b0b1cb5feb33563612839
+SIZE (enescakir-emoji-v1.0.0_GH0.tar.gz) = 68908
+SHA256 (fatih-color-v1.13.0_GH0.tar.gz) = 326ff785bc0cb5171c17be2a65959e83ee7889ba39412ba4c53c062e2df3ffec
+SIZE (fatih-color-v1.13.0_GH0.tar.gz) = 10826
+SHA256 (golang-net-2871e0cb64e4_GH0.tar.gz) = d8e95c07e6b4a0da251c332c26e927cdd0733eef5c676653d546f9bb4de9245f
+SIZE (golang-net-2871e0cb64e4_GH0.tar.gz) = 1229659
+SHA256 (golang-sys-9388b58f7150_GH0.tar.gz) = 14b5828b22179f331d8f54496f453ecb20a07d66d165cdd7b06bb044b305bc25
+SIZE (golang-sys-9388b58f7150_GH0.tar.gz) = 1303010
+SHA256 (golang-text-v0.3.7_GH0.tar.gz) = 7cab2f6c3133ac1d422edd952b0dd2082fa55a73c2663fb2defd9bf83d649b26
+SIZE (golang-text-v0.3.7_GH0.tar.gz) = 8354718
+SHA256 (google-uuid-v1.3.0_GH0.tar.gz) = 7f7f37c47980e0afcc178a9ffc390bec29ed2371919b4c07658eb01791a7f921
+SIZE (google-uuid-v1.3.0_GH0.tar.gz) = 16210
+SHA256 (mattn-go-colorable-v0.1.12_GH0.tar.gz) = 32493594aee411896ffe13aaed14df4a23c3006866c46c1a908af79eacd102b2
+SIZE (mattn-go-colorable-v0.1.12_GH0.tar.gz) = 9801
+SHA256 (mattn-go-isatty-v0.0.14_GH0.tar.gz) = e6460325edf600297cf2ef68834938fb1c5b8d5f234b3b24ec7c0a29a2d70b39
+SIZE (mattn-go-isatty-v0.0.14_GH0.tar.gz) = 4710
diff --git a/benchmarks/ddosify/pkg-descr b/benchmarks/ddosify/pkg-descr
new file mode 100644
index 000000000000..af54643377e2
--- /dev/null
+++ b/benchmarks/ddosify/pkg-descr
@@ -0,0 +1,8 @@
+High-performance load testing tool
+
+Features
+ - Protocol Agnostic - Currently supporting HTTP, HTTPS, HTTP/2.
+ - Scenario-Based - Create your flow in a JSON file. Without a line of code!
+ - Different Load Types - Test your system's limits across different load types.
+
+WWW: https://github.com/ddosify/ddosify