aboutsummaryrefslogtreecommitdiff
path: root/biology/abyss
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-21 11:43:09 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-21 11:43:09 +0000
commitba101b3372ded51df2ef5672b2b48918873fa42e (patch)
tree8ab4aa9eac6b4179fcf4d94ae9c6bb643702d0f8 /biology/abyss
parent5bbda70d09c66ab393a3e9e954761fb19cc0716e (diff)
downloadports-ba101b3372ded51df2ef5672b2b48918873fa42e.tar.gz
ports-ba101b3372ded51df2ef5672b2b48918873fa42e.zip
biology/abyss: fix build on big-endian architectures
Use new GCC from ports on GCC architectures. Merge 25eb9d2a914fb211fdfe04fcda5593f29fd23ff5, fixes build on GCC architectures. Also include sys/endian.h and use bswap32 and bswap64 for byte-swapping (PR at https://github.com/bcgsc/abyss/pull/287 ). PR: 238737 Approved by: yuri (maintainer), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20717
Notes
Notes: svn path=/head/; revision=504788
Diffstat (limited to 'biology/abyss')
-rw-r--r--biology/abyss/Makefile5
-rw-r--r--biology/abyss/distinfo4
-rw-r--r--biology/abyss/files/patch-Common_city.cc13
3 files changed, 20 insertions, 2 deletions
diff --git a/biology/abyss/Makefile b/biology/abyss/Makefile
index 482193836c85..d1eb83c9b86f 100644
--- a/biology/abyss/Makefile
+++ b/biology/abyss/Makefile
@@ -6,6 +6,9 @@ PORTREVISION= 2
CATEGORIES= biology
MASTER_SITES= http://www.bcgsc.ca/platform/bioinfo/software/${PORTNAME}/releases/${DISTVERSION}/
+PATCH_SITES= https://github.com/bcgsc/${PORTNAME}/commit/
+PATCHFILES= 25eb9d2a914fb211fdfe04fcda5593f29fd23ff5.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Assembly By Short Sequences: parallel, paired-end sequence assembler
@@ -21,7 +24,7 @@ LIB_DEPENDS= libffi.so:devel/libffi \
RUN_DEPENDS= bash:shells/bash \
gmake:devel/gmake
-USES= gmake iconv:wchar_t localbase:ldflags shebangfix sqlite
+USES= compiler:c++11-lang gmake iconv:wchar_t localbase:ldflags shebangfix sqlite
SHEBANG_FILES= bin/${PORTNAME}-*
SHEBANG_LANG= make
make_OLD_CMD= /usr/bin/make
diff --git a/biology/abyss/distinfo b/biology/abyss/distinfo
index 1e1588ec91ed..41338e6eb31f 100644
--- a/biology/abyss/distinfo
+++ b/biology/abyss/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1551061546
+TIMESTAMP = 1561103807
SHA256 (abyss-2.1.5.tar.gz) = 65bfc8241e6ff5adf7601ae4ae93a75e3db86d6bff5d593c75aaff7f0ef41757
SIZE (abyss-2.1.5.tar.gz) = 1201318
+SHA256 (25eb9d2a914fb211fdfe04fcda5593f29fd23ff5.patch) = 93ad66c42610c4fba8cfbe256a2ab689bf4a76974c3b97a9e1094863614ad934
+SIZE (25eb9d2a914fb211fdfe04fcda5593f29fd23ff5.patch) = 1701
diff --git a/biology/abyss/files/patch-Common_city.cc b/biology/abyss/files/patch-Common_city.cc
new file mode 100644
index 000000000000..9fc7031b6639
--- /dev/null
+++ b/biology/abyss/files/patch-Common_city.cc
@@ -0,0 +1,13 @@
+--- Common/city.cc.orig 2018-09-21 23:44:14 UTC
++++ Common/city.cc
+@@ -65,6 +65,10 @@ static uint32 UNALIGNED_LOAD32(const char *p) {
+ #define bswap_32(x) OSSwapInt32(x)
+ #define bswap_64(x) OSSwapInt64(x)
+
++#elif defined(__FreeBSD__)
++#include <sys/endian.h>
++#define bswap_32(x) bswap32(x)
++#define bswap_64(x) bswap64(x)
+ #else
+ #include <byteswap.h>
+ #endif