aboutsummaryrefslogtreecommitdiff
path: root/biology/abyss
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-25 07:56:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-25 07:56:45 +0000
commite2f6302b8e76a9358a04443671f0e0decd750646 (patch)
tree7836fe642cf356dd306f46ef345554604a81a55b /biology/abyss
parent4baf830d0d78333ce8a28166d3d114f09bb46562 (diff)
downloadports-e2f6302b8e76a9358a04443671f0e0decd750646.tar.gz
ports-e2f6302b8e76a9358a04443671f0e0decd750646.zip
Notes
Diffstat (limited to 'biology/abyss')
-rw-r--r--biology/abyss/Makefile35
-rw-r--r--biology/abyss/distinfo3
-rw-r--r--biology/abyss/files/patch-Common_Timer.h11
-rw-r--r--biology/abyss/pkg-descr6
-rw-r--r--biology/abyss/pkg-plist60
5 files changed, 115 insertions, 0 deletions
diff --git a/biology/abyss/Makefile b/biology/abyss/Makefile
new file mode 100644
index 000000000000..fa2ba2f9fabb
--- /dev/null
+++ b/biology/abyss/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= abyss
+DISTVERSION= 2.1.5
+CATEGORIES= biology
+MASTER_SITES= http://www.bcgsc.ca/platform/bioinfo/software/${PORTNAME}/releases/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Assembly By Short Sequences: parallel, paired-end sequence assembler
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs \
+ ghc:lang/ghc \
+ pandoc:textproc/hs-pandoc # pandoc is required just for one man page: abyss-sealer
+LIB_DEPENDS= libffi.so:devel/libffi \
+ libgmp.so:math/gmp \
+ libomp.so:devel/openmp
+RUN_DEPENDS= bash:shells/bash \
+ gmake:devel/gmake
+
+USES= gmake iconv:wchar_t localbase:ldflags shebangfix sqlite
+SHEBANG_FILES= bin/${PORTNAME}-*
+SHEBANG_LANG= make
+make_OLD_CMD= /usr/bin/make
+make_CMD= ${PREFIX}/bin/gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-sparsehash # configure fails to find std::hash, reported to the ML: https://groups.google.com/forum/#!topic/trans-abyss/SZDBKR5bKxs
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/biology/abyss/distinfo b/biology/abyss/distinfo
new file mode 100644
index 000000000000..1e1588ec91ed
--- /dev/null
+++ b/biology/abyss/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1551061546
+SHA256 (abyss-2.1.5.tar.gz) = 65bfc8241e6ff5adf7601ae4ae93a75e3db86d6bff5d593c75aaff7f0ef41757
+SIZE (abyss-2.1.5.tar.gz) = 1201318
diff --git a/biology/abyss/files/patch-Common_Timer.h b/biology/abyss/files/patch-Common_Timer.h
new file mode 100644
index 000000000000..134b35c1e848
--- /dev/null
+++ b/biology/abyss/files/patch-Common_Timer.h
@@ -0,0 +1,11 @@
+--- Common/Timer.h.orig 2019-02-25 02:35:12 UTC
++++ Common/Timer.h
+@@ -3,6 +3,8 @@
+
+ #include <string>
+
++#include <time.h>
++
+ /**
+ * Time the duration between the construction and destruction of this
+ * timer object and log that duration.
diff --git a/biology/abyss/pkg-descr b/biology/abyss/pkg-descr
new file mode 100644
index 000000000000..77140fda19ac
--- /dev/null
+++ b/biology/abyss/pkg-descr
@@ -0,0 +1,6 @@
+ABySS is a de novo, parallel, paired-end sequence assembler that is designed for
+short reads. The single-processor version is useful for assembling genomes up to
+100 Mbases in size. The parallel version is implemented using MPI and is capable
+of assembling larger genomes.
+
+WWW: http://www.bcgsc.ca/platform/bioinfo/software/abyss
diff --git a/biology/abyss/pkg-plist b/biology/abyss/pkg-plist
new file mode 100644
index 000000000000..94ec1d8d98df
--- /dev/null
+++ b/biology/abyss/pkg-plist
@@ -0,0 +1,60 @@
+bin/ABYSS
+bin/ABYSS-P
+bin/AdjList
+bin/Consensus
+bin/DAssembler
+bin/DistanceEst
+bin/DistanceEst-ssq
+bin/KAligner
+bin/MergeContigs
+bin/MergePaths
+bin/Overlap
+bin/ParseAligns
+bin/PathConsensus
+bin/PathOverlap
+bin/PopBubbles
+bin/SimpleGraph
+bin/abyss-align
+bin/abyss-bloom
+bin/abyss-bloom-dbg
+bin/abyss-bloom-dist.mk
+bin/abyss-bowtie
+bin/abyss-bowtie2
+bin/abyss-bwa
+bin/abyss-bwamem
+bin/abyss-bwasw
+bin/abyss-db-csv
+bin/abyss-db-txt
+bin/abyss-dida
+bin/abyss-fac
+bin/abyss-fatoagp
+bin/abyss-filtergraph
+bin/abyss-fixmate
+bin/abyss-fixmate-ssq
+bin/abyss-gapfill
+bin/abyss-gc
+bin/abyss-index
+bin/abyss-junction
+bin/abyss-kaligner
+bin/abyss-layout
+bin/abyss-longseqdist
+bin/abyss-map
+bin/abyss-map-ssq
+bin/abyss-mergepairs
+bin/abyss-overlap
+bin/abyss-paired-dbg
+bin/abyss-pe
+bin/abyss-samtoafg
+bin/abyss-samtobreak
+bin/abyss-scaffold
+bin/abyss-sealer
+bin/abyss-stack-size
+bin/abyss-tabtomd
+bin/abyss-todot
+bin/abyss-tofastq
+bin/konnector
+bin/logcounter
+man/man1/ABYSS.1.gz
+man/man1/abyss-pe.1.gz
+man/man1/abyss-sealer.1.gz
+man/man1/abyss-tofastq.1.gz