aboutsummaryrefslogtreecommitdiff
path: root/biology/bifrost
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-07-16 13:40:30 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-07-16 13:40:30 +0000
commit7d4be2d6fd1e3db4109d266d25a4411fedc05235 (patch)
tree7f2579b42062ef4cd72e20dbf4a02c297ace1709 /biology/bifrost
parent63e5ba4396f40d97df99b2856113afcb7623d7c9 (diff)
downloadports-7d4be2d6fd1e3db4109d266d25a4411fedc05235.tar.gz
ports-7d4be2d6fd1e3db4109d266d25a4411fedc05235.zip
biology/bifrost: Portability fixes
Tag as only for 64-bit platforms Fix build on aarch64 (patch out -march=native) Reported by: pkg-fallout
Diffstat (limited to 'biology/bifrost')
-rw-r--r--biology/bifrost/Makefile3
-rw-r--r--biology/bifrost/files/patch-CMakeLists.txt11
2 files changed, 14 insertions, 0 deletions
diff --git a/biology/bifrost/Makefile b/biology/bifrost/Makefile
index 1ca58622a09a..d5afacfb4181 100644
--- a/biology/bifrost/Makefile
+++ b/biology/bifrost/Makefile
@@ -10,6 +10,9 @@ WWW= https://github.com/pmelsted/bifrost
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+# Requires a 64-bit processor
+ONLY_FOR_ARCHS= aarch64 amd64 powerpc64 powerpc64le riscv64
+
USES= cmake
USE_GITHUB= yes
diff --git a/biology/bifrost/files/patch-CMakeLists.txt b/biology/bifrost/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1cf55ff9575f
--- /dev/null
+++ b/biology/bifrost/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2023-07-16 13:25:06 UTC
++++ CMakeLists.txt
+@@ -20,8 +20,6 @@ if(COMPILATION_ARCH MATCHES "OFF")
+ message("Disabling native architecture compilation (including AVX2)")
+ else(COMPILATION_ARCH MATCHES "OFF")
+ message("Compilation architecture: ${COMPILATION_ARCH}")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=${COMPILATION_ARCH}")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=${COMPILATION_ARCH}")
+ endif(COMPILATION_ARCH MATCHES "OFF")
+
+ if(ENABLE_AVX2 MATCHES "OFF")