aboutsummaryrefslogtreecommitdiff
path: root/biology/bifrost
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-08-12 14:38:47 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-08-12 14:38:47 +0000
commitf38473fec0a852349f186e1d28358fc2ce5636de (patch)
treede5e1c7d0de4babf34332233ce583b772cbc5588 /biology/bifrost
parent519c9cc9f61fb1c5d44d563cd3d2594aa2c33ac9 (diff)
downloadports-f38473fec0a852349f186e1d28358fc2ce5636de.tar.gz
ports-f38473fec0a852349f186e1d28358fc2ce5636de.zip
biology/bifrost: Control -march via CPUTYPE make variable
Also disable hard-coded -O3 in cmake to respect user env PR: 272651 Reported by: yuri Reviewed by: nimaje+fbz@bureaucracy.de, dizzy
Diffstat (limited to 'biology/bifrost')
-rw-r--r--biology/bifrost/Makefile5
-rw-r--r--biology/bifrost/files/patch-CMakeLists.txt17
2 files changed, 12 insertions, 10 deletions
diff --git a/biology/bifrost/Makefile b/biology/bifrost/Makefile
index d5afacfb4181..197f58a662dc 100644
--- a/biology/bifrost/Makefile
+++ b/biology/bifrost/Makefile
@@ -1,6 +1,7 @@
PORTNAME= bifrost
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -10,12 +11,14 @@ WWW= https://github.com/pmelsted/bifrost
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-# Requires a 64-bit processor
ONLY_FOR_ARCHS= aarch64 amd64 powerpc64 powerpc64le riscv64
+ONLY_FOR_ARCHS_REASON= Requires a 64-bit processor
USES= cmake
USE_GITHUB= yes
+CMAKE_ARGS= -DCOMPILATION_ARCH=${CPUTYPE:UOFF}
+
GH_ACCOUNT= pmelsted
.include <bsd.port.mk>
diff --git a/biology/bifrost/files/patch-CMakeLists.txt b/biology/bifrost/files/patch-CMakeLists.txt
index 1cf55ff9575f..27893b9ec44d 100644
--- a/biology/bifrost/files/patch-CMakeLists.txt
+++ b/biology/bifrost/files/patch-CMakeLists.txt
@@ -1,11 +1,10 @@
---- CMakeLists.txt.orig 2023-07-16 13:25:06 UTC
+--- CMakeLists.txt.orig 2023-08-12 14:26:29 UTC
+++ CMakeLists.txt
-@@ -20,8 +20,6 @@ if(COMPILATION_ARCH MATCHES "OFF")
- message("Disabling native architecture compilation (including AVX2)")
- else(COMPILATION_ARCH MATCHES "OFF")
- message("Compilation architecture: ${COMPILATION_ARCH}")
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=${COMPILATION_ARCH}")
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=${COMPILATION_ARCH}")
- endif(COMPILATION_ARCH MATCHES "OFF")
+@@ -46,7 +46,6 @@ else(CMAKE_BUILD_TYPE MATCHES Debug)
+ set(CMAKE_EXE_LINKER_FLAGS "-pg")
+ else(CMAKE_BUILD_TYPE MATCHES Profile)
+ message("Build type: Release")
+- add_compile_options(-O3)
+ endif(CMAKE_BUILD_TYPE MATCHES Profile)
+ endif(CMAKE_BUILD_TYPE MATCHES Debug)
- if(ENABLE_AVX2 MATCHES "OFF")