aboutsummaryrefslogtreecommitdiff
path: root/biology/bowtie2
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-23 11:22:39 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-23 11:22:39 +0000
commitbc3c1d13d61545e1c2da83a8ad636f16036c6cba (patch)
tree0e3904a8d452b2322757fa1730f4be8a34411db4 /biology/bowtie2
parent66631eff7591e484c730eae5d244afb0e4f753af (diff)
downloadports-bc3c1d13d61545e1c2da83a8ad636f16036c6cba.tar.gz
ports-bc3c1d13d61545e1c2da83a8ad636f16036c6cba.zip
New port: biology/bowtie2.
Bowtie is an ultrafast, memory-efficient short read aligner. It aligns short DNA sequences (reads) to the human genome at a rate of over 25 million 35-bp reads per hour. This is Bowtie version 2, which will need to coexists with Bowtie 1 for the foreseeable future. Both are required by certain genomics pipelines, in some cases (e.g. Trinity) by the same pipeline. WWW: https://github.com/BenLangmead/bowtie2 PR: 207908 Submitted by: Jason Bacon <bacon4000@gmail.com>
Notes
Notes: svn path=/head/; revision=411698
Diffstat (limited to 'biology/bowtie2')
-rw-r--r--biology/bowtie2/Makefile40
-rw-r--r--biology/bowtie2/distinfo2
-rw-r--r--biology/bowtie2/files/patch-Makefile22
-rw-r--r--biology/bowtie2/pkg-descr5
-rw-r--r--biology/bowtie2/pkg-plist64
5 files changed, 133 insertions, 0 deletions
diff --git a/biology/bowtie2/Makefile b/biology/bowtie2/Makefile
new file mode 100644
index 000000000000..9a37e9cb81b4
--- /dev/null
+++ b/biology/bowtie2/Makefile
@@ -0,0 +1,40 @@
+# Created by: Jason Bacon
+# $FreeBSD$
+
+PORTNAME= bowtie2
+PORTVERSION= 2.2.7
+DISTVERSIONPREFIX= v
+CATEGORIES= biology
+
+MAINTAINER= bacon4000@gmail.com
+COMMENT= Ultrafast, memory-efficient short read aligner
+
+LICENSE= GPLv3
+
+# May also work on other 64-bit platforms, but untested
+ONLY_FOR_ARCHS= amd64
+USES= gmake perl5 shebangfix
+USE_PERL5= run
+SHEBANG_FILES= scripts/*.pl
+
+USE_GITHUB= yes
+GH_ACCOUNT= BenLangmead
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/scripts
+ ${INSTALL_PROGRAM} \
+ ${WRKSRC}/bowtie2*-s \
+ ${WRKSRC}/bowtie2*-l \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} \
+ ${WRKSRC}/scripts/*.sh \
+ ${WRKSRC}/scripts/*.pl \
+ ${STAGEDIR}${DATADIR}/scripts
+ cd ${WRKSRC}/example && ${COPYTREE_SHARE} \
+ 'index reads reference' \
+ ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
+ \* \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/biology/bowtie2/distinfo b/biology/bowtie2/distinfo
new file mode 100644
index 000000000000..a77e0bcf15e3
--- /dev/null
+++ b/biology/bowtie2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (BenLangmead-bowtie2-v2.2.7_GH0.tar.gz) = 54a66a1ce0d1afa75198cc10e9e4e7436cc86cd7d6d93ae41c079462a1c19916
+SIZE (BenLangmead-bowtie2-v2.2.7_GH0.tar.gz) = 5813850
diff --git a/biology/bowtie2/files/patch-Makefile b/biology/bowtie2/files/patch-Makefile
new file mode 100644
index 000000000000..be8a43586cec
--- /dev/null
+++ b/biology/bowtie2/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig 2016-02-11 17:20:57 UTC
++++ Makefile
+@@ -21,8 +21,8 @@
+ # Makefile for bowtie, bowtie2-build, bowtie2-inspect
+ #
+
+-prefix = /usr/local
+-bindir = $(prefix)/bin
++PREFIX ?= /usr/local
++bindir = $(PREFIX)/bin
+
+ INC =
+ GCC_PREFIX = $(shell dirname `which gcc`)
+@@ -169,7 +169,7 @@ SSE_FLAG=-msse2
+
+ DEBUG_FLAGS = -O0 -g3 -m64 $(SSE_FLAG)
+ DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(EXTRA_FLAGS)\""
+-RELEASE_FLAGS = -O3 -m64 $(SSE_FLAG) -funroll-loops -g3
++RELEASE_FLAGS = $(CXXFLAGS) $(SSE_FLAG) -funroll-loops
+ RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(EXTRA_FLAGS)\""
+ NOASSERT_FLAGS = -DNDEBUG
+ FILE_FLAGS = -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
diff --git a/biology/bowtie2/pkg-descr b/biology/bowtie2/pkg-descr
new file mode 100644
index 000000000000..05ac47289c51
--- /dev/null
+++ b/biology/bowtie2/pkg-descr
@@ -0,0 +1,5 @@
+Bowtie is an ultrafast, memory-efficient short read aligner. It aligns short
+DNA sequences (reads) to the human genome at a rate of over 25 million 35-bp
+reads per hour.
+
+WWW: https://github.com/BenLangmead/bowtie2
diff --git a/biology/bowtie2/pkg-plist b/biology/bowtie2/pkg-plist
new file mode 100644
index 000000000000..aeb30e8203aa
--- /dev/null
+++ b/biology/bowtie2/pkg-plist
@@ -0,0 +1,64 @@
+bin/bowtie2
+bin/bowtie2-align-l
+bin/bowtie2-align-s
+bin/bowtie2-build
+bin/bowtie2-build-l
+bin/bowtie2-build-s
+bin/bowtie2-inspect
+bin/bowtie2-inspect-l
+bin/bowtie2-inspect-s
+%%DATADIR%%/scripts/convert_quals.pl
+%%DATADIR%%/scripts/gen_2b_occ_lookup.pl
+%%DATADIR%%/scripts/gen_occ_lookup.pl
+%%DATADIR%%/scripts/gen_solqual_lookup.pl
+%%DATADIR%%/scripts/infer_fraglen.pl
+%%DATADIR%%/scripts/make_a_thaliana_tair.sh
+%%DATADIR%%/scripts/make_b_taurus_UMD3.sh
+%%DATADIR%%/scripts/make_c_elegans.sh
+%%DATADIR%%/scripts/make_canFam2.sh
+%%DATADIR%%/scripts/make_d_melanogaster.sh
+%%DATADIR%%/scripts/make_e_coli.sh
+%%DATADIR%%/scripts/make_h_sapiens_ncbi36.sh
+%%DATADIR%%/scripts/make_h_sapiens_ncbi37.sh
+%%DATADIR%%/scripts/make_hg18.sh
+%%DATADIR%%/scripts/make_hg19.sh
+%%DATADIR%%/scripts/make_m_musculus_ncbi37.sh
+%%DATADIR%%/scripts/make_mm10.sh
+%%DATADIR%%/scripts/make_mm9.sh
+%%DATADIR%%/scripts/make_rn4.sh
+%%DATADIR%%/scripts/make_s_cerevisiae.sh
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/images/bowtie_logo.png
+%%PORTDOCS%%%%DOCSDIR%%/images/osi-certified.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/sflogo.png
+%%PORTDOCS%%%%DOCSDIR%%/images/university.small.horizontal.white.png
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/release.txt
+%%PORTDOCS%%%%DOCSDIR%%/strip_markdown.pl
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/website/faq.shtml
+%%PORTDOCS%%%%DOCSDIR%%/website/faq.ssi
+%%PORTDOCS%%%%DOCSDIR%%/website/foot.ssi
+%%PORTDOCS%%%%DOCSDIR%%/website/index.html
+%%PORTDOCS%%%%DOCSDIR%%/website/index.shtml
+%%PORTDOCS%%%%DOCSDIR%%/website/manual.shtml
+%%PORTDOCS%%%%DOCSDIR%%/website/manual.ssi
+%%PORTDOCS%%%%DOCSDIR%%/website/news.shtml
+%%PORTDOCS%%%%DOCSDIR%%/website/old_news.ssi
+%%PORTDOCS%%%%DOCSDIR%%/website/other_tools.shtml
+%%PORTDOCS%%%%DOCSDIR%%/website/push.sh
+%%PORTDOCS%%%%DOCSDIR%%/website/push_images.sh
+%%PORTDOCS%%%%DOCSDIR%%/website/recent_news.ssi
+%%PORTDOCS%%%%DOCSDIR%%/website/rhsidebar.ssi
+%%PORTDOCS%%%%DOCSDIR%%/website/top.ssi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/lambda_virus.1.bt2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/lambda_virus.2.bt2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/lambda_virus.3.bt2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/lambda_virus.4.bt2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/lambda_virus.rev.1.bt2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index/lambda_virus.rev.2.bt2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reads/longreads.fq
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reads/reads_1.fq
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reads/reads_2.fq
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reads/simulate.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reference/lambda_virus.fa