aboutsummaryrefslogtreecommitdiff
path: root/biology/bwa
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-02 15:01:55 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-02 15:01:55 +0000
commit18226fe0638a70389025c505eeeccbccf81fc071 (patch)
treebdb70a9be7d3d70743e4f0f87229c421a3162ff2 /biology/bwa
parentd1958e1679592af153294a2667bb11f596b1c59d (diff)
downloadports-18226fe0638a70389025c505eeeccbccf81fc071.tar.gz
ports-18226fe0638a70389025c505eeeccbccf81fc071.zip
biology/bwa: fix build on powerpc64le
Use GCC's SSE->Altivec translation: In file included from ksw.c:29: In file included from /usr/lib/clang/11.0.1/include/emmintrin.h:13: In file included from /usr/lib/clang/11.0.1/include/xmmintrin.h:13: /usr/lib/clang/11.0.1/include/mmintrin.h:50:12: error: invalid conversion between vector type '__m64' (vector of 1 'long long' value) and integer type 'int' of different size return (__m64)__builtin_ia32_vec_init_v2si(__i, 0);
Notes
Notes: svn path=/head/; revision=566960
Diffstat (limited to 'biology/bwa')
-rw-r--r--biology/bwa/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index 31f9e074d8ba..0925d101c312 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -31,11 +31,14 @@ GH_ACCOUNT= lh3
PLIST_FILES= bin/bwa bin/qualfa2fq.pl bin/xa2multi.pl man/man1/bwa.1.gz
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == amd64 || ${ARCH} == i386
# Avoid #error in emmintrin.h
CFLAGS+= -msse2
+.elif ${ARCH} == powerpc64le
+CFLAGS+= -DNO_WARN_X86_INTRINSICS
+USES+= compiler:gcc-c++11-lib
.endif
do-install:
@@ -43,4 +46,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>