aboutsummaryrefslogtreecommitdiff
path: root/biology/fasta/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-02 10:35:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-02 10:35:25 +0000
commit052e3152179a31249625364475232036695b5ad8 (patch)
tree8b937a5d64ec1cea631ca2c485ffda8a1fa3f7bb /biology/fasta/Makefile
parent670f0e0e428359b77be8a92887e94fb539d091af (diff)
downloadports-052e3152179a31249625364475232036695b5ad8.tar.gz
ports-052e3152179a31249625364475232036695b5ad8.zip
Notes
Diffstat (limited to 'biology/fasta/Makefile')
-rw-r--r--biology/fasta/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/biology/fasta/Makefile b/biology/fasta/Makefile
index 44538b92eac2..7ce6dbd3e2ec 100644
--- a/biology/fasta/Makefile
+++ b/biology/fasta/Makefile
@@ -13,7 +13,6 @@ COMMENT= Collection of programs for searching DNA and protein databases
NO_CDROM= May not be sold or incorporated into a commercial product
WRKSRC= ${WRKDIR}/fasta
-PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
MAN_FILES= align.1 fasta.1 lalign.1 prdf.1 prss.1 randseq.1 ssearch.1
@@ -32,19 +31,14 @@ do-extract:
post-patch:
@${REINPLACE_CMD} 's|BIN)|DESTDIR)$$(&|' ${WRKSRC}/Makefile
-BROKEN_powerpc= Does not build: runs out of space on powerpc
-
post-install:
- (cd ${WRKSRC} && ${INSTALL_MAN} ${MAN_FILES} \
- ${STAGEDIR}${MAN1PREFIX}/man/man1)
+ ${INSTALL_MAN} ${MAN_FILES:S,^,${WRKSRC}/,} \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
.for mlink in tfasta lfasta plfasta fastx tfastx
- ${LN} -s ${MAN1PREFIX}/man/man1/fasta.1.gz \
- ${STAGEDIR}${MAN1PREFIX}/man/man1/${mlink}.1.gz
+ ${LN} -s fasta.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1/${mlink}.1.gz
.endfor
- ${LN} -s ${MAN1PREFIX}/man/man1/align.1.gz \
- ${STAGEDIR}${MAN1PREFIX}/man/man1/align0.1.gz
- ${LN} -s ${MAN1PREFIX}/man/man1/align.1.gz \
- ${STAGEDIR}${MAN1PREFIX}/man/man1/plalign.1.gz
+ ${LN} -s align.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1/align0.1.gz
+ ${LN} -s align.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1/plalign.1.gz
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}