aboutsummaryrefslogtreecommitdiff
path: root/biology/fastdnaml/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-08-26 00:24:48 +0000
committerWen Heping <wen@FreeBSD.org>2011-08-26 00:24:48 +0000
commit5879d16b61e3a1192ac1db52e0c8c2005c0d17c4 (patch)
treed5ff02a075bce9274addef1718e2f59bd0f846c5 /biology/fastdnaml/Makefile
parent2ab660d1babc1b1cdfb472d2c11e487c01383e01 (diff)
downloadports-5879d16b61e3a1192ac1db52e0c8c2005c0d17c4.tar.gz
ports-5879d16b61e3a1192ac1db52e0c8c2005c0d17c4.zip
Notes
Diffstat (limited to 'biology/fastdnaml/Makefile')
-rw-r--r--biology/fastdnaml/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/biology/fastdnaml/Makefile b/biology/fastdnaml/Makefile
index 39a3c51d8e2a..57b0369bf71d 100644
--- a/biology/fastdnaml/Makefile
+++ b/biology/fastdnaml/Makefile
@@ -7,30 +7,28 @@
PORTNAME= fastdnaml
PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology
-MASTER_SITES= http://geta.life.uiuc.edu:80/~gary/programs/fastDNAml/
+MASTER_SITES= http://www.life.illinois.edu/gary/programs/fastDNAml/
DISTNAME= fastDNAml_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Faster DNAML, makes phylogenetic trees using maximum likelihood
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/GNU_GENERAL_PUBLIC_LICENSE
-USE_GMAKE= yes
-do-build:
- @(cd ${WRKSRC}/source; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+BUILD_WRKSRC= ${WRKSRC}/source
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/source/fastDNAml ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/fastDNAml ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/bin/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/scripts/* ${PREFIX}/bin/${PORTNAME}
-
-post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${PREFIX}/share/doc/${PORTNAME}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>