aboutsummaryrefslogtreecommitdiff
path: root/biology/fasttree
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2017-12-05 03:03:38 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2017-12-05 03:03:38 +0000
commit578a3edd2c098c561c9cd788bfcba4f8996c2310 (patch)
treed8799b7e4d4ce91096f6828b8eac5f6d05d2fa87 /biology/fasttree
parente1cf50b763e2ae4d5f22f93c6b55de4dc7b29465 (diff)
downloadports-578a3edd2c098c561c9cd788bfcba4f8996c2310.tar.gz
ports-578a3edd2c098c561c9cd788bfcba4f8996c2310.zip
biology/fasttree: update to version 2.1.10
Approved by: jrm Differential Revision: https://reviews.freebsd.org/D8187
Notes
Notes: svn path=/head/; revision=455562
Diffstat (limited to 'biology/fasttree')
-rw-r--r--biology/fasttree/Makefile23
-rw-r--r--biology/fasttree/distinfo5
-rw-r--r--biology/fasttree/files/Makefile25
-rw-r--r--biology/fasttree/files/patch-FastTree-2.1.10.c11
4 files changed, 45 insertions, 19 deletions
diff --git a/biology/fasttree/Makefile b/biology/fasttree/Makefile
index 617ac37291d0..ed3311adefda 100644
--- a/biology/fasttree/Makefile
+++ b/biology/fasttree/Makefile
@@ -1,34 +1,23 @@
-# Created by: Jason Bacon <bacon4000@gmail.com>
# $FreeBSD$
PORTNAME= FastTree
-PORTVERSION= 2.1.8
-PORTREVISION= 3
+DISTVERSION= 2.1.10
CATEGORIES= biology
MASTER_SITES= http://www.microbesonline.org/fasttree/
EXTRACT_SUFX= .c
-MAINTAINER= bacon4000@gmail.com
+MAINTAINER= jwb@FreeBSD.org
COMMENT= Approximately-maximum-likelihood phylogenetic trees from alignments
-# LICENSE= unspecified open source
+LICENSE= GPLv2+
USES= compiler:openmp
-CFLAGS+= -DOPENMP -fopenmp -O3 -finline-functions -funroll-loops
-LDFLAGS+= -lm
-
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/FastTree
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
-
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} -o FastTree ${DISTFILES} ${LDFLAGS}
-
-do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/FastTree ${STAGEDIR}${PREFIX}/bin
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
.include <bsd.port.mk>
diff --git a/biology/fasttree/distinfo b/biology/fasttree/distinfo
index abd99c4d0c3c..2777da148528 100644
--- a/biology/fasttree/distinfo
+++ b/biology/fasttree/distinfo
@@ -1,2 +1,3 @@
-SHA256 (FastTree-2.1.8.c) = b172d160f1b12b764d21a6937c3ce01ba42fa8743d95e083e031c6947762f837
-SIZE (FastTree-2.1.8.c) = 385231
+TIMESTAMP = 1512317739
+SHA256 (FastTree-2.1.10.c) = 54cb89fc1728a974a59eae7a7ee6309cdd3cddda9a4c55b700a71219fc6e926d
+SIZE (FastTree-2.1.10.c) = 390916
diff --git a/biology/fasttree/files/Makefile b/biology/fasttree/files/Makefile
new file mode 100644
index 000000000000..ada070cda53b
--- /dev/null
+++ b/biology/fasttree/files/Makefile
@@ -0,0 +1,25 @@
+
+BIN = FastTree
+SRC = FastTree*.c
+CC ?= gcc
+CFLAGS ?= -O3
+CFLAGS += -DOPENMP -fopenmp -finline-functions -funroll-loops
+
+MKDIR ?= mkdir
+INSTALL ?= install
+PREFIX ?= /usr/local
+DESTDIR ?= .
+
+.PHONY: all install clean
+
+all: ${BIN}
+
+${BIN}: ${SRC} Makefile
+ ${CC} ${CFLAGS} ${SRC} -o ${BIN} -lm
+
+install: ${BIN}
+ ${MKDIR} -p ${DESTDIR}${PREFIX}/bin
+ ${INSTALL} -s -c ${BIN} ${DESTDIR}${PREFIX}/bin
+
+clean:
+ ${RM} -f ${BIN}
diff --git a/biology/fasttree/files/patch-FastTree-2.1.10.c b/biology/fasttree/files/patch-FastTree-2.1.10.c
new file mode 100644
index 000000000000..36dd31ceb877
--- /dev/null
+++ b/biology/fasttree/files/patch-FastTree-2.1.10.c
@@ -0,0 +1,11 @@
+--- FastTree-2.1.10.c.orig 2017-12-04 15:09:11 UTC
++++ FastTree-2.1.10.c
+@@ -8759,7 +8759,7 @@ double pnorm(double x)
+
+ void *mymalloc(size_t sz) {
+ if (sz == 0) return(NULL);
+- void *new = malloc(sz);
++ void *new = aligned_alloc(16, sz);
+ if (new == NULL) {
+ fprintf(stderr, "Out of memory\n");
+ exit(1);