aboutsummaryrefslogtreecommitdiff
path: root/biology/gatk/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-02-09 05:57:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-02-09 05:57:04 +0000
commit8b908b1f84a5650d6336294f779e6d146b2b10e7 (patch)
tree503fef22432d7a1da69be43632e8daf1bfd66956 /biology/gatk/Makefile
parent235a81d83cdb34c11be89b5e6c7bfea9b4bcf6fb (diff)
downloadports-8b908b1f84a5650d6336294f779e6d146b2b10e7.tar.gz
ports-8b908b1f84a5650d6336294f779e6d146b2b10e7.zip
Notes
Diffstat (limited to 'biology/gatk/Makefile')
-rw-r--r--biology/gatk/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/biology/gatk/Makefile b/biology/gatk/Makefile
index aea96bcff0a2..a17f7b426d87 100644
--- a/biology/gatk/Makefile
+++ b/biology/gatk/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gatk
DISTVERSION= 4.1.4.1
+PORTREVISION= 1
CATEGORIES= biology java
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -11,7 +12,7 @@ COMMENT= Variant discovery in high-throughput sequencing data
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
-BUILD_DEPENDS= gradle5:devel/gradle5
+BUILD_DEPENDS= gradle:devel/gradle
USES= gettext-runtime
USE_GITHUB= yes
@@ -23,7 +24,7 @@ SUB_LIST= PORTVERSION=${PORTVERSION} JAVA=${JAVA}
NO_ARCH= yes
-DEPS_CACHE_DIR= /tmp # should be ${WRKDIR}, but workaround for the gradle bug that dependency cache is not relocable: https://github.com/gradle/gradle/issues/1338
+DEPS_CACHE_DIR= ${WRKDIR}
PLIST_FILES= bin/${PORTNAME} \
${JAVAJARDIR}/GenomeAnalysisTK-${PORTVERSION}.jar
@@ -52,7 +53,7 @@ post-extract: # need a separate extract step because the cache is in /tmp, and n
do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle5 \
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle \
--gradle-user-home ${DEPS_CACHE_DIR}/gradle-${PORTNAME} --project-cache-dir ${DEPS_CACHE_DIR}/gradle-${PORTNAME} \
${GRADLE_ARGS} --build-cache localJar