aboutsummaryrefslogtreecommitdiff
path: root/biology/hmmer/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-25 22:35:52 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-25 22:35:52 +0000
commit3b1950174468942bd06f5248d30f7bb16ac740f6 (patch)
treed71cb0eef2f2567e0415a23c994f5500174019b1 /biology/hmmer/Makefile
parentdc5dd31002e61348ab7327575b7899b0b85f09dc (diff)
downloadports-3b1950174468942bd06f5248d30f7bb16ac740f6.tar.gz
ports-3b1950174468942bd06f5248d30f7bb16ac740f6.zip
Notes
Diffstat (limited to 'biology/hmmer/Makefile')
-rw-r--r--biology/hmmer/Makefile31
1 files changed, 20 insertions, 11 deletions
diff --git a/biology/hmmer/Makefile b/biology/hmmer/Makefile
index f3e4aa53ce80..c4e8f4a422ac 100644
--- a/biology/hmmer/Makefile
+++ b/biology/hmmer/Makefile
@@ -6,24 +6,29 @@
#
PORTNAME= hmmer
-PORTVERSION= 2.2.g
-PORTREVISION= 1
+PORTVERSION= 2.3.2
CATEGORIES= biology
-MASTER_SITES= ftp://ftp.genetics.wustl.edu/pub/eddy/hmmer/${VERSIONSTRING}/
-DISTNAME= ${PORTNAME}-${VERSIONSTRING}
+MASTER_SITES= ftp://ftp.genetics.wustl.edu/pub/eddy/hmmer/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fernan@iib.unsam.edu.ar
COMMENT= Profile hidden Markov models for biological sequence analysis
GNU_CONFIGURE= yes
USE_PERL5= yes
-VERSIONSTRING= ${PORTVERSION:C|\.([^.]*)$|\1|}
+CONFIGURE_ARGS+=--enable-threads --enable-lfs
-DOCFILES= 00README COPYRIGHT NOTES Userguide.pdf
-MAN1= afetch.1 alistat.1 hmmalign.1 hmmbuild.1 hmmcalibrate.1 \
- hmmconvert.1 hmmemit.1 hmmer.1 hmmfetch.1 hmmindex.1 \
- hmmpfam.1 hmmsearch.1 seqstat.1 sfetch.1 shuffle.1 \
- sreformat.1
+DOCFILES= 00README COPYRIGHT INSTALL LICENSE NOTES Userguide.pdf
+EXAMPLES= 7LES_DROME amino.null globins50.msf nucleic.pri rrm.sto \
+ Artemia.fa amino.pri globins630.fa pkinase.sto RU1A_HUMAN \
+ fn3.sto nucleic.null rrm.hmm
+MAN1= hmmalign.1 hmmbuild.1 hmmcalibrate.1 hmmconvert.1 hmmemit.1 \
+ hmmer.1 hmmfetch.1 hmmindex.1 hmmpfam.1 hmmsearch.1
+
+.if defined(WITH_PVM)
+CONFIGURE_ENV+= PVM_ROOT="${LOCALBASE}/lib/pvm" PVM_ARCH="FREEBSD"
+CONFIGURE_ARGS+= --with-pvm
+BUILD_DEPENDS+= pvm:${PORTSDIR}/net/pvm
+.endif
post-install:
.if !defined(NOPORTDOCS)
@@ -32,6 +37,10 @@ post-install:
@ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.endif
+ @ ${MKDIR} ${EXAMPLESDIR}
+.for example in ${EXAMPLES}
+ @ ${INSTALL_DATA} ${WRKSRC}/tutorial/${example} ${EXAMPLESDIR}
+.endfor
.if !defined(BATCH)
@ ${CAT} ${PKGMESSAGE}
.endif