aboutsummaryrefslogtreecommitdiff
path: root/biology/htslib
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-14 22:35:07 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-12-14 22:35:07 +0000
commit91bd9cdb6834f052703da932d91cd7b832b71dfb (patch)
tree54df141897885ff3684cfad1334155d0d6e72b2d /biology/htslib
parent97fa5cefad2aefe55b470c3acdee74fc3654bb79 (diff)
downloadports-91bd9cdb6834f052703da932d91cd7b832b71dfb.tar.gz
ports-91bd9cdb6834f052703da932d91cd7b832b71dfb.zip
HTSlib is an implementation of a unified C library for accessing common file
formats, such as SAM, CRAM, VCF, and BCF, used for high-throughput sequencing data. It is the core library used by samtools and bcftools. WWW: http://www.htslib.org/ PR: 195591 Submitted by: Reed A. Cartwright <cartwright@asu.edu>
Notes
Notes: svn path=/head/; revision=374729
Diffstat (limited to 'biology/htslib')
-rw-r--r--biology/htslib/Makefile29
-rw-r--r--biology/htslib/distinfo2
-rw-r--r--biology/htslib/files/patch-Makefile64
-rw-r--r--biology/htslib/pkg-descr5
-rw-r--r--biology/htslib/pkg-plist30
5 files changed, 130 insertions, 0 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
new file mode 100644
index 000000000000..b5abcfaecaac
--- /dev/null
+++ b/biology/htslib/Makefile
@@ -0,0 +1,29 @@
+# Created by: Reed A. Cartwright <cartwright@asu.edu>
+# $FreeBSD$
+
+PORTNAME= htslib
+PORTVERSION= 1.1
+CATEGORIES= biology devel
+
+MAINTAINER= cartwright@asu.edu
+COMMENT= C library for high-throughput sequencing data formats
+
+LICENSE= BSD3CLAUSE MIT
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= samtools
+GH_COMMIT= a65fba2
+
+USES= gmake
+USE_LDCONFIG= yes
+
+MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_DIR="${MKDIR}"
+
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
new file mode 100644
index 000000000000..ca1b3fd93d6c
--- /dev/null
+++ b/biology/htslib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (htslib-1.1.tar.gz) = 0614de1795284181675dd0178fb00f0aca176064b6263e3c7e21b53f34710631
+SIZE (htslib-1.1.tar.gz) = 957434
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
new file mode 100644
index 000000000000..5a1b1e3300a9
--- /dev/null
+++ b/biology/htslib/files/patch-Makefile
@@ -0,0 +1,64 @@
+--- Makefile.orig 2014-09-23 14:39:41 UTC
++++ Makefile
+@@ -22,33 +22,27 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CC = gcc
+-AR = ar
+-RANLIB = ranlib
++CC ?= cc
++AR = /usr/bin/ar
++RANLIB = /usr/bin/ranlib
+
+ # TODO: edit cram code to remove need for -DSAMTOOLS
+-CPPFLAGS = -I. -DSAMTOOLS=1
++CPPFLAGS += -I. -DSAMTOOLS=1 -Wno-unused-function -Wno-implicit-function-declaration
+ # TODO: probably update cram code to make it compile cleanly with -Wc++-compat
+-CFLAGS = -g -Wall -O2
++CFLAGS += -Wall
+ EXTRA_CFLAGS_PIC = -fpic
+-LDFLAGS =
+-LDLIBS =
++LDFLAGS +=
++LDLIBS +=
+
+-prefix = /usr/local
++prefix = ${STAGEDIR}${PREFIX}
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ includedir = $(prefix)/include
+ libdir = $(exec_prefix)/lib
+-mandir = $(prefix)/share/man
++mandir = $(prefix)/man
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
+-pkgconfigdir= $(libdir)/pkgconfig
+-
+-MKDIR_P = mkdir -p
+-INSTALL = install -p
+-INSTALL_PROGRAM = $(INSTALL)
+-INSTALL_DATA = $(INSTALL) -m 644
+-INSTALL_DIR = $(MKDIR_P) -m 755
++pkgconfigdir= $(exec_prefix)/libdata/pkgconfig
+
+ BUILT_PROGRAMS = \
+ bgzip \
+@@ -62,7 +56,7 @@ BUILT_TEST_PROGRAMS = \
+ test/test-vcf-api \
+ test/test-vcf-sweep
+
+-all: lib-static lib-shared $(BUILT_PROGRAMS) $(BUILT_TEST_PROGRAMS)
++all: lib-static lib-shared $(BUILT_PROGRAMS)
+
+ HTSPREFIX =
+ include htslib_vars.mk
+@@ -284,7 +278,7 @@ installdirs:
+ # and libhts.so.NN (used by client executables at runtime).
+
+ install-so: libhts.so installdirs
+- $(INSTALL_DATA) libhts.so $(DESTDIR)$(libdir)/libhts.so.$(PACKAGE_VERSION)
++ $(INSTALL_LIB) libhts.so $(DESTDIR)$(libdir)/libhts.so.$(PACKAGE_VERSION)
+ ln -sf libhts.so.$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libhts.so
+ ln -sf libhts.so.$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libhts.so.$(LIBHTS_SOVERSION)
+
diff --git a/biology/htslib/pkg-descr b/biology/htslib/pkg-descr
new file mode 100644
index 000000000000..4abab85879ac
--- /dev/null
+++ b/biology/htslib/pkg-descr
@@ -0,0 +1,5 @@
+HTSlib is an implementation of a unified C library for accessing common file
+formats, such as SAM, CRAM, VCF, and BCF, used for high-throughput sequencing
+data. It is the core library used by samtools and bcftools.
+
+WWW: http://www.htslib.org/
diff --git a/biology/htslib/pkg-plist b/biology/htslib/pkg-plist
new file mode 100644
index 000000000000..74ec1c18ac77
--- /dev/null
+++ b/biology/htslib/pkg-plist
@@ -0,0 +1,30 @@
+bin/bgzip
+bin/tabix
+include/htslib/bgzf.h
+include/htslib/faidx.h
+include/htslib/hfile.h
+include/htslib/hts.h
+include/htslib/hts_defs.h
+include/htslib/kfunc.h
+include/htslib/khash.h
+include/htslib/khash_str2int.h
+include/htslib/klist.h
+include/htslib/knetfile.h
+include/htslib/kseq.h
+include/htslib/ksort.h
+include/htslib/kstring.h
+include/htslib/sam.h
+include/htslib/synced_bcf_reader.h
+include/htslib/tbx.h
+include/htslib/vcf.h
+include/htslib/vcf_sweep.h
+include/htslib/vcfutils.h
+lib/libhts.a
+lib/libhts.so
+lib/libhts.so.1
+lib/libhts.so.%%PORTVERSION%%
+libdata/pkgconfig/htslib.pc
+man/man1/tabix.1.gz
+man/man5/faidx.5.gz
+man/man5/sam.5.gz
+man/man5/vcf.5.gz