aboutsummaryrefslogtreecommitdiff
path: root/biology/kallisto/files/patch-src_CMakeLists.txt
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2022-01-19 13:57:36 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2022-01-19 13:57:36 +0000
commitc9bd01bdf4c1dae17b53482e9dabe000d310cf50 (patch)
tree0ae5d8e3ff02b5a9651dbe258d7db49dec778ccc /biology/kallisto/files/patch-src_CMakeLists.txt
parentf9a2f32279b075d36a16ae85664c4b7ead61410c (diff)
downloadports-c9bd01bdf4c1dae17b53482e9dabe000d310cf50.tar.gz
ports-c9bd01bdf4c1dae17b53482e9dabe000d310cf50.zip
Diffstat (limited to 'biology/kallisto/files/patch-src_CMakeLists.txt')
-rw-r--r--biology/kallisto/files/patch-src_CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/biology/kallisto/files/patch-src_CMakeLists.txt b/biology/kallisto/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..fbeb9128522a
--- /dev/null
+++ b/biology/kallisto/files/patch-src_CMakeLists.txt
@@ -0,0 +1,26 @@
+--- src/CMakeLists.txt.orig 2021-11-24 14:45:50 UTC
++++ src/CMakeLists.txt
+@@ -3,15 +3,13 @@ file(GLOB headers *.h *.hpp)
+
+ list(REMOVE_ITEM sources main.cpp)
+
+-include_directories(../ext/htslib)
+-
+ add_library(kallisto_core ${sources} ${headers})
+ target_include_directories(kallisto_core PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
+
+ add_executable(kallisto main.cpp)
+
+ find_package( Threads REQUIRED )
+-target_link_libraries(kallisto kallisto_core pthread ${CMAKE_CURRENT_SOURCE_DIR}/../ext/htslib/libhts.a)
++target_link_libraries(kallisto kallisto_core pthread)
+
+ if(LINK MATCHES static)
+ set(BUILD_SHARED_LIBS OFF)
+@@ -56,4 +54,4 @@ else()
+ endif(LINK MATCHES static)
+
+
+-install(TARGETS kallisto DESTINATION "${CMAKE_INSTALL_BINDIR}")
+\ No newline at end of file
++install(TARGETS kallisto DESTINATION "${CMAKE_INSTALL_BINDIR}")