aboutsummaryrefslogtreecommitdiff
path: root/biology/kallisto
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2017-12-02 20:44:28 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2017-12-02 20:44:28 +0000
commit429caa13b591029b4e5e374d0369122545e86a01 (patch)
tree928bc3d51181f89d41ff0c1b89ad74c47ac9a2d4 /biology/kallisto
parent40fc605e9d33920044f97a2c5fc5140dd933bbd5 (diff)
downloadports-429caa13b591029b4e5e374d0369122545e86a01.tar.gz
ports-429caa13b591029b4e5e374d0369122545e86a01.zip
[new port] biology/kallisto: Quantify abundances of transcripts from RNA-Seq data
Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D13328
Notes
Notes: svn path=/head/; revision=455382
Diffstat (limited to 'biology/kallisto')
-rw-r--r--biology/kallisto/Makefile33
-rw-r--r--biology/kallisto/distinfo3
-rw-r--r--biology/kallisto/files/kallisto-test.in48
-rw-r--r--biology/kallisto/pkg-descr6
4 files changed, 90 insertions, 0 deletions
diff --git a/biology/kallisto/Makefile b/biology/kallisto/Makefile
new file mode 100644
index 000000000000..724d4398f0d8
--- /dev/null
+++ b/biology/kallisto/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= kallisto
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.43.1
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Quantify abundances of transcripts from RNA-Seq data
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+LIB_DEPENDS= libhdf5.so:science/hdf5 \
+ libsz.so:science/szip
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= pachterlab
+
+SUB_FILES= kallisto-test
+
+PORTEXAMPLES= *
+PLIST_FILES= bin/kallisto
+EXAMPLES_PLIST_FILES= bin/kallisto-test
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install-EXAMPLES-on:
+ ${INSTALL_SCRIPT} ${WRKDIR}/kallisto-test ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}/test && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/biology/kallisto/distinfo b/biology/kallisto/distinfo
new file mode 100644
index 000000000000..a6cf773150b1
--- /dev/null
+++ b/biology/kallisto/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512166931
+SHA256 (pachterlab-kallisto-v0.43.1_GH0.tar.gz) = 2164938c2c61c04e338c4c132cf749f56d39e6f0b4c517121bca1fbc218e430e
+SIZE (pachterlab-kallisto-v0.43.1_GH0.tar.gz) = 1067076
diff --git a/biology/kallisto/files/kallisto-test.in b/biology/kallisto/files/kallisto-test.in
new file mode 100644
index 000000000000..7d989c08f4e2
--- /dev/null
+++ b/biology/kallisto/files/kallisto-test.in
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+##########################################################################
+# Script description:
+#
+# Arguments:
+#
+# Returns:
+#
+# History:
+# Date Name Modification
+# 2016-03-21 Charlie & Begin
+##########################################################################
+
+usage()
+{
+ printf "Usage: $0 test-directory\n"
+ exit 1
+}
+
+
+##########################################################################
+# Main
+##########################################################################
+
+if [ $# != 1 ]; then
+ usage
+fi
+
+dir="$1"
+if [ -e "$dir" ]; then
+ printf "$dir already exists. Remove it first or choose a different name.\n"
+ exit 1
+fi
+
+cp -iR %%EXAMPLESDIR%% "$dir"
+cd "$dir"
+kallisto index -i transcripts.idx transcripts.fasta.gz
+kallisto quant -i transcripts.idx -o output -b 100 reads_1.fastq.gz reads_2.fastq.gz
+ls -l output
+more output/abundance.tsv
+
+cat << EOM
+
+See https://pachterlab.github.io/kallisto/starting.html for instructions
+on interpreting the output above.
+
+EOM
diff --git a/biology/kallisto/pkg-descr b/biology/kallisto/pkg-descr
new file mode 100644
index 000000000000..4f06ae7e4127
--- /dev/null
+++ b/biology/kallisto/pkg-descr
@@ -0,0 +1,6 @@
+Kallisto is a program for quantifying abundances of transcripts from RNA-Seq
+data, or more generally of target sequences using high-throughput sequencing
+reads. It is based on the novel idea of pseudoalignment for rapidly determining
+the compatibility of reads with targets, without the need for alignment.
+
+WWW: https://pachterlab.github.io/kallisto/about.html