aboutsummaryrefslogtreecommitdiff
path: root/biology/libgtextutils
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-03-29 15:41:07 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-03-29 15:41:07 +0000
commit184db1bfcd5cee13f26a9d628d89e734dd93254a (patch)
treef1450e34f85575dffb51a45b1a6886ce5a609e9e /biology/libgtextutils
parent6276f061c2845a81f8cb4a8355a2a4a612fa34ef (diff)
downloadports-184db1bfcd5cee13f26a9d628d89e734dd93254a.tar.gz
ports-184db1bfcd5cee13f26a9d628d89e734dd93254a.zip
biology/libgtextutils: Unbreak for FreeBSD 12
Reported by: pkg-fallout Approved by: jrm Differential Revision: https://reviews.freebsd.org/D14892
Notes
Notes: svn path=/head/; revision=465904
Diffstat (limited to 'biology/libgtextutils')
-rw-r--r--biology/libgtextutils/Makefile2
-rw-r--r--biology/libgtextutils/files/patch-src_gtextutils_text__line__reader.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/biology/libgtextutils/Makefile b/biology/libgtextutils/Makefile
index 4d67c42560e6..eb80110bc211 100644
--- a/biology/libgtextutils/Makefile
+++ b/biology/libgtextutils/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libgtextutils
-PORTVERSION= 0.7
+DISTVERSION= 0.7
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
diff --git a/biology/libgtextutils/files/patch-src_gtextutils_text__line__reader.cpp b/biology/libgtextutils/files/patch-src_gtextutils_text__line__reader.cpp
new file mode 100644
index 000000000000..bbaad570e019
--- /dev/null
+++ b/biology/libgtextutils/files/patch-src_gtextutils_text__line__reader.cpp
@@ -0,0 +1,11 @@
+--- src/gtextutils/text_line_reader.cpp.orig 2018-03-29 13:31:53 UTC
++++ src/gtextutils/text_line_reader.cpp
+@@ -44,6 +44,7 @@ bool TextLineReader::next_line()
+ if (input_stream.eof())
+ return false;
+
+- return input_stream ;
++ // Fix based on the only code change since 0.7
++ return input_stream.good() ;
+ }
+