aboutsummaryrefslogtreecommitdiff
path: root/biology/linux-foldingathome
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 05:45:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 05:45:41 +0000
commite713c30f0cb4f83d0ec9d3d2a9ec1fed43b70b00 (patch)
treed6a42aaa568670020f994769bb86f592f8796101 /biology/linux-foldingathome
parent566c495359d2273e4ee7b18978bff278dd41269e (diff)
downloadports-e713c30f0cb4f83d0ec9d3d2a9ec1fed43b70b00.tar.gz
ports-e713c30f0cb4f83d0ec9d3d2a9ec1fed43b70b00.zip
biology/linux-foldingathome needs to run as root?
(also: update to 5.0.4) Upon installing FoldingAtHome I ran the software from a user account only to find that I was stuck in a loop of trying to enter configuration options. Shortly thereafter I realized that it was trying to write to /usr/local/share/foldingathome, and therefore requires being run as root to write there unless one changes permissions there. Seing as this isn't installed with a startup script for daemonization, and running as root seems a little excessive for this application, should this be adapted to run from a user account or set up to be able to start at boot? And from maintainer: This diff updates the port to version 5.04, and adds support to running as normal user using ~/.fah directory. PR: ports/113335 Submitted by: James Snyder <jbsnyder@fanplastic.org> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=199937
Diffstat (limited to 'biology/linux-foldingathome')
-rw-r--r--biology/linux-foldingathome/Makefile2
-rw-r--r--biology/linux-foldingathome/distinfo6
-rw-r--r--biology/linux-foldingathome/scripts/FoldingAtHome6
3 files changed, 8 insertions, 6 deletions
diff --git a/biology/linux-foldingathome/Makefile b/biology/linux-foldingathome/Makefile
index ed8878efba18..417f87089a94 100644
--- a/biology/linux-foldingathome/Makefile
+++ b/biology/linux-foldingathome/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= foldingathome
-PORTVERSION= 5.02
+PORTVERSION= 5.04
CATEGORIES= biology
MASTER_SITES= http://www.stanford.edu/group/pandegroup/release/
PKGNAMEPREFIX= linux-
diff --git a/biology/linux-foldingathome/distinfo b/biology/linux-foldingathome/distinfo
index 2cfac333d0ef..d019cfb4ee83 100644
--- a/biology/linux-foldingathome/distinfo
+++ b/biology/linux-foldingathome/distinfo
@@ -1,3 +1,3 @@
-MD5 (FAH502-Linux.exe) = 4855e808fb94e6d2c5fde345aea0cdc3
-SHA256 (FAH502-Linux.exe) = 02e2d3665a6e8f8fc89c7751b8faadff6885d34860643bdd4107d92825754d33
-SIZE (FAH502-Linux.exe) = 249236
+MD5 (FAH504-Linux.exe) = 1316853b439d25a4a56adf82fcd953db
+SHA256 (FAH504-Linux.exe) = c491b23af1edee41db474545c0a084f3f4cf4ccf50bceb56da499df63eb38464
+SIZE (FAH504-Linux.exe) = 250964
diff --git a/biology/linux-foldingathome/scripts/FoldingAtHome b/biology/linux-foldingathome/scripts/FoldingAtHome
index 3bd56fcb9f39..c2c2a72dc805 100644
--- a/biology/linux-foldingathome/scripts/FoldingAtHome
+++ b/biology/linux-foldingathome/scripts/FoldingAtHome
@@ -1,5 +1,7 @@
#!/bin/sh
+FAHDIR=~/.fah
CURDIR=`pwd`
-cd DATADIR
-nice -n 20 ./BINNAME -freeBSD
+mkdir $FAHDIR
+cd $FAHDIR
+nice -n 20 /DATADIR/BINNAME -freeBSD
cd $CURDIR