aboutsummaryrefslogtreecommitdiff
path: root/biology/mapm3
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-04 11:28:24 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-04 11:28:24 +0000
commit64680c4bd053e17d1e5256f1d2a55ecd9639e3ec (patch)
tree56812d8729c2952b3e4ddb890b7c6c8caedf254c /biology/mapm3
parente067ed47e5dbdb909a509bd1a82802faade8856a (diff)
downloadports-64680c4bd053e17d1e5256f1d2a55ecd9639e3ec.tar.gz
ports-64680c4bd053e17d1e5256f1d2a55ecd9639e3ec.zip
biology/mapm3: Fix build with llvm11, gcc10
Another instance of -fno-common issue. While here: * strip executables * add license PR: 249077 Submitted by: tphilipp@potion-studios.com (maintainer) MFH: 2020Q3 (build fix, -fno-common)
Notes
Notes: svn path=/head/; revision=547530
Diffstat (limited to 'biology/mapm3')
-rw-r--r--biology/mapm3/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/biology/mapm3/Makefile b/biology/mapm3/Makefile
index f0f5ed61c629..43c0972f95ea 100644
--- a/biology/mapm3/Makefile
+++ b/biology/mapm3/Makefile
@@ -3,23 +3,29 @@
PORTNAME= mapm3
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= http://www.broad.mit.edu/ftp/distribution/software/mapmaker3/ \
ftp://ftp.ibiblio.org/pub/academic/biology/molbio/mapmaker/ \
http://iubio.bio.indiana.edu/soft/molbio/qtl/mapmaker/ \
http://www.mirrorservice.org/sites/iubio.bio.indiana.edu/molbio/qtl/mapmaker/
DISTNAME= mapm3-source
-EXTRACT_SUFX= .tar.Z
MAINTAINER= tphilipp@potion-studios.com
COMMENT= Constructs linkage maps of markers segregating in experimental crosses
-USES= ncurses
+LICENSE= MAPMAKER
+LICENSE_NAME= Whitehead Institute Mapmaker license
+LICENSE_FILE= ${WRKSRC}/READ.ME
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+USES= ncurses tar:Z
USE_CSTD= gnu89
-CFLAGS+= -Wno-return-type
-NO_WRKSUBDIR= yes
+
MAKE_ARGS+= SYS_LIBS="${LDFLAGS} -lm -lncurses"
MAKE_JOBS_UNSAFE= yes
+CFLAGS+= -fcommon -Wno-return-type
+NO_WRKSUBDIR= yes
post-patch:
${CP} ${WRKSRC}/sun/* ${WRKSRC}
@@ -27,4 +33,8 @@ post-patch:
pre-install:
@${REINPLACE_CMD} -e 's|/usr/local|${STAGEDIR}${PREFIX}|' ${WRKSRC}/Makefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mapmaker
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qtl
+
.include <bsd.port.mk>