aboutsummaryrefslogtreecommitdiff
path: root/biology/migrate/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-08-06 13:07:46 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-08-06 13:07:46 +0000
commit199894f6563276e6808887ed84a724e3615a1a85 (patch)
treef162153436d20a386465a8d0492f28de00cf4446 /biology/migrate/Makefile
parent12bfc0ee3ee1c847bb613333ac6c7b96e87be967 (diff)
downloadports-199894f6563276e6808887ed84a724e3615a1a85.tar.gz
ports-199894f6563276e6808887ed84a724e3615a1a85.zip
Add migrate 1.2,
a program to estimate population sizes and migration rates.
Notes
Notes: svn path=/head/; revision=45878
Diffstat (limited to 'biology/migrate/Makefile')
-rw-r--r--biology/migrate/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/biology/migrate/Makefile b/biology/migrate/Makefile
new file mode 100644
index 000000000000..730c5b452c72
--- /dev/null
+++ b/biology/migrate/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: migrate
+# Date created: 6 August 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= migrate
+PORTVERSION= 1.2
+CATEGORIES= biology
+MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/lamarc/migrate/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= wjv@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CONFIGURE_WRKSRC= ${WRKSRC}/src
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+GNU_CONFIGURE= yes
+
+MAN1= migrate.1
+
+post-install:
+ @ cd ${PREFIX}/bin && ${LN} -s migrate-n migrate
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}/graphics
+.for docfile in HISTORY HOWTO-PARALLEL README migrate.html
+ @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+ @ ${INSTALL_DATA} ${WRKSRC}/graphics/* ${DOCSDIR}/graphics
+.endif
+
+.include <bsd.port.mk>