aboutsummaryrefslogtreecommitdiff
path: root/biology/paml
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-10 03:21:05 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-10 03:21:05 +0000
commit54c8d2b70677303f4875614cdd3f4ad1038b660c (patch)
tree329e9e5ed76886ab0eef3dd9e1d614024a8b68f8 /biology/paml
parent8546beeba575e2efc36f5126f12b5b77167a5bdd (diff)
downloadports-54c8d2b70677303f4875614cdd3f4ad1038b660c.tar.gz
ports-54c8d2b70677303f4875614cdd3f4ad1038b660c.zip
Add paml version 3.01.
A set of utilities for performing Phylogenetic Analysis by Maximum Likelihood (PAML). PR: 19753 Submitted by: David A. Bader <dbader@cielo.eece.unm.edu>
Notes
Notes: svn path=/head/; revision=30407
Diffstat (limited to 'biology/paml')
-rw-r--r--biology/paml/Makefile32
-rw-r--r--biology/paml/distinfo1
-rw-r--r--biology/paml/files/patch-aa11
-rw-r--r--biology/paml/files/patch-ab11
-rw-r--r--biology/paml/pkg-comment1
-rw-r--r--biology/paml/pkg-descr22
-rw-r--r--biology/paml/pkg-plist11
7 files changed, 89 insertions, 0 deletions
diff --git a/biology/paml/Makefile b/biology/paml/Makefile
new file mode 100644
index 000000000000..5b792993ec00
--- /dev/null
+++ b/biology/paml/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: paml
+# Date created: 7 July 2000
+# Whom: dbader@eece.unm.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= paml
+PORTVERSION= 3.01
+CATEGORIES= biology
+MASTER_SITES= ftp://abacus.gene.ucl.ac.uk/pub/paml/
+DISTNAME= paml3.0a
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= dbader@eece.unm.edu
+
+NO_WRKSUBDIR= yes
+
+BINARIES= baseml basemlg chi2 codeml codemlsites evolver mcmctree \
+ pamp yn00
+
+do-install:
+.for f in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/pamlDOC.pdf \
+ ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/biology/paml/distinfo b/biology/paml/distinfo
new file mode 100644
index 000000000000..fd6ef9254a30
--- /dev/null
+++ b/biology/paml/distinfo
@@ -0,0 +1 @@
+MD5 (paml3.0a.tar.Z) = 53ce654a8173407a3db278d106deb115
diff --git a/biology/paml/files/patch-aa b/biology/paml/files/patch-aa
new file mode 100644
index 000000000000..4a5d5b546775
--- /dev/null
+++ b/biology/paml/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.orig Sun Mar 12 20:49:36 2000
++++ Makefile Fri Jul 7 06:32:33 2000
+@@ -1,7 +1,7 @@
+ PRGS = baseml codeml codemlsites basemlg pamp evolver mcmctree yn00 chi2
+ CC = cc # cc, gcc, cl
+
+-CFLAGS = -fast
++CFLAGS += -O3
+
+ #CFLAGS = -w0 -warnprotos -newc -std -fast
+ #CFLAGS = -g -w0 -warnprotos -newc -std -edit1 #
diff --git a/biology/paml/files/patch-ab b/biology/paml/files/patch-ab
new file mode 100644
index 000000000000..b0146af88038
--- /dev/null
+++ b/biology/paml/files/patch-ab
@@ -0,0 +1,11 @@
+--- evolver.c-orig Thu Jun 15 14:42:52 2000
++++ evolver.c Fri Jul 7 06:40:09 2000
+@@ -63,7 +63,7 @@
+ static double Qfactor=-1, Qrates[5]; /* Qrates[] hold kappa's for nucleotides */
+
+
+-void main(int argc, char*argv[])
++main(int argc, char*argv[])
+ {
+ char *MCctlf=NULL, outf[]="evolver.out";
+ int i, option=6, ntree=1,rooted, BD=0;
diff --git a/biology/paml/pkg-comment b/biology/paml/pkg-comment
new file mode 100644
index 000000000000..28176e9a1ed1
--- /dev/null
+++ b/biology/paml/pkg-comment
@@ -0,0 +1 @@
+Phylogenetic Analysis by Maximum Likelihood (PAML)
diff --git a/biology/paml/pkg-descr b/biology/paml/pkg-descr
new file mode 100644
index 000000000000..e0fa64554306
--- /dev/null
+++ b/biology/paml/pkg-descr
@@ -0,0 +1,22 @@
+Phylogenetic Analysis by Maximum Likelihood (PAML)
+
+PAML is a program package for phylogenetic analyses of DNA or protein
+sequences using maximum likelihood, and is maintained and distributed
+by Ziheng Yang.
+
+Possible uses of the programs are:
+- Estimation of branch lengths in a phylogenetic tree and parameters
+ in the evolutionary model such as the transition/transversion rate
+ ratio, the shape parameter of the gamma distribution for variable
+ evolutionary rates among sites, and rate parameters for different
+ genes;
+- Test of hypotheses concerning sequence evolution, such as rate
+ constancy and independence among nucleotide or amino acid sites, rate
+ constancy among lineages (the molecular clock), and homogeneity of
+ evolutionary process in multiple genes;
+- Calculation of substitution rates at sites;
+- Reconstruction of ancestral nucleotide or amino acid sequences;
+- Simulation of nucleotide, codon, and amino acid sequence data sets;
+- Phylogenetic tree reconstruction by maximum likelihood and Bayesian methods.
+
+WWW: http://abacus.gene.ucl.ac.uk/software/paml.html
diff --git a/biology/paml/pkg-plist b/biology/paml/pkg-plist
new file mode 100644
index 000000000000..10c94586d974
--- /dev/null
+++ b/biology/paml/pkg-plist
@@ -0,0 +1,11 @@
+bin/baseml
+bin/basemlg
+bin/chi2
+bin/codeml
+bin/codemlsites
+bin/evolver
+bin/mcmctree
+bin/pamp
+bin/yn00
+share/doc/paml/pamlDOC.pdf
+@dirrm share/doc/paml