aboutsummaryrefslogtreecommitdiff
path: root/biology/phrap/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:04:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:04:45 +0000
commit5081af2c649bf6005a0472de4f6dfe99b6786f36 (patch)
treef9a70ac725d6822494225b59eb82fcd00bde8e55 /biology/phrap/Makefile
parentc65af41a3b0e8a047f8159fa8fbd0bc8473e69e4 (diff)
downloadports-5081af2c649bf6005a0472de4f6dfe99b6786f36.tar.gz
ports-5081af2c649bf6005a0472de4f6dfe99b6786f36.zip
New port: biology/consed viewing and editing workbench for sequence
assembly Consed is a tool for viewing, editing, and finishing sequence assemblies. The port is constituted of 4 parts: biology/phred: base caller with quality evaluation biology/phrap: sequence assembler for shotgun sequencing biology/consed: workbench biology/phd2fasta: small utility All these can be used separately; however, most function of consed depends on the others. Although these programs are licensed freely for academic and nonprofit purposes, users have to contact the authors to get the softwares. Phred (including phd2fasta) and phrap are emailed, and consed can be downloaded to a restricted IP address. For commercial users, the licensing fee is ca. $10,000 at the time of writing. PR: ports/118548 Submitted by: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
Notes
Notes: svn path=/head/; revision=213596
Diffstat (limited to 'biology/phrap/Makefile')
-rw-r--r--biology/phrap/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/biology/phrap/Makefile b/biology/phrap/Makefile
new file mode 100644
index 000000000000..094d772390aa
--- /dev/null
+++ b/biology/phrap/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: phrap
+# Date created: 21 June 2005
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phrap
+PORTVERSION= 0.990329
+CATEGORIES= biology
+MASTER_SITES= # put the tarball manually
+DISTFILES= distrib.tar.Z
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= Phrap is a program for assembling shotgun DNA sequence data
+
+RESTRICTED= Redistribution is not permitted in any form. You must request the tarball via e-mail. Free for academic use.
+
+NO_WRKSUBDIR= yes
+
+MAKEFILE= makefile
+ALL_TARGET= all manyreads
+
+BINARIES= cluster cross_match cross_match.manyreads loco \
+ phrap phrap.longreads phrap.manyreads swat
+SCRIPTS= phrapview
+.for f in ${BINARIES} ${SCRIPTS}
+PLIST_FILES+= bin/${f}
+.endfor
+
+PORTDATA= BLOSUM50 BLOSUM62 PAM250 mat50 mat70 penalty2 vector.seq
+PORTDOCS= general.doc phrap.doc swat.doc
+
+.include <bsd.port.pre.mk>
+
+.for f in ${DISTFILES}
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${f})
+IGNORE= you must request the source code \(${DISTFILES}\) via e-mail, place it manually in ${DISTDIR}/${DIST_SUBDIR}, and then try it again
+.endif
+.endfor
+
+do-install:
+.for f in ${BINARIES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
+ @${CHMOD} a-r ${PREFIX}/bin/${f} # as required by the agreement
+.endfor
+.for f in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin/
+.endfor
+ @${MKDIR} ${DATADIR}
+.for f in ${PORTDATA}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>