aboutsummaryrefslogtreecommitdiff
path: root/biology/protomol
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-25 17:19:31 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-25 17:19:31 +0000
commit336c45a97ef5e92029dc8a4daf8ecea4f9b945b3 (patch)
tree9a34bfe19a1d9aa85005bac9ff73b5782479ee8e /biology/protomol
parenta288d12a6b9bc5bd3be7c008d468bcfc6133f341 (diff)
downloadports-336c45a97ef5e92029dc8a4daf8ecea4f9b945b3.tar.gz
ports-336c45a97ef5e92029dc8a4daf8ecea4f9b945b3.zip
- Stagify
- Fix build
Notes
Notes: svn path=/head/; revision=366104
Diffstat (limited to 'biology/protomol')
-rw-r--r--biology/protomol/Makefile5
-rw-r--r--biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGDihedralSystemForce.h20
-rw-r--r--biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGImproperSystemForce.h20
-rw-r--r--biology/protomol/files/patch-framework__forces__DihedralSystemForce.h20
-rw-r--r--biology/protomol/files/patch-framework__forces__HarmDihedralSystemForce.h20
-rw-r--r--biology/protomol/files/patch-framework__forces__ImproperSystemForce.h20
-rw-r--r--biology/protomol/files/patch-framework__forces__NonbondedCutoffMollyForce.h11
-rw-r--r--biology/protomol/files/patch-framework__forces__NonbondedCutoffSystemForce.h11
8 files changed, 124 insertions, 3 deletions
diff --git a/biology/protomol/Makefile b/biology/protomol/Makefile
index 6654c2a53793..959ddb6f4669 100644
--- a/biology/protomol/Makefile
+++ b/biology/protomol/Makefile
@@ -30,7 +30,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= GLUT
OPTIONS_DEFAULT= GLUT
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGLUT}
@@ -42,9 +41,9 @@ CONFIGURE_ARGS+= --with-glut=no
.if ${PORT_OPTIONS:MEXAMPLES}
post-install:
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${FIND} . | ${EGREP} -v '\.cvsignore' | \
- ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGDihedralSystemForce.h b/biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGDihedralSystemForce.h
new file mode 100644
index 000000000000..8366cef4e66f
--- /dev/null
+++ b/biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGDihedralSystemForce.h
@@ -0,0 +1,20 @@
+--- applications/iSGProtomol-app/forces/iSGDihedralSystemForce.h.orig 2005-05-07 18:40:20.000000000 +0400
++++ applications/iSGProtomol-app/forces/iSGDihedralSystemForce.h 2014-08-22 20:49:51.000000000 +0400
+@@ -71,7 +71,7 @@
+ (dynamic_cast<const SemiGenericTopology<TBoundaryConditions>& >(*topo)).boundaryConditions;
+
+ for (unsigned int i = 0; i < topo->dihedrals.size(); i++)
+- calcTorsion(boundary,topo->dihedrals[i], positions, forces,
++ this->calcTorsion(boundary,topo->dihedrals[i], positions, forces,
+ (*energies)[ScalarStructure::DIHEDRAL],
+ (*energies)[ScalarStructure::DIHEDRAL_DELTAMU],
+ energies);
+@@ -95,7 +95,7 @@
+ to = n;
+ int from = (n*i)/count;
+ for (int j = from; j < to; j++)
+- calcTorsion(boundary, topo->dihedrals[j], positions, forces,
++ this->calcTorsion(boundary, topo->dihedrals[j], positions, forces,
+ (*energies)[ScalarStructure::DIHEDRAL],
+ (*energies)[ScalarStructure::DIHEDRAL_DELTAMU],
+ energies);
diff --git a/biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGImproperSystemForce.h b/biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGImproperSystemForce.h
new file mode 100644
index 000000000000..5280623c79e2
--- /dev/null
+++ b/biology/protomol/files/patch-applications__iSGProtomol-app__forces__iSGImproperSystemForce.h
@@ -0,0 +1,20 @@
+--- applications/iSGProtomol-app/forces/iSGImproperSystemForce.h.orig 2005-05-07 18:40:20.000000000 +0400
++++ applications/iSGProtomol-app/forces/iSGImproperSystemForce.h 2014-08-22 20:50:15.000000000 +0400
+@@ -67,7 +67,7 @@
+ const TBoundaryConditions &boundary =
+ (dynamic_cast<const SemiGenericTopology<TBoundaryConditions>& >(*topo)).boundaryConditions;
+ for (unsigned int i = 0; i < topo->impropers.size(); i++)
+- calcTorsion(boundary,topo->impropers[i], positions, forces,
++ this->calcTorsion(boundary,topo->impropers[i], positions, forces,
+ (*energies)[ScalarStructure::IMPROPER],
+ (*energies)[ScalarStructure::IMPROPER_DELTAMU],
+ energies);
+@@ -91,7 +91,7 @@
+ to = n;
+ int from = (n*i)/count;
+ for (int j = from; j < to; j++)
+- calcTorsion(boundary, topo->impropers[j], positions, forces,
++ this->calcTorsion(boundary, topo->impropers[j], positions, forces,
+ (*energies)[ScalarStructure::IMPROPER],
+ (*energies)[ScalarStructure::IMPROPER_DELTAMU],
+ energies);
diff --git a/biology/protomol/files/patch-framework__forces__DihedralSystemForce.h b/biology/protomol/files/patch-framework__forces__DihedralSystemForce.h
new file mode 100644
index 000000000000..7dfa5a39e731
--- /dev/null
+++ b/biology/protomol/files/patch-framework__forces__DihedralSystemForce.h
@@ -0,0 +1,20 @@
+--- framework/forces/DihedralSystemForce.h.orig 2005-05-07 18:40:24.000000000 +0400
++++ framework/forces/DihedralSystemForce.h 2014-08-22 20:41:24.000000000 +0400
+@@ -72,7 +72,7 @@
+ const TBoundaryConditions &boundary =
+ (dynamic_cast<const SemiGenericTopology<TBoundaryConditions>& >(*topo)).boundaryConditions;
+ for (unsigned int i = 0; i < topo->dihedrals.size(); i++)
+- calcTorsion(boundary,topo->dihedrals[i], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
++ this->calcTorsion(boundary,topo->dihedrals[i], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
+ }
+ template<class TBoundaryConditions>
+ inline void DihedralSystemForce<TBoundaryConditions>::parallelEvaluate(const GenericTopology* topo,
+@@ -93,7 +93,7 @@
+ to = n;
+ int from = (n*i)/count;
+ for (int j = from; j < to; j++)
+- calcTorsion(boundary, topo->dihedrals[j], positions, forces, (*energies)[ScalarStructure::DIHEDRAL],energies);
++ this->calcTorsion(boundary, topo->dihedrals[j], positions, forces, (*energies)[ScalarStructure::DIHEDRAL],energies);
+ }
+ }
+ }
diff --git a/biology/protomol/files/patch-framework__forces__HarmDihedralSystemForce.h b/biology/protomol/files/patch-framework__forces__HarmDihedralSystemForce.h
new file mode 100644
index 000000000000..73f842f29728
--- /dev/null
+++ b/biology/protomol/files/patch-framework__forces__HarmDihedralSystemForce.h
@@ -0,0 +1,20 @@
+--- framework/forces/HarmDihedralSystemForce.h.orig 2005-05-07 18:40:24.000000000 +0400
++++ framework/forces/HarmDihedralSystemForce.h 2014-08-22 20:42:13.000000000 +0400
+@@ -119,7 +119,7 @@
+ {
+ if (static_cast<int>(i) != myDihedral) {
+ if(computeOthers) {
+- calcTorsion(boundary,topo->dihedrals[i], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
++ this->calcTorsion(boundary,topo->dihedrals[i], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
+ }
+ }
+ else {
+@@ -149,7 +149,7 @@
+ int from = (n*i)/count;
+ for (int j = from; j < to; j++){
+ if (j != myDihedral) {
+- calcTorsion(boundary,topo->dihedrals[j], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
++ this->calcTorsion(boundary,topo->dihedrals[j], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
+ }
+ else {
+ harmCalcTorsion(topo,boundary,topo->dihedrals[j], positions, forces,(*energies)[ScalarStructure::DIHEDRAL],energies);
diff --git a/biology/protomol/files/patch-framework__forces__ImproperSystemForce.h b/biology/protomol/files/patch-framework__forces__ImproperSystemForce.h
new file mode 100644
index 000000000000..907ade97189e
--- /dev/null
+++ b/biology/protomol/files/patch-framework__forces__ImproperSystemForce.h
@@ -0,0 +1,20 @@
+--- framework/forces/ImproperSystemForce.h.orig 2005-05-07 18:40:24.000000000 +0400
++++ framework/forces/ImproperSystemForce.h 2014-08-22 20:52:46.000000000 +0400
+@@ -69,7 +69,7 @@
+ const TBoundaryConditions &boundary =
+ (dynamic_cast<const SemiGenericTopology<TBoundaryConditions>& >(*topo)).boundaryConditions;
+ for (unsigned int i = 0; i < topo->impropers.size(); i++)
+- calcTorsion(boundary,topo->impropers[i], positions, forces, (*energies)[ScalarStructure::IMPROPER],energies);
++ this->calcTorsion(boundary,topo->impropers[i], positions, forces, (*energies)[ScalarStructure::IMPROPER],energies);
+ }
+ template<class TBoundaryConditions>
+ inline void ImproperSystemForce<TBoundaryConditions>::parallelEvaluate(const GenericTopology* topo,
+@@ -90,7 +90,7 @@
+ to = n;
+ int from = (n*i)/count;
+ for (int j = from; j < to; j++)
+- calcTorsion(boundary, topo->impropers[j], positions, forces, (*energies)[ScalarStructure::IMPROPER],energies);
++ this->calcTorsion(boundary, topo->impropers[j], positions, forces, (*energies)[ScalarStructure::IMPROPER],energies);
+ }
+ }
+ }
diff --git a/biology/protomol/files/patch-framework__forces__NonbondedCutoffMollyForce.h b/biology/protomol/files/patch-framework__forces__NonbondedCutoffMollyForce.h
new file mode 100644
index 000000000000..ef782ed94635
--- /dev/null
+++ b/biology/protomol/files/patch-framework__forces__NonbondedCutoffMollyForce.h
@@ -0,0 +1,11 @@
+--- framework/forces/NonbondedCutoffMollyForce.h.orig 2005-05-07 18:40:24.000000000 +0400
++++ framework/forces/NonbondedCutoffMollyForce.h 2014-08-22 20:42:42.000000000 +0400
+@@ -70,7 +70,7 @@
+ this->enumerator.initialize(realTopo, this->myCutoff);
+
+ unsigned int n = realTopo->cellLists.size();
+- unsigned int count = numberOfBlocks(realTopo,positions);
++ unsigned int count = this->numberOfBlocks(realTopo,positions);
+
+ for(unsigned int i = 0;i<count;i++){
+ unsigned int l = (n*(i+1))/count - (n*i)/count;
diff --git a/biology/protomol/files/patch-framework__forces__NonbondedCutoffSystemForce.h b/biology/protomol/files/patch-framework__forces__NonbondedCutoffSystemForce.h
new file mode 100644
index 000000000000..3868f719e668
--- /dev/null
+++ b/biology/protomol/files/patch-framework__forces__NonbondedCutoffSystemForce.h
@@ -0,0 +1,11 @@
+--- framework/forces/NonbondedCutoffSystemForce.h.orig 2005-05-07 18:40:24.000000000 +0400
++++ framework/forces/NonbondedCutoffSystemForce.h 2014-08-22 20:39:47.000000000 +0400
+@@ -76,7 +76,7 @@
+ this->enumerator.initialize(realTopo, this->myCutoff);
+
+ unsigned int n = realTopo->cellLists.size();
+- unsigned int count = numberOfBlocks(realTopo,positions);
++ unsigned int count = this->numberOfBlocks(realTopo,positions);
+
+ for(unsigned int i = 0;i<count;i++){
+ unsigned int l = (n*(i+1))/count - (n*i)/count;