aboutsummaryrefslogtreecommitdiff
path: root/biology/protomol
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-28 19:01:48 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-28 19:01:48 +0000
commit3d12db171850b1b249da028bcfac412720343c0d (patch)
tree8f450a1970a47f984d0d016fd57085b66fa8cb16 /biology/protomol
parentcee6e4c48a36450d5cae8b9c5177bc3633f0e153 (diff)
downloadports-3d12db171850b1b249da028bcfac412720343c0d.tar.gz
ports-3d12db171850b1b249da028bcfac412720343c0d.zip
- Fix build with GCC 4.2
Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=210034
Diffstat (limited to 'biology/protomol')
-rw-r--r--biology/protomol/Makefile6
-rw-r--r--biology/protomol/files/patch-framework-frontend_OutputDihedrals.cpp17
2 files changed, 18 insertions, 5 deletions
diff --git a/biology/protomol/Makefile b/biology/protomol/Makefile
index 9edae0d80a78..45c82c0d0492 100644
--- a/biology/protomol/Makefile
+++ b/biology/protomol/Makefile
@@ -37,13 +37,9 @@ OPTIONS= GLUT "Use glut" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if defined(WITH_GLUT)
CONFIGURE_ARGS+= --with-glut=yes
-LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
+USE_GL= glut
.else
CONFIGURE_ARGS+= --with-glut=no
.endif
diff --git a/biology/protomol/files/patch-framework-frontend_OutputDihedrals.cpp b/biology/protomol/files/patch-framework-frontend_OutputDihedrals.cpp
new file mode 100644
index 000000000000..8eb868a5bc2b
--- /dev/null
+++ b/biology/protomol/files/patch-framework-frontend_OutputDihedrals.cpp
@@ -0,0 +1,17 @@
+--- framework/frontend/OutputDihedrals.cpp.orig 2008-03-25 22:53:27.000000000 +0100
++++ framework/frontend/OutputDihedrals.cpp 2008-03-25 22:52:21.000000000 +0100
+@@ -387,10 +387,10 @@
+ string atom3name = "";
+ string atom4name = "";
+
+- std::set< int >::iterator myAtomSet_itr1 = NULL;
+- std::set< int >::iterator myAtomSet_itr2 = NULL;
+- std::set< int >::iterator myAtomSet_itr3 = NULL;
+- std::set< int >::iterator myAtomSet_itr4 = NULL;
++ std::set< int >::iterator myAtomSet_itr1;
++ std::set< int >::iterator myAtomSet_itr2;
++ std::set< int >::iterator myAtomSet_itr3;
++ std::set< int >::iterator myAtomSet_itr4;
+
+ for(unsigned int i=0; i < myTopology->dihedrals.size();i++){
+