aboutsummaryrefslogtreecommitdiff
path: root/biology/protomol
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 03:45:28 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 03:45:28 +0000
commite845f7e24e698a068dce4335932ecd19d8aa7b7e (patch)
tree2fdfa62517bc76fcf999664bfd355ca8d453643c /biology/protomol
parent8a0d72f97db0d172e5335cb3db9ae27afc69df38 (diff)
downloadports-e845f7e24e698a068dce4335932ecd19d8aa7b7e.tar.gz
ports-e845f7e24e698a068dce4335932ecd19d8aa7b7e.zip
biology/protomol: Fix build with Clang 6
Report.cpp:208:12: error: invalid operands to binary expression ('std::ostream' (aka 'basic_ostream<char>') and 'const std::__1::ostream' (aka 'const basic_ostream<char>')) *myStream << a; ~~~~~~~~~ ^ ~ /usr/include/c++/v1/ostream:218:20: note: candidate function not viable: no known conversion from 'const std::__1::ostream' (aka 'const basic_ostream<char>') to 'const void *' for 1st argument; take the address of the argument with & basic_ostream& operator<<(const void* __p); ^ ... and so on ... http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/protomol-2.0.3_13.log
Notes
Notes: svn path=/head/; revision=477996
Diffstat (limited to 'biology/protomol')
-rw-r--r--biology/protomol/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/biology/protomol/Makefile b/biology/protomol/Makefile
index 2be07195d4f7..bfd69198dc0e 100644
--- a/biology/protomol/Makefile
+++ b/biology/protomol/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= shebangfix
+USE_CXXSTD= c++98
SHEBANG_FILES= examples/butane_4/procDihedralFile.awk \
examples/butane_4/cleanOutput.bash \
examples/butane_4/runButaneResults.sh \