aboutsummaryrefslogtreecommitdiff
path: root/biology/psi88
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-18 16:23:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-18 16:23:08 +0000
commitbd36806845ba6da07fb4f4371526fef64fd38cfe (patch)
tree637e1c49ae8aabbc9d9f071d68c7e5a64d49ca8d /biology/psi88
parent1f7cb7e82974a9ce6712a8c67ecbd008df3ddd8f (diff)
downloadports-bd36806845ba6da07fb4f4371526fef64fd38cfe.tar.gz
ports-bd36806845ba6da07fb4f4371526fef64fd38cfe.zip
USES=fortran, staging, miscellaneous cleanups.
Notes
Notes: svn path=/head/; revision=336845
Diffstat (limited to 'biology/psi88')
-rw-r--r--biology/psi88/Makefile47
-rw-r--r--biology/psi88/files/patch-aa98
2 files changed, 26 insertions, 119 deletions
diff --git a/biology/psi88/Makefile b/biology/psi88/Makefile
index 1ad02d6fd99f..7ae74c5ede95 100644
--- a/biology/psi88/Makefile
+++ b/biology/psi88/Makefile
@@ -12,41 +12,30 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Plotting wavefunctions (molecular orbitals) in 3D
-PLIST_FILES+= bin/PSI1 bin/PSICON bin/PSI2CT bin/PSI2HP bin/PSI2PS bin/PSI2 \
+USES= fortran
+MAKE_ARGS= BIN=${STAGEDIR}${PREFIX}/bin
+PLIST_FILES= bin/PSI1 bin/PSICON bin/PSI2CT bin/PSI2HP bin/PSI2PS bin/PSI2 \
bin/PREPLOT bin/preplot bin/rpsi1 bin/rpsi2 bin/rpsicon
PORTDOCS= README psi88.doc
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-USE_FORTRAN= yes
-
-pre-patch:
- ${MV} ${WRKSRC}/src/makefile ${WRKSRC}/src/Makefile
-
post-patch:
- @${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g' -e 's+%%FFLAGS%%+${FFLAGS}+g' -e 's+%%LOCALBASE%%+${LOCALBASE}+g' -e 's+%%PREFIX%%+${PREFIX}+g' ${WRKSRC}/src/Makefile
-
-pre-build:
- ${CP} ${FILESDIR}/Makefile.top ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/f77/$${FC}/' -e 's/LFLAGS/LDFLAGS/' \
+ ${WRKSRC}/src/makefile
+ @${CP} ${FILESDIR}/Makefile.top ${WRKSRC}/Makefile
post-install:
- ${LN} -s ${PREFIX}/bin/PSI2PS ${PREFIX}/bin/PSI2
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/preplot ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/rpsi1 ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/rpsi2 ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/rpsicon ${PREFIX}/bin/
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/psi88.doc ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/* ${EXAMPLESDIR}
-.endif
-
-.include <bsd.port.post.mk>
+ ${LN} -s PSI2PS ${STAGEDIR}${PREFIX}/bin/PSI2
+ ${INSTALL_SCRIPT} ${WRKSRC}/unix/preplot ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/unix/rpsi1 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/unix/rpsi2 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/unix/rpsicon ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/psi88.doc ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/biology/psi88/files/patch-aa b/biology/psi88/files/patch-aa
index 0a99544babac..5f429958964b 100644
--- a/biology/psi88/files/patch-aa
+++ b/biology/psi88/files/patch-aa
@@ -1,42 +1,28 @@
---- src/Makefile.orig Sat May 25 04:04:15 1991
-+++ src/Makefile Tue Jan 9 11:30:09 2007
-@@ -27,11 +27,11 @@
- # level and when it is working, increase the optimization level. So far
- # optimization has never caused problems with this program.
+--- src/makefile.orig
++++ src/makefile
+@@ -29,9 +29,6 @@
#
--# SGI 4D series flags
-+# FreeBSD
+ # SGI 4D series flags
#
-f77 = f77
-FFLAGS = -w0 -O4 -G 64
-LFLAGS = -lfastm -lfpe -s
-+FC = %%FC%%
-+FFLAGS = %%FFLAGS%%
-+#LFLAGS = -lfastm -lfpe -s
#
# SUN Sparc series flags version 1.3 or later compiler
#
-@@ -60,12 +60,12 @@
+@@ -60,7 +57,6 @@
# Place your G88/G90 util library definition here if you wish to
# compile chk2psi
#
-G90LIB = /usr/people/frisch/g90/libg90.a
-+#G90LIB = /usr/people/frisch/g90/libg90.a
#
# define the directory where the executables will reside
# usually /usr/local/bin or ~/bin to put it in your own directory
- #
--BIN = /usr/local/bin
-+BIN = %%PREFIX%%/bin
- #
- #**** Add PSI2 to this and the install lists if you have a user defined
- # Plotting library to plot to the screen, also remove any which you
-@@ -84,13 +84,15 @@
+@@ -84,13 +80,13 @@
#######################################################################
#
- all: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
-+# all: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
+ all: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT $(EXTRAS)
#
@@ -44,88 +30,20 @@
# depending on where you decide to put it (/usr/local/bin for instance)
#
-install: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
-+#install: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
+install: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT $(EXTRAS)
mv PSI1 $(BIN)
chmod +rx $(BIN)/PSI1
mv PSICON $(BIN)
-@@ -99,71 +101,71 @@
+@@ -99,8 +95,6 @@
chmod +rx $(BIN)/PREPLOT
mv PSI2* $(BIN)
chmod +rx $(BIN)/PSI2*
- mv chk2psi $(BIN)
- chmod +rx $(BIN)/chk2psi
-+# mv chk2psi $(BIN)
-+# chmod +rx $(BIN)/chk2psi
#
# This is the Density matrix generation program (PSI1/88)
- #
- PSI1: psi1.f
-- f77 $(FFLAGS) psi1.f -o PSI1 $(LFLAGS)
-+ %%FC%% $(FFLAGS) psi1.f -o PSI1 $(LFLAGS)
-
- #
- # This is the contour generation program (PSICON/88)
- #
- PSICON: psicon.f
-- f77 $(FFLAGS) psicon.f -o PSICON $(LFLAGS)
-+ %%FC%% $(FFLAGS) psicon.f -o PSICON $(LFLAGS)
-
- #
- # This is for the plotting routine (PSI2/88) to a user defined graphics lib
- #
- PSI2: psi2.f
-- f77 $(FFLAGS) psi2.f -o PSI2 $(GRLIBS) $(LFLAGS)
-+ %%FC%% $(FFLAGS) psi2.f -o PSI2 $(GRLIBS) $(LFLAGS)
-
- #
- # This is for the plotting routine set up to plot to a GKS device
- # gksplot.f is a gks library that SHOULD work on any machine.....
- #
- PSI2GKS: psi2.f gksplot.f
-- f77 $(FFLAGS) psi2.f gksplot.f -o PSI2GKS $(LFLAGS) $(GKSLIB)
-+ %%FC%% $(FFLAGS) psi2.f gksplot.f -o PSI2GKS $(LFLAGS) $(GKSLIB)
-
- #
- # This is for the plotting routine set up to plot to a ChemText Metafile
- #
- PSI2CT: psi2.f ctplot.f
-- f77 $(FFLAGS) psi2.f ctplot.f -o PSI2CT $(LFLAGS)
-+ %%FC%% $(FFLAGS) psi2.f ctplot.f -o PSI2CT $(LFLAGS)
-
- #
- # This is for the plotting routine set up to plot to a PostScript device
- # psplot.f is a postscript library that SHOULD work on any machine.....
- #
- PSI2PS: psi2.f psplot.f
-- f77 $(FFLAGS) psi2.f psplot.f -o PSI2PS $(LFLAGS)
-+ %%FC%% $(FFLAGS) psi2.f psplot.f -o PSI2PS $(LFLAGS)
-
- #
- # This is for the plotting routine set up to plot to a HP plotter
- # hpplot.f is a HP plotter library that SHOULD work on any machine.....
- #
- PSI2HP: psi2.f hpplot.f
-- f77 $(FFLAGS) psi2.f hpplot.f -o PSI2HP $(LFLAGS)
-+ %%FC%% $(FFLAGS) psi2.f hpplot.f -o PSI2HP $(LFLAGS)
-
- #
- # This is a program to convert MOPAC .GPT files (using the graph keyword)
- # to PSI/88 input files.
- #
- PREPLOT: preplot.f
-- f77 $(FFLAGS) preplot.f -o PREPLOT $(LFLAGS)
-+ %%FC%% $(FFLAGS) preplot.f -o PREPLOT $(LFLAGS)
-
- #
- # This is a program to read checkpoint files -
- #
- chk2psi: chk2psi.f $(G90LIB)
-- f77 $(FFLAGS) chk2psi.f $(G90LIB) -o chk2psi $(LFLAGS)
-+ %%FC%% $(FFLAGS) chk2psi.f $(G90LIB) -o chk2psi $(LFLAGS)
-
- #
+@@ -164,6 +158,6 @@
# Clean up when done
#
clean :