aboutsummaryrefslogtreecommitdiff
path: root/biology/py-biom-format
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2020-09-24 19:31:43 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2020-09-24 19:31:43 +0000
commitf244f722da75787b1024d6b6507e173cb15d922a (patch)
tree7a7b9d1d58521812dc0cc60d8c0bb92994cd4af3 /biology/py-biom-format
parent381269f441ae66764c99686dd94196c42ac6f523 (diff)
downloadports-f244f722da75787b1024d6b6507e173cb15d922a.tar.gz
ports-f244f722da75787b1024d6b6507e173cb15d922a.zip
biology/py-biom-format: Restore in preparation for an update to v2.1.8
Version 2.1.8 supports python 3
Notes
Notes: svn path=/head/; revision=549943
Diffstat (limited to 'biology/py-biom-format')
-rw-r--r--biology/py-biom-format/Makefile42
-rw-r--r--biology/py-biom-format/distinfo3
-rw-r--r--biology/py-biom-format/pkg-descr19
3 files changed, 64 insertions, 0 deletions
diff --git a/biology/py-biom-format/Makefile b/biology/py-biom-format/Makefile
new file mode 100644
index 000000000000..d81fb8a2b85a
--- /dev/null
+++ b/biology/py-biom-format/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= biom-format
+PORTVERSION= 2.1.7
+PORTREVISION= 3
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Biological Observation Matrix (BIOM) Format Project
+
+LICENSE= BSD3CLAUSE
+
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0.16.0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.13.0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.20.0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>=2.2.0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
+
+USES= python:-3.6
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyqi>0:devel/py-pyqi@${PY_FLAVOR}
+.endif
+
+post-extract:
+ ${RM} -r ${WRKSRC}/tests
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/biom/*.so
+
+.include <bsd.port.post.mk>
diff --git a/biology/py-biom-format/distinfo b/biology/py-biom-format/distinfo
new file mode 100644
index 000000000000..b705caff7e40
--- /dev/null
+++ b/biology/py-biom-format/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538769748
+SHA256 (biom-format-2.1.7.tar.gz) = b47e54282ef13cddffdb00aea9183a87175a2372c91a915259086a3f444c42f4
+SIZE (biom-format-2.1.7.tar.gz) = 11820666
diff --git a/biology/py-biom-format/pkg-descr b/biology/py-biom-format/pkg-descr
new file mode 100644
index 000000000000..41a8b5b6ca30
--- /dev/null
+++ b/biology/py-biom-format/pkg-descr
@@ -0,0 +1,19 @@
+The BIOM file format (canonically pronounced biome) is designed to be a
+general-use format for representing biological sample by observation contingency
+tables. BIOM is a recognized standard for the Earth Microbiome Project and is a
+Genomics Standards Consortium supported project.
+
+The BIOM format is designed for general use in broad areas of comparative
+-omics. For example, in marker-gene surveys, the primary use of this format is
+to represent OTU tables: the observations in this case are OTUs and the matrix
+contains counts corresponding to the number of times each OTU is observed in
+each sample. With respect to metagenome data, this format would be used to
+represent metagenome tables: the observations in this case might correspond to
+SEED subsystems, and the matrix would contain counts corresponding to the number
+of times each subsystem is observed in each metagenome. Similarly, with respect
+to genome data, this format may be used to represent a set of genomes: the
+observations in this case again might correspond to SEED subsystems, and the
+counts would correspond to the number of times each subsystem is observed in
+each genome.
+
+WWW: http://biom-format.org/