aboutsummaryrefslogtreecommitdiff
path: root/biology/py-fastTSNE
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-15 08:58:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-15 08:58:05 +0000
commita8badfa6b1a9a72595012f296b2706241e1f7fdb (patch)
treef9471c32871b212eaad2d6c05e9b85dff1f3870a /biology/py-fastTSNE
parent0f5694db950190056be7b7d190a4604379eeb95e (diff)
downloadports-a8badfa6b1a9a72595012f296b2706241e1f7fdb.tar.gz
ports-a8badfa6b1a9a72595012f296b2706241e1f7fdb.zip
Notes
Diffstat (limited to 'biology/py-fastTSNE')
-rw-r--r--biology/py-fastTSNE/Makefile25
-rw-r--r--biology/py-fastTSNE/distinfo3
-rw-r--r--biology/py-fastTSNE/files/patch-setup.py12
-rw-r--r--biology/py-fastTSNE/pkg-descr6
4 files changed, 46 insertions, 0 deletions
diff --git a/biology/py-fastTSNE/Makefile b/biology/py-fastTSNE/Makefile
new file mode 100644
index 000000000000..6314aca0a910
--- /dev/null
+++ b/biology/py-fastTSNE/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= fastTSNE
+DISTVERSION= 0.2.13
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast, parallel implementations of t-SNE
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ libomp.so:devel/openmp
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}numba>=0.38.1:devel/py-numba@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.20.0:science/py-scikit-learn@${PY_FLAVOR}
+
+USES= localbase:ldflags python:3.5+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/biology/py-fastTSNE/distinfo b/biology/py-fastTSNE/distinfo
new file mode 100644
index 000000000000..1d05309d308e
--- /dev/null
+++ b/biology/py-fastTSNE/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544862153
+SHA256 (fastTSNE-0.2.13.tar.gz) = c602acf5e61f80bdda1bdfe91838ec89d7fdbdbb072e54c0d8da31c35fc964a0
+SIZE (fastTSNE-0.2.13.tar.gz) = 687321
diff --git a/biology/py-fastTSNE/files/patch-setup.py b/biology/py-fastTSNE/files/patch-setup.py
new file mode 100644
index 000000000000..d2bb2d1d4607
--- /dev/null
+++ b/biology/py-fastTSNE/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2018-12-15 08:37:12 UTC
++++ setup.py
+@@ -87,7 +87,8 @@ extensions = [
+ ]
+
+ # Check if we have access to FFTW3 and if so, use that implementation
+-if has_c_library('fftw3'):
++# has_c_library fails to use CFLAGS: https://github.com/pavlin-policar/fastTSNE/issues/43
++if True or has_c_library('fftw3'):
+ lm_opt = '/lm' if IS_WINDOWS else '-lm'
+ fftw3_opt = '/lfftw3' if IS_WINDOWS else '-lfftw3'
+ extensions.append(
diff --git a/biology/py-fastTSNE/pkg-descr b/biology/py-fastTSNE/pkg-descr
new file mode 100644
index 000000000000..5d168f46e2d6
--- /dev/null
+++ b/biology/py-fastTSNE/pkg-descr
@@ -0,0 +1,6 @@
+Fast, parallel implementations of t-SNE allows, for example, in one case
+to visualize 160,796 single cell transcriptomes from the mouse nervous system
+computed in under 2 minutes using FFT accelerated interpolation and approximate
+nearest neighbors.
+
+WWW: https://github.com/pavlin-policar/fastTSNE