aboutsummaryrefslogtreecommitdiff
path: root/biology/py-gffutils
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-19 02:06:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-19 02:06:53 +0000
commit4daaa701d3b3232df135b7033b0b625a0c3f3697 (patch)
tree88dddf4df0c6cc5db74da3e6b7fa3047a14e472d /biology/py-gffutils
parentac2652a87788097f19838182299cfe498b1a1d0f (diff)
downloadports-4daaa701d3b3232df135b7033b0b625a0c3f3697.tar.gz
ports-4daaa701d3b3232df135b7033b0b625a0c3f3697.zip
New port: biology/py-gffutils: Work with GFF and GTF files in a flexible database framework
Notes
Notes: svn path=/head/; revision=482400
Diffstat (limited to 'biology/py-gffutils')
-rw-r--r--biology/py-gffutils/Makefile25
-rw-r--r--biology/py-gffutils/distinfo3
-rw-r--r--biology/py-gffutils/pkg-descr7
3 files changed, 35 insertions, 0 deletions
diff --git a/biology/py-gffutils/Makefile b/biology/py-gffutils/Makefile
new file mode 100644
index 000000000000..4cd1202fefe7
--- /dev/null
+++ b/biology/py-gffutils/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= gffutils
+DISTVERSION= 0.9
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Work with GFF and GTF files in a flexible database framework
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argcomplete>0:devel/py-argcomplete@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}argh>0:devel/py-argh@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyfaidx>0:biology/py-pyfaidx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>0:devel/py-simplejson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/biology/py-gffutils/distinfo b/biology/py-gffutils/distinfo
new file mode 100644
index 000000000000..c6d2c3d2ee23
--- /dev/null
+++ b/biology/py-gffutils/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539913631
+SHA256 (gffutils-0.9.tar.gz) = e1b0bf2b422ec3491be13d77bf7baf71d274abd844e8f8b6c1217a95b236218b
+SIZE (gffutils-0.9.tar.gz) = 1537395
diff --git a/biology/py-gffutils/pkg-descr b/biology/py-gffutils/pkg-descr
new file mode 100644
index 000000000000..84768b7458ac
--- /dev/null
+++ b/biology/py-gffutils/pkg-descr
@@ -0,0 +1,7 @@
+gffutils is a Python package for working with and manipulating the GFF and GTF
+format files typically used for genomic annotations. Files are loaded into a
+sqlite3 database, allowing much more complex manipulation of hierarchical
+features (e.g., genes, transcripts, and exons) than is possible with plain-text
+methods alone.
+
+WWW: https://github.com/daler/gffutils