aboutsummaryrefslogtreecommitdiff
path: root/biology/py-macs2/files
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2020-04-14 12:13:55 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2020-04-14 12:13:55 +0000
commitbad93f9f141866746c755c7acb4dfc41f8030628 (patch)
tree697cd2ebb6baeb0b67b19b5ab83f8d91f5d0b6a5 /biology/py-macs2/files
parente605d0d939f49aec491e7ee7ee6b32f12ea0a7f5 (diff)
Notes
Diffstat (limited to 'biology/py-macs2/files')
-rw-r--r--biology/py-macs2/files/patch-setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/biology/py-macs2/files/patch-setup.py b/biology/py-macs2/files/patch-setup.py
new file mode 100644
index 000000000000..3434e1146357
--- /dev/null
+++ b/biology/py-macs2/files/patch-setup.py
@@ -0,0 +1,25 @@
+--- setup.py.orig 2020-04-12 14:46:03 UTC
++++ setup.py
+@@ -26,22 +26,6 @@ def main():
+
+ cwd = os.path.abspath(os.path.dirname(__file__))
+
+- # install required numpy
+- p = subprocess.call([sys.executable, "-m", 'pip', 'install', f'numpy{numpy_requires}'],cwd=cwd)
+- if p != 0:
+- # Could be due to a too old pip version and build isolation, check that
+- try:
+- # Note, pip may not be installed or not have been used
+- import pip
+- if LooseVersion(pip.__version__) < LooseVersion('18.0.0'):
+- raise RuntimeError("Installing requirements failed. Possibly due "
+- "to `pip` being too old, found version {}, "
+- "needed is >= 18.0.0.".format(pip.__version__))
+- else:
+- raise RuntimeError("Installing requirements failed!")
+- except ImportError:
+- raise RuntimeError("Installing requirement failed! `pip` has to be installed!")
+-
+ from numpy import get_include as numpy_get_include
+ numpy_include_dir = [numpy_get_include()]
+