aboutsummaryrefslogtreecommitdiff
path: root/biology/py-macs2
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2017-12-02 20:46:28 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2017-12-02 20:46:28 +0000
commit9956039fdd1611d65ef0db3af37c29b4e66902d0 (patch)
tree0a6bd8d5ff15762dafd691285ae5b6355ca998ff /biology/py-macs2
parent429caa13b591029b4e5e374d0369122545e86a01 (diff)
downloadports-9956039fdd1611d65ef0db3af37c29b4e66902d0.tar.gz
ports-9956039fdd1611d65ef0db3af37c29b4e66902d0.zip
[new port] biology/py-macs2: Analysis of chromatin immunoprecipitation (ChIP) sequences
Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D13322
Notes
Notes: svn path=/head/; revision=455383
Diffstat (limited to 'biology/py-macs2')
-rw-r--r--biology/py-macs2/Makefile31
-rw-r--r--biology/py-macs2/distinfo3
-rw-r--r--biology/py-macs2/pkg-descr6
3 files changed, 40 insertions, 0 deletions
diff --git a/biology/py-macs2/Makefile b/biology/py-macs2/Makefile
new file mode 100644
index 000000000000..5fd3fa1567ae
--- /dev/null
+++ b/biology/py-macs2/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= macs2
+PORTVERSION= 2.1.0.p20170505
+CATEGORIES= biology python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Analysis of chromatin immunoprecipitation (ChIP) sequences
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython distutils
+
+USE_GITHUB= yes
+GH_ACCOUNT= taoliu
+GH_PROJECT= MACS
+GH_TAGNAME= 6946b2f
+
+PYSETUP= setup_w_cython.py
+
+post-stage:
+ ${STRIP_CMD} \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/MACS2/*.so \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/MACS2/*/*.so
+
+.include <bsd.port.mk>
diff --git a/biology/py-macs2/distinfo b/biology/py-macs2/distinfo
new file mode 100644
index 000000000000..e6e69444c3c6
--- /dev/null
+++ b/biology/py-macs2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512241922
+SHA256 (taoliu-MACS-2.1.0.p20170505-6946b2f_GH0.tar.gz) = c6e4fb8b69b955134399fcdfc075cea5fbc29fabbc46cc4e9acdedeb1174fcfd
+SIZE (taoliu-MACS-2.1.0.p20170505-6946b2f_GH0.tar.gz) = 159560613
diff --git a/biology/py-macs2/pkg-descr b/biology/py-macs2/pkg-descr
new file mode 100644
index 000000000000..c101167de737
--- /dev/null
+++ b/biology/py-macs2/pkg-descr
@@ -0,0 +1,6 @@
+MACS is a tool for chromatin immunoprecipitation (ChIP) sequence analysis.
+MACS empirically models the length of the sequenced ChIP fragments, which
+tend to be shorter than sonication or library construction size estimates,
+and uses it to improve the spatial resolution of predicted binding sites.
+
+WWW: https://github.com/taoliu/MACS