aboutsummaryrefslogtreecommitdiff
path: root/biology/py-pysam
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-05-06 06:05:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-05-06 06:05:24 +0000
commit9ca211c1ffa8212e7c9e781a7aa1070bd977541b (patch)
tree69193bcda9a19ee6090f464aa2223270e49b2543 /biology/py-pysam
parenta2c4a5c233c0693a18d4e2e27663be4b4b006636 (diff)
downloadports-9ca211c1ffa8212e7c9e781a7aa1070bd977541b.tar.gz
ports-9ca211c1ffa8212e7c9e781a7aa1070bd977541b.zip
pysam is a lightweight wrapper of the htslib C-API and provides facilities to
read and write SAM/BAM/VCF/BCF/BED/GFF/GTF/FASTA/FASTQ files as well as access to the command line functionality of the samtools and bcftools packages. The module supports compression and random access through indexing. This module provides a low-level wrapper around the htslib C-API as using cython and a high-level API for convenient access to the data within standard genomic file formats. WWW: https://pypi.python.org/pypi/pysam PR: 218745 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=440231
Diffstat (limited to 'biology/py-pysam')
-rw-r--r--biology/py-pysam/Makefile22
-rw-r--r--biology/py-pysam/distinfo3
-rw-r--r--biology/py-pysam/files/patch-setup.py11
-rw-r--r--biology/py-pysam/pkg-descr10
4 files changed, 46 insertions, 0 deletions
diff --git a/biology/py-pysam/Makefile b/biology/py-pysam/Makefile
new file mode 100644
index 000000000000..4ed2c427ff1d
--- /dev/null
+++ b/biology/py-pysam/Makefile
@@ -0,0 +1,22 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pysam
+PORTVERSION= 0.11
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python module for reading, manipulating and writing genomic data sets
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= cython:lang/cython
+RUN_DEPENDS= cython:lang/cython
+
+USES= gmake python:2
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/biology/py-pysam/distinfo b/biology/py-pysam/distinfo
new file mode 100644
index 000000000000..8386380d3fdb
--- /dev/null
+++ b/biology/py-pysam/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492580723
+SHA256 (pysam-0.11.tar.gz) = 815c8a6150c5fe21df227e730dd57e4212984ae568854fcc5873e243072dcbad
+SIZE (pysam-0.11.tar.gz) = 2425484
diff --git a/biology/py-pysam/files/patch-setup.py b/biology/py-pysam/files/patch-setup.py
new file mode 100644
index 000000000000..d82a8bbbefcf
--- /dev/null
+++ b/biology/py-pysam/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2017-04-19 05:48:10 UTC
++++ setup.py
+@@ -60,7 +60,7 @@ def run_configure(option):
+
+
+ def run_make_print_config():
+- stdout = subprocess.check_output(["make", "-s", "print-config"])
++ stdout = subprocess.check_output(["gmake", "-s", "print-config"])
+ if IS_PYTHON3:
+ stdout = stdout.decode("ascii")
+
diff --git a/biology/py-pysam/pkg-descr b/biology/py-pysam/pkg-descr
new file mode 100644
index 000000000000..3278584b89c1
--- /dev/null
+++ b/biology/py-pysam/pkg-descr
@@ -0,0 +1,10 @@
+pysam is a lightweight wrapper of the htslib C-API and provides facilities to
+read and write SAM/BAM/VCF/BCF/BED/GFF/GTF/FASTA/FASTQ files as well as access
+to the command line functionality of the samtools and bcftools packages. The
+module supports compression and random access through indexing.
+
+This module provides a low-level wrapper around the htslib C-API as using
+cython and a high-level API for convenient access to the data within standard
+genomic file formats.
+
+WWW: https://pypi.python.org/pypi/pysam