aboutsummaryrefslogtreecommitdiff
path: root/biology/python-nexus
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-29 13:39:14 +0000
committerWen Heping <wen@FreeBSD.org>2009-12-29 13:39:14 +0000
commit47dea29df882c392eb6d643610e85f81303c8683 (patch)
treecfe3fa5a68aa11c9caa8dd3874484cee728945a3 /biology/python-nexus
parentc3145e81b2e42a7a8a9c0ca9dfb5320acc12d019 (diff)
downloadports-47dea29df882c392eb6d643610e85f81303c8683.tar.gz
ports-47dea29df882c392eb6d643610e85f81303c8683.zip
Notes
Diffstat (limited to 'biology/python-nexus')
-rw-r--r--biology/python-nexus/Makefile19
-rw-r--r--biology/python-nexus/distinfo3
-rw-r--r--biology/python-nexus/pkg-descr4
-rw-r--r--biology/python-nexus/pkg-plist8
4 files changed, 34 insertions, 0 deletions
diff --git a/biology/python-nexus/Makefile b/biology/python-nexus/Makefile
new file mode 100644
index 000000000000..dc7b19c63936
--- /dev/null
+++ b/biology/python-nexus/Makefile
@@ -0,0 +1,19 @@
+# Ports collection makefile for: python-nexus
+# Date created: 29 Dec, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= python-nexus
+PORTVERSION= 0.6d
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= A generic nexus file format reader for python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/biology/python-nexus/distinfo b/biology/python-nexus/distinfo
new file mode 100644
index 000000000000..ac019c537935
--- /dev/null
+++ b/biology/python-nexus/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-nexus-0.6d.tar.gz) = 79b804e6165823c9b09651c9c318eb30
+SHA256 (python-nexus-0.6d.tar.gz) = 2290c35a02879c8f91047638274dd659dc08c694eca2dbdbd7d1907c891c2718
+SIZE (python-nexus-0.6d.tar.gz) = 22899
diff --git a/biology/python-nexus/pkg-descr b/biology/python-nexus/pkg-descr
new file mode 100644
index 000000000000..dfb734c054ac
--- /dev/null
+++ b/biology/python-nexus/pkg-descr
@@ -0,0 +1,4 @@
+python-nexus is a generic nexus (phylogenetics) file format(.nex, .trees)
+reader for python.
+
+WWW: http://simon.net.nz/articles/python-nexus
diff --git a/biology/python-nexus/pkg-plist b/biology/python-nexus/pkg-plist
new file mode 100644
index 000000000000..423f2df09b1e
--- /dev/null
+++ b/biology/python-nexus/pkg-plist
@@ -0,0 +1,8 @@
+bin/nexus_randomise.py
+bin/nexus_calc_missings.py
+bin/nexus_remove_uniquechars.py
+bin/nexus_deinterleave.py
+bin/nexus_detranslate.py
+bin/nexus_remove_constantchars.py
+bin/nexus_combine_nexus.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%